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Introduction

WELCOME!
This is the User’s Guide for Deko500, a full-color video character generator
from Pinnacle Systems, Inc. Based on the Windows NT operating system,
Deko500 offers unprecedented performance in a broadcast-quality character
generator, including:

� The highest picture quality available for television graphics

� The ease of use and networking capabilities of Windows NT

� The power of a word processor, a page layout program and a
“slide show” presentation program, in a single application

Like a word processor, Deko500 offers a variety of tools for typing text and for
selecting fonts and styles.

Like a page layout program, Deko500 allows total flexibility in positioning text
and full-color graphic elements on the screen.

Like a presentation program, Deko500 plays back a series of graphic pages
using a wide range of real-time effects, including rolls and crawls.

We think you’ll be pleased with Deko500’s quality, power and flexibility. Our
goal is to make Deko500 the number one video character generator. If you have
any suggestions for features to include in future software releases, we would
very much like to hear from you. See How to Contact Pinnacle Systems, Inc.,
page 7.
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HOW TO USE THIS MANUAL

The Deko500 User’s Guide is a reference manual that describes the operation of
Deko500. The User’s Guide is derived largely from Deko500’s on-line Help
screens—you’ll find pretty much the same information in both places.

One difference between this manual and the on-line Help is how we define new
terms and keywords. In the on-line Help, new terms appear in green—you click
on a term with the mouse to see its definition. In the User’s Guide, there is no
green and no mouse. So, whenever a new term is defined, we show it in bold
italic type.

Please refer to the Glossary for a definition.

You need not read the User’s Guide cover to cover. Most chapters are arranged
as a series of step-by-step “To do” instructions, such as “To add an edge” or “To
rotate selected text.” A good approach is to read through the Table of Contents
to get an idea of Deko500’s capabilities, then refer to specific sections as
necessary.

We strongly suggest, however, that you read the chapter, An Overview of
Deko500. It provides an overall description of Deko500’s user interface and
operating philosophy.

Hardware issues, including installation and setup of Deko500, are covered
separately, in the Deko500 Installation Guide.

If you’re familiar with other Windows applications like Word or WordPerfect,
we think you’ll find using Deko500 easy and natural. If you know Windows, but
not Windows NT, you have nothing to worry about—their operation is almost
identical.

If you’re new to Windows, we suggest that you pick up a book on the subject to
familiarize yourself with the basic Windows concepts. For the most part, this
User’s Guide assumes a working knowledge of Windows.
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HOW TO CONTACT PINNACLE SYSTEMS
Pinnacle Systems, Inc.
280 N. Bernardo
Mountain View, CA 94043

What to do before you call:
Whenever you contact Pinnacle Systems for technical support, please have the
following information available:

Product name and software version number

Product serial number (in the Help menu, choose About)

Type of computer hardware you are using

Precise description of problem and attempted solutions

Exact wording of any error messages

Pinnacle Systems Technical Support by Phone:
Pinnacle Systems technical support for the Deko product line is available 8:00am
to 8:00pm Eastern time, Monday through Friday.

Phone: (650) 237-1800

Information and Technical Support on the Internet:
For the latest information on Deko upgrades, visit our website at:
www.pinnaclesys.com.

Our e-mail address for technical support is:
broadcast-support@pinnaclesys.com.
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STARTING WINDOWS NT

To start Windows NT:
1. Turn on the power to the PC. The computer monitor shows a series of diagnostic

screens, then displays the Windows NT startup screen. Press Ctrl+Alt+Delete to
log on.

2. Enter your user name and password, then press Enter. If you don’t have a user
name, log on as user Deko500. This user name is installed at the factory and
does not require a password.

Notes Once you log on, you will see the Windows NT Program
Manager. This is the main screen of Windows NT, from which
you can launch any application program, including Deko500.
You must be privileged as a System Administrator or Power
User to run Deko500. For more information about Windows
NT, refer to the Windows NT documentation supplied with
Deko500.

STARTING DEKO500

To start Deko500:
1. Close or minimize windows, if necessary, to access the start-up screen

of your desktop.

2. Do one of the following:
� Double-click the Deko500 program icon.

� Hold Ctrl and press Tab as necessary to activate the Deko500
program group, use the cursor keys to highlight the Deko500
program icon, then press Enter.

To start Deko500 automatically, every time you boot up
Windows NT:

1. From the Options menu, choose Preferences.

2. Choose Common at the top of the Preferences dialog box.

3. Check On re-boot, automatically log on to NT.

4. Enter your user password.

5. Press Enter or click OK.

Note To use the auto-login feature, you must be privileged as a
System Administrator and must also supply a password. Please
refer to the Windows NT documentation for details.
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To start Deko500 automatically, every time you log on:
In the Windows NT Program Manager, hold Ctrl down and drag
the Deko500 program icon into the Startup group. Refer to your
Windows NT documentation for more information.

EXITING DEKO500

To exit Deko500 and return to the Program Manager:
Do one of the following:
� Double-click the control icon at the left end of the Deko500

program title bar, or choose Close from the control icon menu.

� From the File menu, choose Exit.

To have Deko500 prompt before exiting:
1. From the Options menu, choose Preferences.

2. Choose Prompts at the top of the Preferences dialog box.

3. Check Prompt before exiting Deko500.

To use other applications without exiting Deko500:
1. Do one of the following:

� Click the minimize button in the upper-right corner of the Deko500
application window.

� Choose Minimize from the control icon menu.

� Hold Alt down and press Tab repeatedly to switch to other open
applications.

2. When you are ready to return to Deko500, double-click the Deko500
icon.

EXITING WINDOWS NT

To log off from Windows NT:
1. Exit Deko500.

2. In the Windows NT Program Manager, do one of the following:
� Press Ctrl+Alt+Delete, then choose Logoff.

� Double-click the control icon at the left end of the Program
Manager title bar, then choose Log off.

� From the File menu, choose Logoff.

3. Click OK to log off. After you log off, Windows NT remains active,
allowing you or another user to log back on. Shared files are still
accessible from other networked workstations.
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To shut down Windows NT:
1. Exit Deko500.

2. In the Windows NT Program Manager, do one of the following:
� Press Ctrl+Alt+Delete, then choose Shutdown.

� Double-click the control icon at the left end of the Program
Manager title bar, then choose Shutdown.

� From the File menu, choose Shutdown.

3. Click OK to shut down Windows NT. Don’t turn off the power to your
computer until a message on the screen tells you it’s OK to do so. Once
shut down, Windows NT must be restarted before you or another user
can log back on. Shared files are not accessible from other networked
workstations.
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Overview of Deko500

THE DEKO500 DESKTOP

All creation and playback of Deko500 graphics is done using the mouse and
keyboard to interact with the various controls and windows on Deko500’s
desktop.

The appearance of the desktop depends on the current layout, as selected from
the Window menu.

ABOUT GRAPHIC FILES

The main function of Deko500 is the creation and display of graphic files. You
create a Deko500 graphic, including text and background elements, in a
Program window. Once created, a graphic may be saved on disk in a graphic
file.

A graphic consists of one or more layers and a background. Each layer can be
text or a geometric shape—a rectangle or an ellipse. See Graphics and Layers.

Each character of text is rendered in a particular style, which specifies its font
and look. Each geometric shape is rendered in a particular look. See Creating
Styles.

Deko500 provides a variety of tools for typing, justifying, positioning, sizing
and otherwise editing text and shapes. See Composing Text.

Graphic files may be recalled from disk individually—“opened,” in Windows
terminology. You can play back a series of graphic files by entering them into a
sequence. See Effects and Sequences.

THE PROGRAM WINDOW

All graphics are created in a Program window.

The Program window shows the current on-air graphic. The contents of this
window match Deko500’s video output, with the addition of a cursor, safe-title
lines and other markers. There is only one Program window.



Creating and Saving Graphics 12

Deko500 User’s Guide

CREATING A GRAPHIC

To create a Deko500 graphic:
1. Activate a Program window. If desired, clear any previous graphic

by pressing F8 once, or press F8 twice to clear the background,
too.

2. Use the cursor keys or click the mouse to position the text cursor.

3. Type any desired text.

4. Use any of Deko500’s compositional tools to select fonts and
styles, add geometric shape or text layers, position layers, etc.

5. Save the graphic, by choosing Save Graphic As (F12) from the File
menu.

SAVING A GRAPHIC FILE

To save a graphic under a new name:
1. Activate the graphic window (F5).

2. From the File menu, choose Save Graphic As (F12).

3. In the dialog box, navigate to the drive and directory where you
will store the file.

4. Type a new file name in the File Name text box, then click OK or
press Enter.

Note Deko500 automatically attaches “.dko” to the file name. Do
not type a different extension.
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To save a modified graphic:
1. Activate the graphic window.

2. From the File menu, choose Save Graphic (Ctrl+S or Alt+F12) to
replace the previous version of the .dko file.

To save a graphic under a different video standard:
1. From the File menu choose Save Graphic As (F12).

2. In the Save Graphic As dialog box, choose Options.

3. Do one of the following:
� In the Video Standard text box, select NTSC.

� In the Video Standard text box, select PAL.

� In the Video Standard text box, select custom, then enter
Horizontal pixel and Vertical pixel values.

4. Click OK or press Enter.
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To specify whether or not to save character glyphs:
1. From the File menu choose Save Graphic As (F12).

2. In the Save Graphic As dialog box, choose Options.

3. Select whether to save graphic files with pre-rendered glyphs
Always, Never or If not already in pre-rendered style.

4. Click OK or press Enter.

Note Graphic files that include a large font or complicated look
occupy more disk space when saved with character glyphs, but
can be retrieved faster.

To save a fully rendered bitmap with a graphic file:
1. From the File menu choose Save Graphic As (F12).

2. In the Save Graphic As dialog box, choose Options.

3. Check Save rendered bitmap, for faster recall.

4. Click OK or press Enter.

Note Graphic files that are saved with pre-rendered bitmaps occupy
more disk space, but can be retrieved much faster.

To save a graphic with an automatic comment:
1. From the File menu choose Save Graphic As (F12).

2. In the Save Graphic As dialog box, choose Options.

3. Check Add automatic comment, based on text in file.

4. Click OK or press Enter. Deko500 will automatically fill in the
comment field with the content of the graphic’s first text field.

To use file compression when saving TIFF and Targa
files:

1. From the File menu choose Save Graphic As (F12).

2. In the Save Graphic As dialog box, choose Options.

3. Under When saving TIFF and Targa files, check Use file
compression.

4. Click OK or press Enter.

To save TIFF and Targa files with alpha channel:
1. From the File menu choose Save Graphic As (F12).

2. In the Save Graphic As dialog box, choose Options.

3. Under When saving TIFF and Targa files, check Save with alpha
channel (32-bit).

4. Click OK or press Enter.
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OPENING A GRAPHIC FILE

To open a graphic file:
1. From the File menu, choose Open (Ctrl+O or F9).

2. In the Open dialog box, navigate to the drive and directory that
contain the file.

3. Choose the file from the File Name list box or type the file name in
the File Name text box, then click OK or press Enter.

Notes The next time you call up the File Open dialog box, Deko500
will prompt you with the name of the next file in the current
directory. Use the cursor up and down keys to scroll through
other file names.

Deko500 can import several file types, including text files
(.txt), Windows Bitmap files (.bmp), TIFF files (.tif), Targa
files (.tga) JPEG files (.jpg), Graphics Factory stills (.gf)
videoDesigner stills (.tv), Kseries/ Presto ppic files (.20k), and
Pinnacle (.g) files created in FlashFile, Lightning or Genie.

Warning Unlike many Windows applications, Deko500 does not always
open a new window when you open a file. If a graphic
(Program) window is already open, Deko500 will open a
graphic into that window, replacing the previous file. Be sure
to save any modified file before opening another file in the
same window.

To browse for graphic files to add to a sequence:
1. Activate the Sequence window (F11).

2. Do one of the following:
� From the Sequence menu, choose Browse for Files (Ctrl+L).

� Select Browser from the View window (Ctrl+L).

3. Double-click a thumbnail to enter it into the sequence

To open a graphic recorded under a different aspect
ratio:

1. From the File menu, choose Open (Ctrl+O or F9).

2. In the dialog box, choose Options.

3. Choose one of the following in the File Open Options dialog box:

For native (.dko) files of non-native aspect ratio:
� Clip to fit.

Scales a 4 x 3 graphic to fit a 16 x 9 screen horizontally, but
chops off part of the top and bottom.
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Chops off part of the left and right sides of a 16 x 9 graphic,
leaving a 4 x 3 center.

� Pad to fit.

Centers a 4 x 3 graphic, padding the right and left sides.

Shrinks a 16 x 9 graphic to fit horizontally, padding the top
and bottom.

� Scale to fit.

Stretches a 4 x 3 graphic horizontally, but not vertically, to fit
the full 16 x 9 screen.

Compresses a 16 x 9 graphic horizontally, but not vertically,
to fit the 4 x 3 screen.

For non-native (not .dko) files:
� Scale to full screen

Adjusts width and height and does not maintain pixel aspect
ratio.

� Square pixels, preserve height

Adjusts width to maintain aspect ratio of pixels assumed to be
square.

� Square pixels, preserve width

Adjusts height to maintain aspect ratio of pixels assumed to be
square.

4. Click OK or press Enter.

5. In the Open dialog box, navigate to the drive and directory that
contain the file.

6. Choose the file from the File Name list box or type the file name in
the File Name text box, then click OK or press Enter.

Note Clip to fit and Pad to fit maintain the graphic’s original aspect
ratio. Scale to fit distorts it.

To re-open the graphic file in the active window:
From the File menu, choose Revert.
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To transfer a GF/Halo/Kseries/Presto image to
Deko500:

1. <Record> the GF/Halo image as a still or Kseries/Presto as ppic.

2. Insert a compatible disk formatted for DOS into one of the
GF/Halo drives.

3. <Do> dos export. Export the GF/Halo still to the DOS disk as a
DOS file with a .gf extension for GF or .20k for Kseries/Presto.

4. Remove the disk from the GF/Halo drive and insert it into a drive
on the PC running Deko500.

5. From the File menu, choose Open, then navigate to the drive and
directory that contain the.gf file or .20k file.

6. Choose the file from the File Name list box or type the file name in
the File Name text box, then click OK or press Enter.

Note You can reverse this process to transfer graphics from
Deko500 to GF/Halo.

Only graphic files (still, targa, tiff and dko, g and bmp) can be
shared. Text files are not compatible.

KEYING

Using Deko500’s built-in keyer, you can key text and graphics over live video.
Or, you can use Deko500’s linear key output to key text and graphics
downstream, using a switcher.

To turn Deko500’s keyer on:
1. Connect an input video signal to Deko500. See Video Inputs in the

Deko500 Installation Guide.

2. From the Options menu, choose Hardware Settings then Input
Selection, and select an input video source.

3. From the Channel menu, choose Keyer On.

To turn Deko500’s keyer off:
From the Channel menu, choose Keyer Off.

To output only the key of a graphic:
From the Channel menu, choose Show Key Output.

To output only the key of a graphic:
From the Channel menu, choose Show Key Output.
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FRAME GRABBING

To set grab options:
In the Channel menu, click Grab Options, then click to select or
de-select options from the drop-down menu. A checkmark next to
an option indicates that it is selected.

Grab With Key
Select to enable frame grabbing video input with key. This option
must be selected to enable fram grabbing of shaped input video.

Input Video Is Shaped
Select to enable frame grabbing of shaped input video. This
selection is not available if Grab With Key is not selected.

To grab a frame of video:
1. Connect an input signal to Deko500. See Video Inputs in the

Deko500 Installation Guide.

2. From the Channel menu, choose Frame Grab.

Note Use a digital input source for the highest quality frame
grabbing.

SUPPRESSING MOTION

To apply motion suppression when frame grabbing:
1. From the Channel Menu, choose Motion Suppress.

2. Check Motion Suppress When Grabbing.

To apply motion suppression to the current
background:

1. From the Channel Menu, choose Motion Suppress.

2. Check Motion Suppress Now.

To specify motion suppression options:
1. From the Channel Menu, choose Motion Suppress.

2. Do one of the following:
� Check Interpolate Scan Lines to specify interpolation between

every other scan line.

� Check Duplicate Scan Lines to specify duplication of every
other scan line.

3. Check either Preserve Field 1 (odd field) or Preserve Field 2 (even
field) to specify which field’s scan lines to interpolate or duplicate.
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Composing Text

SELECTING TEXT

To select a block of text:

Drag across, then down or up the text.

Use arrow keys (↑ → ↓ ←)  to move the cursor to the beginning or end
of the text block, then hold Shift and press arrow keys as necessary.

To select multiple blocks of text:

Hold Ctrl as you drag across, then down or up the text.

Choose Select More from the Edit menu. For each block of text, use
arrow keys (↑ → ↓ ←)  to move the cursor to the beginning or end of
the text block, then hold Shift and press arrow keys to select the block.

To select a word:

Double-click the word.

Use arrow keys (↑ → ↓ ←)  to move the cursor to the beginning or end
of the word, then hold Shift and press right or left arrow.

To select all text in a text field:

From the top left of the text, drag across, then down the text.

Press Insert and Tab to the text field, or choose Select Field from the
Edit menu.
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To select all text characters in a graphic:

Choose Select All (Crl+A) from the Edit menu.

To select all text characters in the current style:

Choose Select Style from the Edit menu.

To de-select text:

Click anywhere in the text field.

Press any arrow key (↑ → ↓ ←).

SELECTING A TYPEFACE

To select a typeface:
1. Select the text to which you will apply the new typeface. If no text

is selected, Deko500 applies changes to the current style.

2. Do one of the following:
� From the View menu, choose Browser, then choose Browse

Typefaces from the File menu.

� On the text bar, click the Typeface drop-down list box.

� In the Style window, choose Font, then click Browse.

� In the Style window, choose Font, then click the Typeface
drop-down list box.

3. Double-click a typeface on the browser or the drop-down list, or
type the name of the typeface in the text box.

Note If you select a custom typeface, Deko500 automatically sets
the font to the size at which no scaling will occur. You may
then select any font size.

To select a typeface from a graphic:
1. Move the text cursor immediately to the right of a character in the

desired typeface.

2. From the Text menu, choose Pick Font.

Note If you check “Cursor movement sets font and look” in the
Options/Preferences/Cursor dialog box, the current style will
always show the style of the character to the left of the text
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cursor, unless a text character or layer is selected.

USING AN INTERNATIONAL CHARACTER SET

To type a character from an international character
set:

1. From the View menu, choose International.

2. In the International window, click the Character Set list box, then
choose a character set from the drop-down list.

3. In the graphic window, position the insertion point where you
wish to insert the character.

4. Click the desired character in the International window.

Note Not all TrueType or Postscript fonts include every character in
every character set. The International window displays a small
box in place of any character that is not available in the
current font.

To change the current keyboard layout:
1. From the View menu, choose Style.

2. In the Style window, choose Font, then click the Keyboard list box.

3. Type or scroll to the new keyboard layout.

Notes Any keyboard layout installed in Windows NT is automatically
available in Deko500. In the Windows NT Program Manager,
double-click Main, Control Panel, then International. Refer to
Windows NT documentation for more detailed information.

Deko500 supports most alphabet-based languages as well as
several ideographic languages. For the following languages,
you must install the local version of Windows NT: Arabic,
Chinese, Hebrew, Japanese, Korean, and Thai.
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BOLD AND ITALIC

To change normal text to bold:
1. Select the text to be changed, or select nothing to change the

current style.

2. Do one of the following:
� Press the bold button on the text bar (Ctrl+B).

� Activate the Style window, select Font at the top of the Style
window, then check Bold.

3. To change text back to normal, unpress the bold button or uncheck
Bold.

To change normal text to italic:
1. Select the text to be changed, or select nothing to change the

current style.

2. Do one of the following:
� Press the italic button on the text bar (Ctrl+I).

� Activate the Style window, select Font at the top of the Style
window, then check Italic.

3. To change text back to normal, unpress the italic button or uncheck
Italic.

UNDERLINING TEXT

To underline text:
1. Select the text to be underlined, or select nothing to add an

underline to the current style.

2. Press the underline button on the text bar (Ctrl+U).

To change text back to normal, unpress the underline button.

ROTATING TEXT

To rotate text using the keyboard:
1. In the Options menu, choose Transform/Rotate & Skew (Ctrl+R).

2. In the Options menu, choose Transform and set increment of
change to Coarse or Fine (Ctrl+spacebar).
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3. Select the text to rotate.

4. Hold down Alt and press either the down arrow (↓ ) to rotate the
selected text clockwise, or the up arrow (↑ ) to rotate
counterclockwise.

To rotate text using the mouse:
1. Click the rotate/skew button in the Tools window.

2. Select the text to rotate.

3. Move the pointer near the dotted line surrounding selected text, so
that the pointer becomes the rotation tool.

4. Drag to rotate selected text.

To specify a numerical value for rotation:
1. Select the text to rotate. If no text is selected, Deko500 applies

changes to the current style.

2. Activate the Style window.

3. Choose Font at the top of the Style window.

4. Double-click the Rotation text box, then type or scroll to a value.
Negative values set counterclockwise rotation of the selected text,
and positive values set clockwise rotation.

SKEWING TEXT

To skew text using the keyboard:
1. In the Options menu, choose Transform/Rotate & Skew (Ctrl+R).

2. In the Options menu, choose Transform and set increment of
change to Coarse or Fine (Ctrl+spacebar).

3. Select the text to skew.

4. Hold down Alt and press either the right arrow (→) to skew the
selected text clockwise, or the left arrow (←←←←) to skew
counterclockwise.

 To skew text using the mouse:
1. Click the rotate/skew button in the Tools window.

2. Select the text to skew.

3. Move the pointer over the top-right-corner handle of the selected
text, so that the pointer becomes the skewing tool.
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4. Drag the handle to skew selected text.

To specify a numerical value for skewing:
1. Select the characters to skew. If no text is selected, Deko500

applies changes to the current style.

2. Activate the Style window.

3. Choose Font at the top of the Style window.

4. Double-click the Skew text box, then type or scroll to a value.
Negative values skew text counterclockwise, and positive values
skew text clockwise.

Note Skew can be used to italicize text to angles different from the
default italic angle.

SMALL CAPS

To change lower case text to small upper case text:
1. Select the text to be capitalized, or select nothing to change the

current style.

2. Do one of the following:
� Press the small caps button on the text bar.

� In the Style/Font window, check Small Caps.

To change text back to normal, unpress the small caps button or
uncheck Small Caps.

CHANGING TEXT CASE

To change the first character of each word to upper
case:

1. Select the text to be changed, or select nothing to change all text in
the current text field.

2. From the Text menu, choose Capitalize.

To change selected text to upper case:
1. Select the text to be changed, or select nothing to change all text in

the current text field.

2. From the Text menu, choose Upper Case.
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To change selected text to lower case:
1. Select the text to be changed, or select nothing to change all text in

the current text field.

2. From the Text menu, choose Lower Case.

CHANGING THE TEXT FIELD BOX

To change the text field box, using the keyboard:
1. From the Options menu, choose Transform/Move (Ctrl+M).

2. In the Options menu, choose Transform and set increment of
change to Coarse or Fine (Ctrl+spacebar).

3. Select a text field.

4. Hold Alt down and press arrow keys (↑↓→  ←←←←) to move the text
field box up, down, left or right.

To change the text field box, using the mouse:
1. Click the move button in the Tools window.

2. Select a text field.

3. Position the pointer near the border or a handle of the field, so that
the pointer becomes the moving tool or a sizing tool.

4. Drag to move or size the text field box.

Important When you size the text field box, Deko500 does not scale the
text along with the box. The text remains the same size, but
wraps differently to fit within the box. To scale the text along
with the box, see Scaling a Layer.

SCALING TEXT

To scale text using the keyboard:
1. In the Options menu, choose Transform/Scale & Width (Ctrl+W).

2. In the Options menu, choose Transform and set increment of
change to Coarse or Fine (Ctrl+spacebar).

3. Select the text for scaling.

4. Hold down Alt and press either the up or down arrow (↑↓ ) to
increase or decrease text size, or the right or left arrow (→ ←←←←) to
increase or decrease text width.
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To scale text using the mouse:
1. Click the scaling button in the Tools window.

2. Select the text for scaling.

3. Move the pointer to a handle on any side or corner of selected text,
so that the pointer becomes one of the scaling tools.

4. Drag a handle either outward to increase or inward to decrease text
size.

Corner handles control height and width together; middle handles
on the right or left control width only; and middle handles on the
top or bottom control height only.

Hold Ctrl down while dragging a corner handle to preserve the
aspect ratio of the text — height and width scale together.

To specify a numerical value for font size:
1. Select the text to scale. If no text is selected, Deko500 applies

changes to the current style.

2. Do one of the following:
� On the text bar, double-click the Size text box.

� 
� In the Style/Font window, then double-click the Size text box.

3. In the text box, type or scroll to a new font size.

4. Press Enter to apply the new size.

CHARACTER SPACING (KERNING)

To kern text using the keyboard:
1. In the Options menu, choose Transform/Kerning & Leading

(Ctrl+K).

2. In the Options menu, choose Transform and set increment of
change to Coarse or Fine (Ctrl+spacebar).

3. Select the characters to kern.

4. Hold down Alt and press either the right arrow (→) to widen the
space between selected characters, or the left arrow (←←←←) to reduce
character spacing.

To kern text using the mouse:
1. Click the kerning/leading button in the Tools window.
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2. Select the characters to kern.

3. Move the pointer to a handle at either side of the selected text, so
that the pointer becomes the kerning tool.

4. Drag the handle either outward to widen spacing between
characters or inward to decrease character spacing.

To specify a numerical value for kerning:
1. Select the characters to kern. If no text is selected, Deko500

applies changes to the current style.

2. Activate the Style window.

3. Choose Font at the top of the Style window.

4. Double-click or Tab to the Kerning text box, then type or scroll to
the desired value. A positive kerning value increases space
between characters; a negative value decreases the space. To use
default kerning, specify a value of zero.

CHARACTER WIDTH

To change character width using the keyboard:
1. In the Options menu, choose Transform/Scale & Width (Ctrl+W).

2. In the Options menu, choose Transform and set increment of
change to Coarse or Fine (Ctrl+spacebar).

3. Select the characters to change.

4. Hold Alt down and press either the right arrow (→) to widen
characters, or the left arrow (←) to decrease character width.

To change character width using the mouse:
1. Click the scale button in the Tools window.

2. Select the characters to change.

3. Move the pointer to a handle on either side of selected text, so that
the pointer becomes the widening tool.

4. Drag the handle either outward to widen characters or inward to
decrease character width.

To specify a numerical value for character width:
1. Select the characters to change. If no text is selected, Deko500

applies changes to the current style.

2. Activate the Style window.

3. Choose Font at the top of the Style window.
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4. Double-click or Tab to the Width % text box, then type or scroll to
a percentage of normal character width.

ROW SPACING (LEADING)

To change leading using the keyboard:
1. In the Options menu, choose Transform/Kerning & Leading

(Ctrl+K).

2. In the Options menu, choose Transform and set increment of
change to Coarse or Fine (Ctrl+spacebar).

3. Select the text for leading.

4. Hold down Alt and press either the up arrow (↑ ) to increase the
space between rows of selected text, or the down arrow (↓ ) to
decrease space.

To change leading using the mouse:
1. Click the kerning/leading button in the Tools window.

2. Select the text for leading.

3. Move the pointer to a handle above or below selected text, so that
the pointer becomes a leading tool.

4. Drag the handle downward to increase the space between rows, or
upward to reduce row spacing.

To specify a numerical value for leading:
1. Select the text for leading. If no text is selected, Deko500 applies

changes to the current style.

2. Activate the Style window.

3. Choose Font at the top of the Style window.

4. Double-click the Leading text box, then type or scroll to the
desired value. A positive value increases the space between rows; a
negative value decreases it. The default value is zero.

TYPING ON A CURVE

To activate the Baseline Edit window:
Do one of the following:
� From the Layer menu, choose Edit Baseline (to activate the

Baseline Edit window).

� If the Baseline Edit window is open but not active, check
Baseline Edit in the Window menu.
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To draw a curved baseline:
1. Select the layer whose baseline you wish to modify.

2. Activate the Baseline Edit window.

3. Do one of the following:
� In the Baseline menu, check Draw Curve.

� Click the curve drawing tool button in the Tools window.

4. Position the drawing tool where you will begin the curve, and drag
the mouse to draw the curve.

To draw a line-segment baseline:
1. Select the layer whose baseline you wish to modify.

2. Activate the Baseline Edit window.

3. Do one of the following:
� In the Baseline menu, check Draw Curve.

� Click the curve drawing tool button in the Tools window.

4. Click to begin the line, then move the drawing tool to the desired
end point and click again. Repeat this step as desired to draw
multiple line segments.

5. To break the line, move the cursor out of the Baseline Edit
window.

To use a rectangle or ellipse as a baseline:
1. Select the layer whose baseline you wish to modify.

2. Activate the Baseline Edit window.

3. Click the rectangle or ellipse button in the Tools window, then
drag the cursor in the Baseline Edit window to define the rectangle
or ellipse.

4. Once you release the mouse button, you will be in Edit Curve
mode. Drag points as desired to edit the baseline.

Note Holding Ctrl as you drag the cursor maintains a square or
round baseline.

To apply a baseline:
Once you have drawn or edited the baseline as desired, do one of
the following:
� To apply the baseline and remain in baseline edit mode,

choose Apply Baseline (Enter) from the Baseline menu.

� To apply the baseline and close the Baseline Edit window,
choose Accept Baseline (Alt+Enter) from the Baseline menu.
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To delete or insert a point on a baseline:
1. If not already in the Baseline Edit mode, choose Edit Baseline

from the Layer menu.

2. In the Baseline menu, check Edit Curve.

3. Do one of the following:
� Click the point you wish to delete, then choose Delete

Selected Point (Delete) from the Baseline menu.

� Choose Insert Point (Insert) from the Baseline menu, then
click on the curve where you wish to insert the point.

To reverse the direction of the baseline:
1. If not already in the Baseline Edit mode, choose Edit Baseline

from the Layer menu.

2. In the Baseline menu, choose Reverse Baseline.

To change the type of a point on the baseline:
1. In the Baseline menu, check Edit Curve.

2. Click the point to select it.

3. In the Baseline menu, do one of the following:
� Check Move To, for a point that begins a new section of the

baseline.

� Check Line To, for a point connected to the previous point by
a straight line.

� Check Bezier, for a point connected to the previous point by a
Bezier curve.

To adjust the continuity between two Bezier curves:
1. In the Baseline menu, check Edit Curve.

2. Click the point shared by the two curves.

3. In the Baseline menu, do one of the following:
� Check Cusp for no continuity. The control points on either

side of the shared point move independently.

� Check Smooth for C1 continuity.

� Check Symmetric for C2 continuity.

To cancel changes to a baseline:
1. Do one of the following:

� To cancel all changes and exit the Baseline Edit window,
choose Cancel from the Baseline menu.

� If Undo is enabled, you can choose Undo (Ctrl+Z) from the
Edit menu, for each change you wish to undo.
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CUTTING AND PASTING TEXT

To cut or copy text:
1. Select the text to be cut or copied.

2. Do one of the following:
� To cut selected text, from the Edit menu, choose Cut (Ctrl+X),

or click the cut button on the text bar.

� To copy selected text, from the Edit menu, choose Copy
(Ctrl+C), then Selected, or click the copy button on the text
bar.

To paste text:
1. Position the cursor where you will insert the text.

2. From the Edit menu, choose Paste (Ctrl+V), or click the paste
button on the text bar.

Notes When you cut or copy text, it is saved in the Windows NT
clipboard.

Unlike moving text, cutting and pasting text changes the
location of the text cursor. When you move text, the cursor
appears in the original location of the text even after the text
has been moved, but when you cut and paste text, the cursor
follows the text.

DELETING TEXT

To delete text:
1. Select the text to be deleted.

2. Choose Delete (Delete) from the Edit menu.

To delete all text within a text field:
1. Select a text field.

2. From the Layer menu, choose Clear Text. The emptied layer
remains in the graphic.
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FINDING AND REPLACING TEXT

To find text within a graphic:
1. From the Edit menu, choose Find (Ctrl+F).

2. In the dialog box, type the text in the Find What text box.

3. If desired, check Match Case or Match Whole Word Only.

4. Choose Find Next (Ctrl+G) to find and select the next occurrence
of the text.

5. Click Cancel to close the dialog box.

To find and replace text within a graphic:
1. From the Edit menu, choose Replace (Ctrl+H).

2. In the dialog box, type original text in the Find What text box.

3. Type replacement text in the Replace With text box.

4. If desired, check Match Case or Match Whole Word Only.

5. Do one of the following:
� Choose Find Next (Ctrl+G) to find and select the next

occurrence of original text. Then choose Replace to remove
and replace selected text, or Find Next to skip to the next
occurrence of original text.

� To find and replace all occurrences of original text, choose
Replace All.

6. Click Cancel to close the dialog box.

MOVING TEXT

To move text using the keyboard:
1. In the Options menu, choose Transform/Move (Ctrl+M).

2. In the Options menu, choose Transform and set increment of
change to Coarse or Fine (Ctrl+spacebar).

3. Select the text to move.

4. Hold down Alt and press arrow keys (↑↓→  ←←←←) to move selected
text up, down, right or left.

To move text using the mouse:
1. Select the text to move.

2. Click the move button in the Tools window.

3. Move the pointer near the dotted line surrounding selected text, so
that the pointer becomes the moving tool.
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4. Drag to move selected text in any direction.

Note Unlike cutting and pasting text, moving text does not change
the location of the text cursor. When you cut and paste text,
the cursor follows the text, but when you move text, the cursor
appears in the original location of the text even after the text
has been moved.

If no text is selected:
� Alt + ↓  moves the cursor row and all lower rows down.

� Alt + ↑  moves the cursor row and all lower rows up.

� Alt + → moves all characters from the cursor to the end of the
row (or tab field) to the right.

� Alt + ←←←← moves all characters from the cursor to the end of the
row (or tab field) to the left.

JUSTIFYING TEXT

To justify text using the mouse:
1. Select the text, or select nothing to justify the entire field of text.

2. Do one of the following:
� On the text bar, click the appropriate justification button to

alter horizontal justification, vertical justification, or both,
then choose the desired setting.

� From the Text menu, choose Justify, then select a setting for
horizontal justification, vertical justification or both. The
choices are self-explanatory, except for full and spread
justification.

Full horizontal justification makes selected text, except any row with a newline
character (hard return), flush with the left and right sides of the text field box.

Full vertical justification makes the top and bottom lines of selected text flush
with the top and bottom of the field box.
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Spread justification makes all lines of selected text flush with both the left and
right sides of the text field box. To do this, space is inserted between words and
between letters, as controlled by the Spread % in the Style/Layers window.

To justify text using the keyboard:
1. Select the text, or select nothing to justify the entire field of text.

2. Hold Ctrl down and press one of the numbers on the numeric
keypad to justify selected text in the corresponding position of the
selected text field.

7                8 9
Top left         Top center Top right

4                 5 6
Middle left    Middle center Middle right

1                 2 3
Bottom left    Bottom center Bottom right

0
Justification off             

Notes If you select only some of the text in a field, that text will be
justified in a separate field.
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TAB STOPS

To set a tab stop:
1. Position the cursor where you will insert the tab stop.

2. From the Text menu, choose Tab Set.

3. Choose an alignment (Right, Left, Center or Decimal) from the
drop-down menu.

4. The current tab settings for a text field are displayed at the bottom
of the text field box, using the following markers:

Left:        Right:        Center:        Decimal: 

5. Whenever you Tab to a tab stop, a similar tab marker is displayed
to the left of the first character at the tab stop.

To clear a selected tab stop:
1. Tab to the tab stop.

2. From the Text menu, choose Tab Clear.

To clear all tabs within a layer:
From the Text menu, choose Tab Clear All.

To move a tab stop:
1. Position the cursor to the left of the tab stop.

2. In the Options menu, choose Transform and set increment of
change to Coarse or Fine (Ctrl+spacebar).

3. Do one of the following:
� In the Options menu, select Transform, then Move.

� Click the move button in the Tools window.

4. Hold Alt and use the right or left arrow keys (→ ←←←←) to move the
tab stop.

To cut or copy a tab stop:
1. Select the tab stop you wish to cut or copy.

2. Do one of the following:
� To remove the selected tab stop from its current position,

choose Cut (Ctrl+X) from the Edit menu, or click the cut
button in the Tools window.

� 
� To copy and leave the selected tab stop intact, choose Copy

(Ctrl+C), then Tabs, from the Edit menu, or click the copy
button in the Tools window.
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� 

To paste a cut or copied tab stop:
1. If necessary, open the file into which you will paste the tab stop.

2. Position to text cursor where you will insert the cut or copied tab
stop.

3. From the Edit menu, choose Paste (Ctrl+V), or click the paste
button in the Tools window.

To change the decimal tab character:
1. From the Options menu, choose Preferences.

2. At the top of the dialog box, choose Common.

3. In the Decimal tab char text box, type a new decimal tab character.

4. Choose OK or press Enter.

To display or hide tab markers:
1. From the Options menu, choose Preferences.

2. In the dialog box, under Markers, check or uncheck Tab stops.

USING UNDO

To undo the previous action(s):
From the Edit menu, choose Undo (Ctrl+Z) for each action you
wish to undo. The Edit menu tells you what will be undone.

To redo undone actions:
From the Edit menu, choose Redo (Ctrl+Y) for each action you
wish to redo. The Edit menu tells you what will be redone.

To enable or disable Undo:
In the Edit menu, check or un-check Undo enabled.

Notes The default setting is Undo enabled. Undo uses several
megabytes of space on your hard drive and may slow some
Deko500 operations. Disabling Undo frees space on your hard
drive and may speed up Deko500’s performance.

You cannot disable Undo, then enable Undo and use it to
undo actions performed while it was disabled.

Undo will not undo changes to a macro or custom typeface,
and is disabled during sequence playback. When you play a
sequence, Deko500 resets the Undo buffer so that no previous
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actions can be undone.
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Creating Styles

SPECIFYING A FONT

ABOUT FONTS

A font is a single typeface in a particular size and orientation. In Deko500, the
current font and the current look make up the current style.

Deko500 supports alphabet-based fonts as well as fonts of several ideographic
languages. For the following languages, you must install the local version of
Windows NT: Arabic, Chinese, Hebrew, Japanese, Korean, and Thai.

The preceding Composing Text chapter described how to select and manipulate
a font interactively. This section describes howto use the controls in the
Style/Font Window to change the attributes of the current font.

Later sections describe how to install TrueType or Postscript fonts and how to
create a Custom Typeface.

To change the attributes of the current font:
Do one of the following:
� Use the text bar to choose the current typeface, size, bold,

italic and justification rules.

� Use the Style/Font Window to control all aspects of the
current font.

THE STYLE/FONT WINDOW

To display the Style/Font Window:
1. In the View menu, Choose Style (F6).

2. Click Font at the top of the Style window.
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Controls in the Style/Font Window:
Typeface

The name of the current typeface. Click this box to call up a list of
available typefaces. The list includes TrueType and Postscript
fonts as well as Deko500 Custom Typefaces. The latter are
indicated by the word “(deko)” after the typeface name.

Browse

Opens the Typeface Browser window, showing the current font
and a sample of each available typeface. Double-click a typeface
sample to select it.

Size

The height of the current font, in screen units.

Width

Percent of normal width. Enter a percent less than 100 to condense
the font, or greater than 100 to expand it.

Bold

Selects a bold version of the current typeface. If no bold version is
available, this item is dimmed.

Italic

Selects an italic version of the current typeface. If no italic version
is available, this item is dimmed.

Small Caps

Turns all lower case characters into small upper case characters.

Leading

Controls the spacing between rows of text. A value of zero
produces the default row spacing. Values greater than zero increase
the space between rows; values less than zero decrease it.

Kerning

Controls the spacing between characters. A value of zero produces
the default kerning. Values greater than zero increase the space
between characters; values less than zero decrease it.

Rotation

Controls the angle of the baseline, in degrees.

Skew

Controls the amount of skew applied to the characters. This is
independent of the italic setting.

Spacing

Chooses the type of character spacing for the font:

proportional

Characters are spaced according to their widths.

monospace

All characters are forced to have the same widths.
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digits

The digits 0-9 are monospace, but all other characters are
proportional.

Note For many typefaces, there is no difference between
“proportional” and “digits” spacing. In other words, the fonts
were designed with monospaced digits.

Keyboard

Selects the keyboard language layout for typing with the font.

Orientation

Determines field orientation, i.e. left-to-right, top-to-bottom, etc.

Note Right-to-left is available only for Arabic or Hebrew, and top-
to-bottom and top-to-bottom-rotated are available only for
Chinese, Japanese or Korean.

Pre-rendered style

Indicates that this style was previously rendered and saved so it
can be typed quicker.

INSTALLING TRUETYPE AND POSTSCRIPT FONTS

To install a TrueType or Postscript font:
1. Close or minimize windows as necessary to access the start-up

screen of your desktop.

2. Click the Start button in the bottom lefthand corner of the screen,
then click Settings, then Control Panel.

3. Double-click Fonts.

4. Select the fonts to install. Refer to help for the Fonts dialog box for
detailed help with font installation.

Note Once fonts have been installed in Windows NT, you must
restart Deko500 before those fonts are available in Deko500.

COPYING AND PASTING A FONT

To copy and paste a font:
1. Select text whose font you wish to copy.

2. From the Edit menu, choose Copy (Ctrl+C), then Font.

3. Select the text or position the cursor where you will apply the font.

4. From the Edit menu, choose Paste (Ctrl+V), or click the paste
button on the text bar.



Specifying a Font 41

Deko500 User’s Guide

Note When you copy a font, it is saved in the Windows NT
clipboard.

CUSTOM TYPEFACE

The Custom Typeface feature enables you to create custom
characters for use in Deko500 graphics

To open a Custom Typeface window:
Do one of the following:
� From the Window menu, choose Select Layout, then Typeface

Edit.

� From the View menu, choose Custom Typeface.

� From the File menu, choose Open, navigate to the drive and
directory containing an existing custom typeface, then press
Enter or click OK.

To import an active graphic as a character into a
custom typeface:

1. Activate the Program window and open the graphic you wish to
import as a character.

2. Activate the Custom Typeface window and optionally open an
existing custom typeface.

3. Click or use arrow keys to select the character.

4. From the File menu, choose Import Character.

To import a graphic file as a character into a custom
typeface:

1. Activate the Custom Typeface window and optionally open an
existing custom typeface.

2. Click or use arrow keys to select the character.

3. From the File menu, choose Import Character From File.

4. In the dialog box, navigate to the drive and directory that contain
the file that will become the custom character.

5. Type the file name in the File Name text box or choose it from the
File Name list box, then click OK or press Enter. Deko500 copies
the file into the selected character.

Note Deko500 can import several file types to use as custom
characters, including Deko500 graphics (.dko), Windows
bitmap files (.bmp), Graphics Factory stills (.gf),
videoDesigner stills (.tv), JPEG files (.jpg), TIFF files (.tif)
and Targa files (.tga).
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To change pin location and set width of a character:
1. In the Custom Typeface window, double-click the character you

wish to edit. Deko500 displays the character in its own window.

2. In the character window, type in or scroll to X and Y values for the
character’s pin location.

3. Type in or scroll to a Width value for the character’s set width.

4. To close the character window, double-click its control icon.

Note Multiple character windows can be open at one time.

To specify custom typeface properties:
1. Activate the Custom Typeface window and open the custom

typeface.

2. In the Custom Typeface window, click Properties.

3. Edit properties as desired, then click OK.

Custom Typeface Properties
Font size

The default size of the typeface, i.e. the size at which no
scaling will occur.

Cap height

The height of upper case characters, as a percentage of the
font size.

Ascender

The maximum distance of character ascenders from the
baseline, as a percentage of the font size.

Descender

The maximum distance of character descenders from the
baseline, as a percentage of the font size.

Underline size

Underline height, as a percentage of the font size.

Underline position

Underline position, relative to character position, as a
percentage of the font size.

Space width

Space between characters, specified as a percentage of the font
size.

Number width

Number width, specified as a percentage of the font size.
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SPECIFYING A LOOK

ABOUT LOOKS

This section describes how to control the current style’s look. The look controls
everything about the way a text character looks, including colors, edges,
shadows, etc.

A look consists of a list of details. Each detail is a face, edge, frame, shadow, or
underline, and has its own set of attributes which dictate color, size, shape, etc.

A look coupled with a font makes up a style.

To change the attributes of the current look:
Do one of the following:
� Use the text bar to turn on and off the first face, edge, shadow,

underline and frame of a look, and to choose colors for each.

� Use the Style/Look Window to control all aspects of the
current look, including additional edges, shadows, etc.

THE STYLE/LOOK WINDOW

To display the Style/Look Window:
1. In the View menu, Choose Style (F6).

2. Click Look (Alt+L) at the top of the Style window.

Controls in the Style/Look Window:
Details

The list of details for the current look. The selected detail is
highlighted, and its attributes are displayed in the lower half of the
window.

Details come in these flavors:

Edge

An edge around the character. The edge is based on details
above it in the list of details.

Face

The face of the character. Most looks have only a single face,
which is usually the first detail in the list of details.

Frame

A frame behind the character.

Shadow

A shadow of the character. The shadow is based on details
above it in the list of details. A look can have up to two
shadows.
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Underline

An underline below the character. A look can have only one
underline.

Frame

A frame behind the character. A look can have up to two
frames.

Add

Adds a new detail to the current look. A pop-up menu lets you
choose which kind of detail to add. The new detail is added after
the selected detail.

Delete

Deletes the selected detail.

FACE

To add or remove a face:
1. Select the text to change. If no text is selected, a face is added to or

removed from the current style.

2. Click the face button on the text bar to toggle the face on or off.

To change the color of a face:
1. Select the text to change. If no text is selected, Deko500 applies

changes to the current style.

2. Do one of the following:
� Click the shader button next to the face button on the text bar

(only for the first face of a look).

� Open the Style window (F6), select Look (Alt+L) at the top of
the Style window, click on the appropriate face detail, then
click the Shader button.

3. In the Shader window, choose a Color, Ramp or Texture.
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To change other attributes of a face:
1. Select the text to change. If no text is selected, Deko500 applies

changes to the current style.

2. Activate the Style window.

3. Choose Look (Alt+L) at the top of the Style window.

4. In the Details list, choose the face. Deko500 displays face
attributes in the lower half of the Style window.

FACE ATTRIBUTES

Hide

Check this box to hide the face. A hidden face can still affect other
details, based on its Priority and the “From previous detail”
settings of other details.

Shader

Opens the Face Shader window. Use the Face Shader to apply a
color, ramp or texture to the face.

Blur

Controls the amount of blur, from 0 (no blur) to 100.

Priority

Determines whether the face appears in front of or behind other
details. By default, Deko500 assigns a priority to each detail so
that they render from front to back, in the order they appear in the
Details list. Use Priority to change the rendering order. Priority
ranges from 0 (closest to viewer) to 1000 (farthest from viewer).

Priority also controls the rendering order of overlapping details
from different styles.

EDGE

To add or remove an edge:
1. Select the text to change. If no text is selected, an edge is added to

or removed from the current style.

2. Click the edge button on the text bar to toggle the edge on or off.

This button controls only the first edge of a look.

To add additional edges:
1. Activate the Style window.

2. Choose Look at the top of the Style window.

3. Next to the Details list, choose Add, then choose Edge from the
popup menu. The edge is added after the selected detail.
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To change the color of an edge:
1. Select the text to change. If no text is selected, Deko500 applies

changes to the current style.

2. Do one of the following:
� Click the shader button next to the edge button on the text bar

(only for the first edge of a look).

� Open the Style window (F6), select Look at the top of the
Style window, click on the appropriate edge detail, then click
the Shader button.

3. In the Shader window, choose a Color, Ramp or Texture.

To change other attributes of an edge:
1. Select the text to change. If no text is selected, Deko500 applies

changes to the current style.

2. Activate the Style window.

3. Choose Look at the top of the Style window.

4. In the Details list, choose the edge. Deko500 displays Edge
Attributes in the lower half of the Style window.

EDGE ATTRIBUTES

Hide

Hides the edge. A hidden edge can still affect other details, based
on its Priority and “To next detail” settings.

Shader

Opens the Edge Shader window. Use the Edge Shader to apply a
color, ramp or texture to the edge.

Blur

Controls the amount of blur, from 0 (no blur) to 100.

Shape

Specifies the shape of the edge:

round

creates a rounded edge.

square

creates a rectangular edge.

Type

Specifies the type of edge:

outer

creates an edge that extends outward from the outer edge of
the edged detail.
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inner

creates an edge that extends inward from the outer edge of the
edged detail.

border

creates an edge that extends both outward and inward from the
outer edge of the edged detail.

filled

creates an edge that extends outward from the outer edge of
the edged detail; the inside is filled with the edge color.

                         
  Outer              Inner            Border            Filled

Size

Controls the size of the edge, from 0 (no edge) to 100 (very large
edge).

Priority

Determines whether the edge appears in front of or behind other
details. By default, Deko500 assigns a priority to each detail so
that they render from front to back, in the order they appear in the
Details list. Use Priority to change the rendering order. Priority
ranges from 0 (closest to viewer) to 1000 (farthest from viewer).

Priority also controls the rendering order of overlapping details
from different styles.

From previous detail

Specifies which other details in the look provide the shape on
which this edge is based:

face

produces an edge based only on the face detail.

frame

produces an edge around the first frame detail above the edge
in the Details list.

previous

produces an edge based on the “To next detail” setting of the
detail immediately above the edge in the Details list.

underline

produces an edge around the first underline above the edge in
the Details list.

To next detail

Determines what this edge will send to the detail immediately
below it in the Details list:

previous

sends whatever was sent to the edge from the detail above it.
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merged

sends the combinations of the edge and whatever was sent to
the edge from the detail above it.

this

sends the edge only.

SHADOW

To add or remove a shadow:
1. Select the text to change. If no text is selected, a shadow is added

to or removed from the current style.

2. Click the shadow button on the text bar to toggle the shadow on or
off.

This button controls only the first shadow of a look.

To add additional shadows:
1. Activate the Style window.

2. Choose Look at the top of the Style window.

3. Next to the Details list, choose Add, then choose Shadow from the
popup menu. The shadow is added after the selected detail.
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To change the color of a shadow:
1. Select the text to change. If no text is selected, Deko500 applies

changes to the current style.

2. Do one of the following:
� Click the shader button next to the shadow button on the text

bar (only for the first shadow of a look).

� Open the Style window (F6), select Look at the top of the
Style window, click on the appropriate shadow detail, then
click the Shader button.

3. In the Shader window, choose a Color, Ramp or Texture.

To change other attributes of a shadow:
1. Select the text to change. If no text is selected, Deko500 applies

changes to the current style.

2. Activate the Style window.

3. Choose Look at the top of the Style window.

4. In the Details list, choose the shadow. Deko500 displays Shadow
Attributes in the lower half of the Style window.

SHADOW ATTRIBUTES

Hide

Hides the shadow. A hidden shadow can still affect other details,
based on its Priority and “To next detail” settings.

Shader

Opens the Shadow shader window. Use the Shadow Shader to
apply a color, ramp or texture to the shadow.

Blur

Controls the amount of blur, from 0 (no blur) to 100.

Angle

Controls the angle that the shadow is offset from the detail(s) being
shadowed. An angle of zero produces a shadow directly above the
shadowed detail.



Specifying a Look 50

Deko500 User’s Guide

Type

Determines the type of shadow:

drop

creates a single shadow of the detail being shadowed.

deep

creates a thick shadow, as if the detail were extruded.

                                   
                      Drop                  Deep

Distance

Controls the distance of the shadow from the shadowed detail(s).

Priority

Determines whether the shadow appears in front of or behind other
details. By default, Deko500 assigns a priority to each detail so
that they render from front to back, in the order they appear in the
Details list. Use Priority to change the rendering order. Priority
ranges from 0 (closest to viewer) to 1000 (farthest from viewer).

Priority also controls the rendering order of overlapping details
from different styles.

From previous detail

Specifies which other details in the look provide the shape on
which this shadow is based:

face

produces a shadow based only on the face detail.

previous

produces a shadow based on the “To next detail” setting of the
detail immediately above the shadow in the Details list.

frame

produces a shadow of the first frame detail above the shadow
in the Details list.

underline

produces a shadow of the first underline above the shadow in
the Details list.

To next detail

Determines what this shadow will send to the detail immediately
below it in the Details list:

previous

sends whatever was sent to the shadow from the detail above
it.

this

sends the shadow only.
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merged

sends the combination of the shadow and whatever was sent to
the shadow from the detail above it.

UNDERLINE

To add or remove an underline:
1. Select the text to change. If no text is selected, an underline is

added to or removed from the current style.

2. Click the underline button on the text bar to toggle the underline on
or off.

This button controls only the first underline of a look.

To change the color of an underline:
1. Select the text to change. If no text is selected, Deko500 applies

changes to the current style.

2. Do one of the following:
� Click the shader button next to the underline button on the text

bar (only for the first underline of a look).

� Open the Style window (F6), select Look at the top of the
Style window, click on the appropriate underline detail, then
click the Shader button.

3. In the Shader window, choose a Color, Ramp or Texture.
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To change other attributes of an underline:
1. Select the text to change. If no text is selected, Deko500 applies

changes to the current style.

2. Activate the Style window.

3. Choose Look at the top of the Style window.

4. In the Details list, choose the underline. Deko500 displays
Underline Attributes in the lower half of the Style window.

UNDERLINE ATTRIBUTES

Hide

Hides the underline. A hidden underline can still affect other
details, based on its Priority and “To next detail” settings.

Shader

Opens the Underline Shader window. Use the Underline Shader to
apply a color, ramp or texture to the underline.

Blur

Controls the amount of blur, from 0 (no blur) to 100.

Shape

Specifies the shape of the underline:

round

produces an underline with rounded corners.

square

produces an underline with rectangular corners.

Height

Controls the height of the underline. The default value is 100
percent.

Width

Specifies an additional amount of underline that extends beyond
the width of underlined text. A value of zero produces an underline
that exactly matches the width of underlined text.

V offset

Specifies a vertical offset from the underline’s normal position.
Negative values move the underline down, and positive values
move it up.

Spaces

Underlines the spaces between words.
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Priority

Determines whether the underline appears in front of or behind
other details. By default, Deko500 assigns a priority to each detail
so that they render from front to back, in the order they appear in
the Details list. Use Priority to change the rendering order. Priority
ranges from 0 (closest to viewer) to 1000 (farthest from viewer).

Priority also controls the rendering order of overlapping details
from different styles.

To next detail

Determines what this underline will send to the detail immediately
below it in the Details list:

previous

sends whatever was sent to the underline from the detail above
it.

this

sends the underline only.

merged

sends the combination of the underline and whatever was sent
to the underline from the detail above it.

FRAME

To add or remove a frame:
1. Select the text to change. If no text is selected, a frame is added to

or removed from the current style.

2. Click the frame button on the text bar to toggle the frame on or off.

This button controls only the first frame of a look.

To add additional frames:
1. Activate the Style window.

2. Choose Look at the top of the Style window.

3. Next to the Details list, choose Add, then choose Frame from the
popup menu. The frame is added after the selected detail.
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To change the color of a frame:
1. Select the text to change. If no text is selected, Deko500 applies

changes to the current style.

2. Do one of the following:
� Click the shader button next to the frame button on the text bar

(only for the first frame of a look).

� Open the Style window (F6), select Look at the top of the
Style window, click on the appropriate frame detail, then click
the Shader button.

3. In the Shader window, choose a Color, Ramp or Texture.

To change other attributes of a frame:
1. Select the text to change. If no text is selected, Deko500 applies

changes to the current style.

2. Activate the Style window.

3. Choose Look at the top of the Style window.

4. In the Details list, choose the frame. Deko500 displays Frame
Attributes in the lower half of the Style window.

FRAME ATTRIBUTES

Hide

Hides the frame. A hidden frame can still affect other details,
based on its Priority and “To next detail” settings.

Shader

Opens the Frame Shader window. Use the Frame Shader to apply a
color, ramp or texture to the frame.

Blur

Controls the amount of blur, from 0 (no blur) to 100.

Shape

Determines the shape of the frame:

round

creates a frame with rounded corners.

square

creates a frame with rectangular corners.

Height

Specifies the height of the frame.

Width

Specifies the width of the frame.



Specifying a Look 55

Deko500 User’s Guide

H offset

Offsets the frame horizontally relative to the detail being framed.

V Offset

Offsets the frame vertically relative to the detail being framed.

Descenders

Lowers the bottom of the frame to accommodate lower case
descender characters like g, j and y.

Spaces

Frames the spaces between words.

Priority

Determines whether the frame appears in front of or behind other
details. By default, Deko500 assigns a priority to each detail so
that they render from front to back, in the order they appear in the
Details list. Use Priority to change the rendering order. Priority
ranges from 0 (closest to viewer) to 1000 (farthest from viewer).

Priority also controls the rendering order of overlapping details
from different styles.

To next detail

Determines what this frame will send to the detail immediately
below it in the Details list:

previous

sends whatever was sent to the frame from the detail above it.

this

sends the frame only.

merged

sends the combination of the frame and whatever was sent to
the frame from the detail above it.

CUTTING AND PASTING DETAILS AND LOOKS

To cut or copy a detail:
1. Activate the Style window.

2. Choose Look at the top of the Style window.

3. In the Details list, click on the detail you wish to cut or copy.

4. Do one of the following:
� To remove the selected detail from its current position, choose

Cut Detail (Ctrl+X) from the Edit menu, or click the cut
button in the Tools window.

� 
� To copy and leave the selected detail intact, choose Copy

Detail (Ctrl+C) from the Edit menu, or click the copy button
in the Tools window.
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� 

To paste a detail into a Details list:
1. If necessary, open the Style file into which you will paste the

detail.

2. Click on the detail in the Details list where you will insert the cut
or copied detail.

3. From the Edit menu, choose Paste Detail (Ctrl+V), or click the
paste button in the Tools window.

To copy and paste a look:
1. Select text whose look you wish to copy.

2. From the Edit menu, choose Copy (Ctrl+C), then Look.

3. Select the text or position the cursor where you will apply the look.

4. From the Edit menu, choose Paste (Ctrl+V), or click the paste
button on the text bar.

Note When you copy a look, it is saved in the Windows NT
clipboard.
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SPECIFYING A SHADER

ABOUT SHADERS

To apply color to text or graphics, Deko500 uses a shader.

Each detail in a look (face, edge, frame, shadow or underline) has its own
shader. The shader determines how color is applied to the detail.

Deko500 shaders come in three flavors:
� A color shader produces a detail with a single, solid color.

� A ramp shader produces a detail with a four-color ramp and
an optional highlight.

� A texture shader produces a detail with a bitmap texture.

Any detail can have any kind of shader. For instance, a face can have a color
shader, an edge a ramp shader, and a shadow a texture shader, all within a single
look.

Multiple occurrences of the same type of detail within a look do not have to
have the same type of shader. For example, a look with three edges can have a
different shader for each edge.

You can use the same type of shader on multiple details within a graphic. In
addition, each graphic’s background has its own shader. Using the background
shader, you can make a solid, ramped or textured background for any graphic.

Shaders are specified in the Shader window (F7). Any shader can be stored as a
preset shader. The preset shaders can be saved in a .shd file for future use.
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ACTIVATING A SHADER

To activate a shader for the current look’s first face,
edge, shadow, underline or frame:

Click the appropriate detail shader button on the text bar.

        face          edge      shadow    underline    frame

Note If you click the shader button for a detail that is not in the
Details list, Deko500 automatically adds the detail.

To activate the background shader:
Click the background-shader button (Ctrl+F7) on the text bar.

To activate the shader for any detail in the current
style:

1. Activate the Style window.

2. In the Style window, click the desired detail in the Details list box.

3. In the Style window, click the Shader button.

APPLYING A COLOR

To apply a solid color to a detail:
1. Activate the detail’s shader.

2. At the top of the Shader window, choose Color. The Color button
near the top of the window displays the detail’s current color.

3. Use the color picker to pick a color.

4. When you are satisfied with the color, right-click the Color button
to set the detail’s shader to that color. The color is automatically
applied to the detail.
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APPLYING A RAMP

To apply a ramp to a detail:
1. Activate the detail’s shader.

2. At the top of the Shader window, choose Ramp. The Sample box
near the top of the window displays the detail’s current ramp.

3. For each of the four colors in the ramp, click the color button, use
the color picker to pick a color, then right-click the color button to
set it to that color.

4. Choose Options and specify ramp options as desired.

To apply highlighting to a ramp:
1. Follow above instructions for applying a ramp.

2. Click the Hilite button, then use the color picker to pick a color for
the highlight.

3. When you are satisfied with the color right-click the Hilite button
to set it to that color.

4. Check the Hilite box to turn the highlight on.

5. Choose Options and specify highlight options as desired.

RAMP OPTIONS

Group

Specifies how the ramp should be applied:

letter

applies the ramp individually to each letter.

word

applies the ramp to each word.

row

applies the ramp to each row of text.

page

applies the ramp to the entire page of text.

Opacity

Controls overall transparency of the ramp, in addition to any
transparency in the individual colors of the ramp. Enter a value for
ramp opacity from zero (transparent) to 100 percent (opaque).
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H Scale

Determines the width of the ramp relative to the group. For settings
less than 100 percent, only part of the ramp is applied to the group.

V Scale

Determines the height of the ramp relative to the group. For
settings less than 100 percent, only part of the ramp is applied to
the group.

HIGHLIGHT OPTIONS

Highlight Size

Specifies the size of the highlight relative to the height of the ramp,
up to 100 percent.

Highlight Angle

Specifies the angle (-360 to 360) of the highlight. An angle of zero
produces a horizontal highlight.

Highlight H Offset

Specifies the horizontal position of the highlight in the ramp.
Negative values offset the highlight to the left, positive values to
the right.

Highlight V Offset

Specifies the vertical position of the highlight in the ramp.
Negative values offset the highlight down, positive values up.

APPLYING A TEXTURE

To apply a texture to a detail:
1. Activate the detail’s shader.

2. At the top of the Shader window, choose Texture.

               
3. Do one of the following:

� In the File Name text box, type name of the texture file.

� Press Browse, then double-click a thumbnail in the Texture
Browser.

4. Specify texture options as desired.

Notes The Sample box in the Shader window displays the current
texture.
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The texture is copied from its file, in its original size, and
“pasted” onto the detail. The texture’s size does not change —
the larger the detail, the greater the area of texture that is
applied to it.

In addition to Deko500 (.dko) graphics, Deko500 can import
Windows bitmap files (.bmp), Graphics Factory stills (.gf),
videoDesigner stills (.tv), JPEG files (.jpg), TIFF files (.tif),
Targa files (.tga) and Pinnacle (.g) files created in FlashFile,
Lightning or Genie, to use as textures.

Multiple Deko500 graphics can use the same texture file.

TEXTURE OPTIONS

File Name

The name of the texture file.

If you check the File Name check box (the default), Deko500 saves
only the name of the texture file when saving the graphic. Any
changes you make to the texture file will be reflected in the graphic
as well.

If you un-check File Name, Deko500 copies the bitmap from the
original texture file and saves it as part of the graphic. The word
“unnamed” appears in the File Name text box to indicate that the
texture is being stored with the graphic. The graphic will increase
in size by approximately the size of the texture file. Any
subsequent changes you make to the original texture file will not
affect the texture bitmap saved with the graphic.

Details using textured shaders can save only the name of the
texture file; they cannot store an unnamed texture.

Group

Specifies how the ramp should be applied:

letter

applies the texture individually to each letter.

word

applies the texture to each word.

row

applies the texture to each row of text.

page

applies the texture to the entire page of text.

Opacity

Controls the texture’s opacity, from zero (transparent) to 100
(opaque).

H offset

Offsets the texture relative to its horizontal alignment.

V offset

Offsets the texture relative to its vertical alignment.
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H Alignment

Specifies how the original texture is aligned with the selected
detail(s), depending on the Group setting:

left

aligns the left edge of the texture with the left edge of the
group.

center

aligns the center of the texture with the center of the group.

right

aligns the right edge of the texture with the right edge of the
group.

V Alignment

Specifies how the original texture is mapped onto the selected
detail(s), depending on the group setting:

top

aligns the top of the texture with the top of the group.

middle

aligns the middle of the texture with the middle of the group.

baseline

aligns the middle of the texture with the baseline of the group.

bottom

aligns the bottom of the texture with the bottom of the group.
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THE COLOR PICKER

Use Deko500’s color picker to pick colors for the color shader and ramp
shader.

RGB

Selects the RGB color space. Click a color on the palette, or enter
numerical values up to 100 percent for each of red, green and blue.

HSV

Selects the HSV color space. Click a color on the palette, or enter
numerical values to specify:

Hue

the spectral shade of the color, represented by an angle (0-360)
around the color wheel or vector scope.

Sat

the color’s saturation, its percentage of pure color. Black,
white and gray have zero saturation. A 100 percent saturated
color is pure color—it contains no white or gray.

Value

the brightness of the color, represented by the maximum of
either red, blue or green. While not a true luminance amount,
Value is closely related to the brightness of a color.

Opacity

Controls the translucence of the color. An opacity of zero produces
a completely transparent color, while 100 percent is completely
opaque.
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Selected Component

Selects the color component RGB or HSV to display in the
Selected Component Bar. In the picture above, Value is the
selected component. If Opacity is selected, Deko500 displays a
gray scale in the Selected Component Bar.

Un-selected Components

The large square displays the two un-selected RGB or HSV
components. In other words, if Value is the Selected Component,
this square shows Hue along the vertical axis and Saturation along
the horizontal axis. If Opacity is the Selected Component,
Deko500 displays a gray scale in this square.

Current Color

Shows the current color, the color whose numerical values appear
above.

Eyedropper

Enables selection of a color directly from the desktop.

PICKING A COLOR

To pick a color:
1. Choose a color space by selecting RGB or HSV.

2. Use the color picker to pick a color, or enter numerical amounts for
Red, Green and Blue or Hue, Saturation and Value. Enter an
amount for Opacity, if desired.

3. To deposit the color into a color shader or ramp shader, right-click
on one of the color buttons near the top of the Shader window.

To pick a color from anywhere on the desktop:
1. Move the mouse pointer over the eyedropper button, then press

and hold the left mouse button down.

The cursor changes to an eyedropper.

2. Keep holding the left mouse button down, and move the
eyedropper cursor anywhere on the desktop. With the mouse
pointer over the desired color, release the mouse button.
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USING PRESET SHADERS

The 18 Preset Shader buttons appear at the bottom of the Shader window. Any
type of shader may be assigned to any preset.

To apply a preset shader to a detail:
1. Activate the detail’s shader.

2. In the Shader window, click the preset button.

To assign the current shader to a preset shader
button:

Do one of the following:
� Right-click the preset shader button.

� Activate the Shader window (F7), then choose Preset Shader
Set from the Shader menu and select a preset shader from the
drop-down menu.

To save the current preset shaders:
1. Activate the Shader window (F7).

2. From the File menu choose Save Preset Shaders (Ctrl+S or
Alt+F12) or Save Preset Shaders As (F12).

3. To name the file, navigate in the Save As dialog box to the drive
and directory where you will store the file, type a name in the File
Name text box, then click OK or press Enter.

Note When you save a preset shader file, Deko500 automatically
attaches “.shd” to the file name. Do not type a different
extension.
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WORKING WITH STYLES

THE CURRENT STYLE WINDOW

The Current Style window shows the current style.

This window shows the current font and look, in the actual size they would
appear if typed in the default Program window. If you are creating a style with a
very large font, you can enlarge the window to accommodate the larger sample
characters.

To move the Current Style window:
1. In the Window menu, make sure Freeze is not checked.

2. Move the selection cursor over the window’s title bar.

3. Drag the window anywhere on the desktop.

To re-size the Current Style window:
1. In the Window menu, make sure Freeze is not checked.

2. Move the selection cursor anywhere over the border of the
window. The cursor becomes a sizing cursor.

3. Drag the border to change the window’s size.

To return the Current Style window to its original
position:

1. Move the selection cursor over the window’s title bar.

2. Drag the window offscreen left. The window will pop back to its
original spot in the lower left corner.
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SAVING A STYLE

To save an unnamed style or to rename a style:
1. Activate the Style window (F6).

2. Choose Save Style As (F12) from the File menu.

3. In the dialog box, navigate to the drive and directory where you
will store the file.

4. Type a file name in the File Name text box, then click OK or press
Enter.

Note When you save a style file, Deko500 automatically attaches
“.sty” to the file name. Do not type a different extension.

To save a modified style:
1. Activate the Style window (F6).

2. Choose Save Style (Ctrl+S or Alt+F12) from the File menu.
Deko500 replaces the previously saved version of the file.

COPYING AND PASTING A STYLE

To copy and paste a style:
1. Select text whose style you wish to copy.

2. From the Edit menu, choose Copy (Ctrl+C), then Style.

3. Select the text or position the cursor where you will apply the
style.

4. From the Edit menu, choose Paste (Ctrl+V), or click the paste
button on the text bar.

Note When you copy a style, it is saved in the Windows NT
clipboard.

ASSIGNING A STYLE TO A STYLE PRESET

To assign the current style to a preset style button:
1. If the Preset Style window is not visible, choose Preset Styles

(Alt+F7) from the View menu.

2. Right-click the preset style button.



Working With Styles 68

Deko500 User’s Guide

To pick up a style from a graphic and assign it to a
preset style button:

1. Activate a graphic window.

2. Move the text cursor immediately to the left of a character in the
desired style.

3. Select the character or choose Pick Style from the Text menu. The
style of that character is now the current style.

4. Right-click the preset button.

Note If “Moving cursor sets font and look” is checked in the
Options/Preferences/Cursor dialog box, you can omit step 3.

To pick up multiple styles from a graphic and assign
them to preset style buttons:

1. Activate a graphic window.

2. From the Text menu, choose Pick Presets. Deko500 assigns the
first style in the graphic to the first preset button, the next style to
the second preset button, and so on.

RETRIEVING A STYLE

To select a preset style for typing:
1. Activate the Preset Style window (Alt+F7).

2. Click on one of the eight preset styles. That style is now the current
style.

To retrieve a style from a preset styles (.pst) file:
1. Activate the Preset Style window (Alt+F7).

2. Choose Open (Ctrl+O or F9) from the File menu.

3. In the dialog box, navigate to the drive and directory that contain
the preset styles file.

4. Type the file name in the File Name text box or choose it from the
File Name list box, then click OK or press Enter.

5. In the Preset Style window, click a preset button. That preset is
now the current style.
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To retrieve a style from a style (.sty) file:
1. Activate the Style window (F6).

2. Choose Open (Ctrl+O or F9) from the File menu.

3. In the dialog box, navigate to the drive and directory that contain
the style file.

4. Type the file name in the File Name text box or choose it from the
File Name list box, then click OK or press Enter. The style in the
.sty file is now the current style.

SAVING PRESET STYLES

To save the eight preset styles in a Presets file:
1. Activate the Preset Style window (Alt+F7).

2. Choose Save Preset Styles As (F12) from the File menu.

3. In the dialog box, navigate to the drive and directory where you
will store the file.

4. Type a new file name in the File Name text box, then click OK or
press Enter.

Note When you save a preset style file, Deko500 automatically
attaches “.pst” to the file name. Do not type a different
extension.

To save modified preset styles:
1. Activate the Preset Style window (Alt+F7).

2. Choose Save Preset Styles (Ctrl+S or Alt+F12) from the File
menu.Deko500 replaces the previously saved version of the file.
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SAVING A PRE-RENDERED STYLE

To save the current style as a pre-rendered style:
1. Activate the Style window (F6).

2. From the File menu choose Render and Save Style.

3. In the dialog box, navigate to the drive and directory where you
will store the file.

4. Type a file name in the File Name text box, then click OK or press
Enter.

Notes When saving a pre-rendered style, Deko500 renders each
character in the style’s font using the style’s look. For
complicated styles, this can take several minutes.

A pre-rendered style file occupies more disk space than a
normal style file. However, when you type pre-rendered
characters, they appear on screen more quickly than
characters that must be rendered “on the fly” as they are
typed.

Pre-rendered styles are indicated at the bottom of the
Style/Font window by a check next to Pre-rendered Style, and
in the Preset Style window by an (R) in front of the typeface
name.
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Graphics and Layers

VIDEO STANDARD

You can create Deko500 graphics in standard 4 x 3 aspect ratio or in the wider
16 x 9 aspect ratio used for some feature films, music videos and commercials.
The default video standard is standard NTSC.

To change the aspect ratio:
From the Options menu, select Hardware Settings, then choose
4 x 3 or 16x9.

To change the current video standard:
1. Right-click the Windows desktop, choose Properties from the

drop-down menu, then click the Pinnacle tab.

2. Click the Setup button, then choose PAL or NTSC.

3. Close all dialog boxes and windows and re-start Windows NT.

Notes When you change the video standard, Deko500 automatically
changes related input/output settings (number of scan lines,
pedestal, blanking width, etc.).

If this is the first time you are switching to a new standard,
you must recalibrate all levels and delays—Deko500
maintains a separate set of values for each standard.

ABOUT LAYERS AND BACKGROUNDS

Each graphic consists of a background and one or more layers.

The layers:
A layer is one element of a Deko500 graphic. A graphic can have an unlimited
number of layers. Each layer is one of two types:

� a text layer—also called a text field

� a geometric shape layer—a rectangle or an ellipse
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Layers are rendered in order from front to back, starting with the first layer.
Using the Layer menu, layers may be selected, reordered, hidden, moved,
rotated, scaled, etc.

The background:
Behind the final layer is the background, a full-screen rectangle that is either
off or on.

� When off, the background is effectively transparent. This is
where “live video” shows through when Deko500 graphics are
keyed over external video.

� When on, the background’s shader determines its color. Like
all Deko500 shaders, the background can be a solid color, a
ramp or a texture.
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 THE BACKGROUND

To turn the background on:
Do one of the following:
� Click the background button on the text bar.

� In the Layer menu, check Show Background.

To turn the background off:
Do one of the following:
� Click the background button on the text bar.

� From the Edit menu, choose Clear Background (Ctrl+F8).

� In the Layer menu, un-check Show Background.

To apply a color, ramp or texture to the background:
1. Follow the above instructions to turn on the background.

2. Activate the Background Shader window (Ctrl+F7).

3. Select a color, ramp, or texture shader.

To open a graphic directly into the background:
1. Activate a graphic window.

2. From the File menu, choose Replace Background (Ctrl+F9).

3. In the dialog box, navigate to the drive and directory that contain
the file.

4. Choose the file from the File Name list box or type the file name in
the File Name text box, then click OK or press Enter.

To turn the background into a layer:
In the Layer menu, choose Background to Layer.

Notes The background turns into a full-screen rectangle, but keeps
the shader it had as a background. The graphic now has a
transparent background.

If the background is an unnamed texture, you cannot turn it
into a layer.

To replace the background key with luminance from
a graphic file:

1. Activate a graphic window.
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2. From the File menu, choose Replace Background Key.

3. In the dialog box, navigate to the drive and directory that contain
the graphic file.

4. Choose the file from the File Name list box or type the file name in
the File Name text box, then click OK or press Enter.

Note This is useful if your graphic has a “companion” graphic in
which the luminance represents the key of the original.

ADDING A TEXT FIELD

To add a text field to a graphic, using the keyboard:
From the Layer menu choose Add Text Field. Deko500 adds a text
layer based on the boundaries of the safe title area.

To add a text field to a graphic, using the mouse:
1. Click the add-text-field button in the Tools window.

2. In the graphic, the cursor becomes a text layer cursor.

3. Drag the cursor to define the text field box.

Notes Holding Ctrl as you drag the cursor maintains a square field
box.

Deko500 always adds a new text field as the frontmost layer.

To create a new field or fields for selected text:
Select the text you wish to move to a new field or fields.

Do one of the following:
� To put selected text into a single new field, choose Text to

Field from the Text menu.

� To create a new field for each discrete group of selected text,
choose Text to Multiple Fields from the Text menu.
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To specify text field properties:
1. Select the text field.

2. Do one of the following:
� From the Layer menu, choose Properties.

� Open the Style window (F6) and choose Layer at the top of
the window.

3. Specify text field properties as desired.

TEXT FIELD PROPERTIES

Box

Defines the text field box. All values refer to the original text field
box, before any transformation — scaling, rotation or skewing.

Left, Top

The left and top edges of the text field box, in screen units.

Width, Height

The width and height of the text field box.

Aspect

The ratio of width to height.

Fixed aspect

Maintains the text field’s aspect ratio, whenever the width or
the height changes.

Transform

Defines how the text field box is transformed from its original
position:

H Scale, V Scale

Horizontal and vertical scale factors.

Rotation

Text field rotation in degrees.

Skew

Text field skew amount.

H Origin, V Origin

The center of rotation.

Same priority as previous layer

Specifies that the current layer appears in the same plane as the
layer in front of it. In other words, Deko500 renders this layer as if
it were part of the layer in front of it.

Hidden

Hides the text field.
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More

Displays more Text Field Properties.

Justification

Specifies default justification for text within the text field:

Horizontal

Justifies text between the left and right edges of the text field.

Vertical

Justifies text between the top and bottom of the text field.

Spread %

When Horizontal justification is set to “spread,” specifies how
much additional space to add between the letters within a
word, compared to the space added between words.

Word wrap

Automatically wraps words to the next row, as necessary, to keep
text within the text field box.

Auto-scaling

None

No automatic text scaling.

Scale to fit box

Scales text to exactly fit the text field.

Shrink to fit box

Scales text down, if necessary, to fit within the text field.

Text initialization

Determines how the text field is initialized when its graphic is
opened.

String

A text string to display in the field or the name of a macro file.

Usage

Specifies whether Deko500 use text, a macro (which must
return a string), or data in an .aut file, or requests data from an
automation host to initialize the field.

Macro

Uses a macro, which must return a string.

Query

Causes the Automation interface to request updates from the
host at user-specified intervals.

Replace

Replaces the graphic’s replace fields with the data in an
automation (.aut) file.
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Update freq

Specifies how often, in seconds, to run a macro or request data
from an automation host.

ADDING A RECTANGLE LAYER

To add a rectangle to a graphic, using the keyboard:
From the Layer menu choose Add Rectangle. A rectangle layer is
added at the center of the screen.

To add a rectangle to a graphic, using the mouse:
1. Click the rectangle button in the Tools window.

In the graphic, the cursor becomes a rectangle cursor.

2. Drag the cursor to define the rectangle.

Notes Holding Ctrl as you drag the cursor maintains a square
rectangle.

Deko500 always adds a new rectangle as the frontmost layer.

ADDING AN ELLIPSE LAYER

To add an ellipse to a graphic, using the keyboard:
From the Layer menu choose Add Ellipse. An ellipse layer is
added at the center of the screen.

To add an ellipse to a graphic, using the mouse:
1. Click the ellipse button in the Tools window.

2. In the graphic, the cursor becomes a ellipse cursor.

3. Drag the cursor to define the ellipse.

Notes Holding Ctrl as you drag the cursor constrains the ellipse to a
circle.

Deko500 adds a new ellipse as the frontmost layer.
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SPECIFYING LAYER PROPERTIES

To specify properties of a layer:
1. Select the layer.

2. Do one of the following:
� From the Layer menu, choose Properties

� Open the Style window (F6) and choose Layer at the top of
the window.

3. Specify layer properties as desired.

LAYER PROPERTIES

Box

Defines the box surrounding the ellipse or rectangle. All values
refer to the original box, before any transformation — scaling,
rotation or skewing.

Left, Top

The left and top edges of the ellipse or rectangle, in screen
units.

Width, Height

The width and height of the ellipse or rectangle.

Aspect

The ratio of width to height.

Fixed aspect

Maintains the shape’s aspect ratio, whenever the width or the
height changes.

Transform

Defines how the box is transformed from its original position.

H Scale, V Scale

Horizontal and vertical scale factors.

Rotation

Rotation in degrees.

Skew

Skew amount.

H Origin, V Origin

The center of rotation.

Same priority as previous layer

Specifies that the current layer appears in the same plane as the
layer in front of it. In other words, Deko500 renders this layer as if
it were part of the layer in front of it.
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Hidden

Hides the layer.

Lock

Prevents selection or modification of the layer.

SELECTING A LAYER

To select a layer in the active graphic:
Do one of the following:
� Click on an ellipse, rectangle or the box around a text field.

� Page Up or Page Down to the layer.

� Choose the layer from the list at the bottom of the Layer
menu.

To select the layer in front of the currently selected
layer:

Do one of the following:
� Activate the graphic window and press Page Up.

� From the Layer menu, choose Select Previous Layer
(Alt+Page Up).

To select the layer behind the currently selected layer:
Do one of the following:
� Activate the graphic window and press Page Down.

� From the Layer menu, choose Select Next Layer (Alt+Page
Down).

To select all layers in the active graphic:
Choose Select Layers from the Edit menu.

To select multiple layers in the active graphic:
1. Check the Select More toggle in the Edit menu.

2. Use one of the above methods to select each layer individually.

CLEARING A GRAPHIC

To clear the layers from the active graphic:
From the Edit menu, choose Clear Layers (F8). Deko500 replaces
the layers with a single, empty text field.
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To clear the background from the active graphic:
From the Edit menu, choose Clear Background (Ctrl+F8).

To clear the layers and the background from the
active graphic:

From the Edit menu, choose Clear All (press Alt+F8 or press F8
twice in rapid succession).

To have Deko500 prompt you to save modified files
before clearing them:

1. From the Options menu, choose Preferences.

2. Choose Prompts at the top of the Preferences dialog box.

3. In the Prompts dialog box, check Prompt to save before clearing or
opening window.

CLEARING OR DELETING A LAYER

To delete a layer:
1. Select the layer.

2. From the Layer menu, choose Delete Layer.

To delete all layers:
From the Edit menu, choose Clear Layers (F8).

Note Clear Layers replaces all the layers in the graphic with a
single, empty text field. The Background remains intact.

To clear text from a text field:
1. Select a text field.

2. From the Layer menu, choose Clear Text. The empty text field
remains in the graphic.
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CUTTING AND PASTING LAYERS

To cut or copy a layer:
1. Select the layer to be cut or copied.

2. Do one of the following:
� To cut the selected layer, from the Edit menu, choose Cut

(Ctrl+X), or click the cut button on the text bar.

� To copy the selected layer, from the Edit menu, choose Copy
(Ctrl+C), then Selected, or click the copy button on the text
bar.

To paste a layer:
1. If you are moving the layer to a different file, open the destination

file.

2. Select a layer.

3. From the Edit menu, choose Paste (Ctrl+V), or click the paste
button on the text bar.

Deko500 pastes the cut or copied layer directly in front of the
selected layer.

APPENDING A GRAPHIC TO SECOND GRAPHIC

To append one graphic to another graphic:
1. Open the first graphic file.

2. From the File menu, choose Append Layers (Alt+F9).

3. In the dialog box, navigate to the drive and directory containing the
second graphic file.

4. Choose the file from the File Name list box or type it in the File
Name text box, then click OK or press Enter.

Note Deko500 appends the second graphic’s layers behind the
layers of the first graphic. The second graphic’s background is
not used.
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REORDERING LAYERS

To move a layer forward or backward in a graphic:
1. Select the layer.

2. From the Layer menu, choose one of the following:

Send Back One Layer (Ctrl+-)

Swaps the layer with the layer behind it.

Bring Forward One Layer (Ctrl++)

Swaps the layer with the layer in front of it.

Send to Back (Alt+-)

Makes the layer the backmost layer, just in front of the
background.

Bring to Front (Alt++)

Makes the layer the frontmost layer.

PASTING LAYERS TO THE BACKGROUND

To combine all layers in the active graphic:
From the Layer menu, choose Layers to Background.

Note Deko500 copies the layers to combine them in the background.
The original layers remain until you choose Clear Layers (F8)
from the Edit menu.

COMBINING TEXT FIELDS

To combine multiple text fields into a single text field:
1. Select the text fields you wish to combine. Hold Ctrl and drag the

mouse to select the fields.

2. From the Layer menu, choose Text to Field.

Note Deko500 combines the fields into a single, new field.

MOVING A LAYER

To move a layer using the keyboard:
1. From the Options menu, choose Transform/Move (Ctrl+M).

2. In the Options menu, choose Transform and set increment of
change to Coarse or Fine (Ctrl+spacebar).
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3. Select the layer.

4. Hold down Alt and press arrow keys (↑↓→  ←) to move the layer
up, down, left or right.

To move a layer using the mouse:
1. Click the move button in the Tools window.

2. Select the layer.

3. Position the pointer near the border of the layer, so that the pointer
becomes the moving tool.

4. Drag to move the layer in any direction.

To specify numerical values for layer position:
1. Select the layer.

2. Activate the Style window.

3. Choose Layer at the top of the Style window.

4. In the Style window, enter values for Left, Top, Width and Height.
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JUSTIFYING A LAYER

To justify a rectangle, ellipse, or text layer:
1. Select the rectangle, ellipse, or text layer.

2. Do one of the following:
� On the text bar, click the appropriate justification button to

alter horizontal justification, vertical justification, or both,
then choose the desired setting.

� From the Text menu, choose Justify, then select a setting for
horizontal or vertical justification or both.

� Hold Ctrl down and press one of the numbers on the numeric
keypad to justify the rectangle or ellipse in the corresponding
position of the Program window.

7                8 9
Top left         Top center Top right

4                 5 6
Middle left    Middle center Middle right

1                 2 3
Bottom left    Bottom center Bottom right

0
Justification off             

ROTATING A LAYER

To rotate a layer using the keyboard:
1. From the Options menu, choose Transform/Rotate & Skew

(Ctrl+R).

2. In the Options menu, choose Transform and set increment of
change to Coarse or Fine (Ctrl+spacebar).

3. Select the layer.

4. Hold down Alt and press either the down arrow (↓ ) to rotate the
layer clockwise, or the up arrow (↑ ) to rotate it counterclockwise.

To rotate a layer using the mouse:
1. Click the rotate button in the Tools window.

2. Select the layer.
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3. Position the pointer near the border of the layer, so that the pointer
becomes the rotation tool.

4. Drag to rotate the layer.

To specify a numerical value for rotation:
1. Select the layer.

2. Activate the Style window.

3. Choose Layer at the top of the Style window.

4. Double-click the Rotation text box, then type or scroll to a value.

SCALING A LAYER

To scale a layer using the keyboard:
1. From the Options menu, choose Transform/Scale & Width

(Ctrl+W).

2. In the Options menu, choose Transform and set increment of
change to Coarse or Fine (Ctrl+spacebar).

3. Select the layer.

4. Hold down Alt and press either the up or down arrow (↑↓ ) to
increase or decrease  layer size, or the right or left arrow (→ ←) to
increase or decrease layer width.

To scale a layer using the mouse:
1. Click the scale button in the Tools window.

2. Select the layer.

3. Position the pointer over a handle on any side or corner of the
layer, so that the pointer becomes a scaling tool.

4. Drag to scale the layer.

To specify a numerical value for layer scaling:
1. Select the layer.

2. Activate the Style window.

3. Choose Layer at the top of the Style window.

4. In the Style window, enter values for H Scale and V Scale.

Note When you scale a text field, Deko500 scales all text within the
field. To change the size of the text field without scaling the
text, change the Box value in Text Field Properties.
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SKEWING A LAYER

To skew a layer using the keyboard:
1. From the Options menu, choose Transform/Rotate & Skew

(Ctrl+R).

2. In the Options menu, choose Transform and set increment of
change to Coarse or Fine (Ctrl+spacebar).

3. Select the layer.

4. Hold down Alt and press either the right arrow (→) to skew the
selected layer clockwise, or the left arrow (←) to skew
counterclockwise.

To skew a layer using the mouse:
1. Click the skew and rotate button in the Tools window.

2. Select the layer.

3. Position the pointer over the top-right-corner handle of the selected
layer, so that the pointer becomes the skewing tool.

4. Drag the handle to skew the layer.

To specify a numerical value for skewing:
1. Select the layer.

2. Activate the Style window.

3. Choose Layer at the top of the Style window.

4. Double-click the Skew text box, then type or scroll to a value.   
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Effects and Sequences

ABOUT DEKO500 EFFECTS

You can play back graphic files individually or in series, using a variety of
effects.

Transitional Effects

A Transitional Effect replaces the on-air (Program) graphic with
another (Preview) graphic.

clear

Clears the layers, background or all of the Program graphic.

cut

The Preview graphic replaces the Program graphic.

dissolve

The Program graphic fades out as the Preview graphic fades
in.

push up/down/left/right

The Preview graphic pushes the Program graphic offscreen.

repeat thru

Repeats the previous effect on each subsequent file up to the
specified file.

slide up/down/left/right

The Preview graphic slides on top of the Program graphic.

slideoff up/down/left/right

The Program graphic slides off to reveal the Preview graphic.

wipe up/down/left/right

The Program graphic is wiped off in place, revealing the
Preview graphic.

Text Effects operate primarily on text fields:

roll

Text scrolls continuously up the Program graphic, bottom to
top.
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crawl

Text moves continuously across the Program graphic, right to
left.

reveal

Text is typed onto the Program graphic, one character, word or
row at a time.

Macro Effect

One additional, powerful effect, command, is available with the
Automation option. The command effect runs the macro specified
in the File Name column during sequence playback.

CREATING A SEQUENCE

To open a Sequence window:
Do one of the following:
� From the Windows menu, choose Select Layout, then

Sequence Playback.

� From the View menu, choose Sequence (F11).

To create a sequence:
1. Activate the Sequence window.

2. From the Sequence menu, choose Clear Sequence, if necessary, to
clear all events.

3. Use the Tab or arrow keys to move to the various fields, enter the
following information for each event in the sequence:

Control/Time

Controls the timing of the event:

(blank)

Starts as soon as the previous event is done.

pause

Waits for a GPI trigger, right mouse click, or a Pause
Sequence (Pause) or Play Sequence (Alt+Enter) command
before playing.

delay

Pauses “Time” fields before playing.

stop

Stops the sequence, returning control to the user. To resume
playback, choose Play Sequence (Alt+Enter).

skip

Skips to the next event. This is useful for inserting a comment.
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loop

Repeats subsequent events “Time” times, until an “end” is
encountered. Loops can be nested.

end

Ends the current loop.

go to

Skips to event number in “Time” field.

Effect

See About Deko500 Effects for descriptions of effects.

Layers

The graphic element, e.g. layers, background, row, etc., on
which to perform the effect. Options depend on the specified
effect. Leave this column blank to perform the effect on the
entire graphic.

File Name

The name of the graphic file on which to perform the effect.
Press Ctrl+L or click the Browse button to select the file from
the Graphic Browser window.

Rate

The rate at which Deko500 performs the effect, as specified
here or with Sequence/Playback Rate.

Units

The unit of measurement for rate.

To save a sequence:
1. Activate the Sequence window.

2. From the File menu, choose Save Sequence As (F12).

3. In the dialog box, navigate to the drive and directory where you
will store the file.

4. Type a file name in the File Name text box, then click OK or press
Enter.

Note When you save a sequence, Deko500 automatically attaches
“.seq” to the file name. Do not type a different extension.

To append a sequence to the active sequence:
1. Activate the Sequence window in which you will insert the second

sequence.

2. From the File menu, choose Append to Sequence.

3. In the Append Sequence dialog box, navigate to the drive and
directory that contain the sequence (.seq) file you wish to append.
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4. Choose the file from the File Name list or type it in the File Name
text box, then click OK or press Enter.

COMPOSING ROLLS

To compose a graphic for a “roll” effect:
1. Activate a graphic window (F5).

2. In the Text menu, select Vertical Scrolling. A scrollable graphic
can be higher than one screen height.

3. Compose the text for the roll, scrolling down as necessary.

4. Save the graphic.

To run a roll effect:
1. Activate the Sequence window (F11).

2. Enter the graphic’s file name, specify “roll” as the effect, and enter
a playback rate.

3. Press Alt+Enter to run the effect.

To adjust duration or spacing for smooth roll
playback:

1. Activate the Sequence window (F11).

2. From the Sequence menu, choose Smooth Roll Playback
Adjustment, then select one of the following from the drop-down
menu:
� None—Turns off Smooth Roll Playback Adjustment.

Deko500 will not suggest any adjustments.

� Full and Half Vertical Resolution Rates—Deko500 suggests
adjustments based on acceptability of full and half vertical
resolution rates. Allows some aliasing.

� Only Full Vertical Resolution Rates—Deko500 suggests
adjustments based on acceptability of full vertical resolution
rates only. Allows only clean rates.

3. Choose OK or press Enter.

Note When you enter a playback rate for a roll effect, Deko500
displays any suggested adjustments in a dialog box. You can
choose to decrease or increase duration of the roll or original
line spacing of the graphic. Line spacing adjustments are not
offered when they would not be effective, e.g. if the document
is non-scrollable or if you choose a page-per-second rate.
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COMPOSING CRAWLS

To compose a graphic for a "crawl" effect:
1. Activate a graphic window (F5).

2. In the Text menu, select Horizontal Scrolling.

3. Compose the text for the crawl. If you are composing more than
one row of text to crawl, use the Enter key to create up to three
additional rows.

4. Save the graphic.

Notes By default, text composed without horizontal scrolling selected
crawls across the bottom of the screen.

You can create multi-row crawls of up to four rows of text

To run a crawl effect:
1. Activate the Sequence window (F11).

2. Enter the graphic’s file name, specify “crawl” as the effect, and
enter a playback rate.

3. Press Alt+Enter to run the effect. See Creating a Sequence.

To crawl text across a specific row of the screen:
1. Follow the above instructions for composing a graphic for a

“crawl” effect.

2. Before you save the graphic, move the cursor to the top row of
text. Press Alt+↓  to move the text down to the desired screen
location.

3. Follow the above instructions for running the crawl effect.

BROWSING FOR GRAPHICS IN A SEQUENCE

To browse for graphic files to add to a sequence:
1. Activate the Sequence window (F11).

2. Do one of the following:
� From the Sequence menu, choose Browse for Files (Ctrl+L).

� Select Browser from the View window (Ctrl+L).

3. Double-click a thumbnail to enter it into the sequence.
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To automatically advance to the next event while
browsing for graphics to put into a sequence:

1. Activate the Sequence window (F11).

2. In the Sequence menu, select Auto Advance From Browser.

Note If the next event is empty, Deko500 duplicates the last event.

SELECTING EVENTS

To select a single event:
Do one of the following:
� Double-click the event number.

� Use arrow keys (↑↓ ) to position the cursor on the event, then
hold Shift and press the down arrow (↓ ).

To select multiple events:
Do one of the following:
� Drag the mouse across the event numbers.

� Use arrow keys (↑↓ ) to position the cursor on the first or last
event you wish to select, then hold Shift and press an arrow
key (↑↓ ) to highlight the events.

To select all events from the current to the first event:
Do one of the following:
� Press Shift+Home.

� Press Ctrl+Shift+Home.

Note Which keys you press depends on how you have “Home and
End key behavior” set in Options/Preferences/Cursor.

To select all events from the current to the last event:
Do one of the following:
� Press Shift+End.

� Press Ctrl+Shift+End.

Note Which keys you press depends on how you have “Home and
End key behavior” set in Options/Preferences/Cursor.
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CUTTING AND PASTING EVENTS

To cut or copy an event or group of events:
1. Select an event or group of events.

2. Do one of the following:
� To cut events, choose Cut Events (Ctrl+X) from the Edit

menu, or click the cut button on the text bar.

� To copy events, choose Copy Events (Ctrl+C) from the Edit
menu, or click the copy button on the text bar.

To paste events into a sequence
1. Position the cursor at the event where you will insert cut or copied

events.

2. From the Edit menu, choose Paste Events (Ctrl+V), or click the
paste button on the text bar.

INSERTING AND DELETING EVENTS

To insert a blank event above the current event:
Choose Insert Event (Alt+Insert) from the Sequence menu.

To delete the current event:
Choose Delete Event (Alt+Delete) from the Sequence menu.

To delete a group of events:
1. Select the group of events to be deleted. See Selecting Events.

2. Press Delete.
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PLAYING A SEQUENCE

To specify the starting event:
1. Activate the Sequence window.

2. Press the up or down arrow (↑↓ ) to move the cursor to an event.
Deko500 always begins a sequence with the current event.

To play a sequence:
1. Activate the Sequence window.

2. Do one of the following:
� Click the play button in the Sequence window.

� Choose Play Sequence (Alt+Enter) from the Sequence menu.

In the Sequence window, the play button lights up green to
indicate that sequence playback is in progress.

PAUSING SEQUENCE PLAYBACK

To pause sequence playback:
Do one of the following:
� Click the pause button in the Sequence window.

� Choose Pause Sequence (Pause) from the Sequence menu..

The play button light goes off and the pause button lights up
yellow to indicate that a sequence has been paused.

To specify a pause in a sequence:
In the Control column, select pause.

During playback, Deko500 pauses the sequence and displays the
message “Sequence paused. Press Alt+Enter to continue.”
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To resume a paused sequence:
Do one of the following:
� Right-click the mouse.

� Click the pause button in the Sequence window.

� Choose Pause Sequence (Pause) from the Sequence menu.

� Choose Play Sequence (Alt+Enter) from the Sequence menu.

� Click the play button in the Sequence window.

� Use a GPI trigger.

The pause button light goes off and the play button lights up
green.

USING A GPI TRIGGER

To connect a GPI trigger:
1. Connect the triggering device to an available com port, if it is not

already connected. Refer to the figure below.

2. Restart Deko500.

1
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4
5
6
7
8
9

SW1J1

DE9S

R1
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(RED)

CD
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Optional circuitry

To enable GPI triggering:
1. Activate the Sequence window (F11).

2. From the Sequence menu, choose GPI Settings.

3. In the GPI Trigger Settings dialog box, check GPI Enabled, enter
the Com port name (e.g. COM2), then choose OK.
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STOPPING SEQUENCE PLAYBACK

To stop sequence playback:
Do one of the following:
� Press Esc.

� Click the stop button in the Sequence window.

� 
� Choose Stop Sequence Playback (Ctrl+Pause) from the

Sequence menu.
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User Preferences

DEKO500 LAYOUTS

Deko500 offers six standard layouts for creating, editing and playing back
graphics and macros:

Graphic Compose

To compose text and graphics.

Style Edit

To create and edit styles.

Sequence Playback

To control the playback of a series of graphic files.

Macro Edit

To create and edit macros.

Macro Record

To see a macro as it is being recorded.

Typeface Edit

To create and edit user-defined custom typefaces.

USER PREFERENCES

To specify preferences:
1. From the Options menu, choose Preferences.

2. In the dialog box, select the tab for the type of preferences you
wish to specify: Common, Prompts, Paths, Cursor, Marker or
Advanced.

Note Hardware settings are described in the Deko500 Installation
Guide.

To save current preferences:
In the Options menu, check Save Settings Now.
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To automatically save current preferences each time
you exit Deko500:

In the Options menu, check Save Settings on Exit.

To reset preferences to factory default settings:
1. From the Options menu, choose Preferences.

2. In the dialog box, choose the type of preference you wish to
change: Common, Prompts, Paths, Cursor, Markers or Advanced.

3. In the dialog box, choose Set this page to defaults, then click OK
or press Enter.

To reset all preferences, hardware settings or
software settings to factory defaults:

1. From the Options menu, choose Factory Defaults.

2. Select the type of settings you wish to change:
� User Preferences as set in Options/Preferences

� Hardware Settings as set in Options/Hardware Settings

� Software Settings, which includes all program settings not
explicitly set in Hardware Settings or Preferences — current
preset styles and shaders, window freeze status, etc.

3. Click OK or press Enter.
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COMMON PREFERENCES

Starting Layout

The desktop layout that appears each time you start Deko500.

Color used where graphic is transparent

The color Deko500 uses to fill all transparent areas of a graphic
(areas filled with live video when the Deko500 keyer is turned on).
The default color is dark gray. To select a new color, click the
color button.

Decimal tab char

The character that Deko500 uses as a decimal point when decimal-
aligning rows of text. The default decimal tab character is a period.

On re-boot, automatically log on to NT

Check this box to have Deko500 automatically started whenever
you re-boot Windows NT. You must enter your password for this
feature to work properly.

Keyboard

If you have the FastAction Keyboard option, you can choose to
enable the FastAction function keys or use the function keys as
you would on a standard keyboard. You can also choose to enable
the numeric keypad for FastAction access to reading in graphic
files.

PROMPTS PREFERENCES

Prompt to save before clearing or opening a window

Prompts you to save a modified graphic or macro before clearing it
or opening a file into it.

Prompt to save before closing a window

Prompts you to save any modified file before closing its window or
exiting Deko500.

Prompt if file not found

Displays an error prompt any time Deko500 cannot find a graphic,
style, or custom typeface file used in a graphic. If this option is not
selected, Deko500 skips missing files during sequence playback,
and displays missing textures as solid black.

Prompt before exiting Deko500

Prompts you for verification each time you attempt to exit the
program.



Types of Preferences and Preference Options 100

Deko500 User’s Guide

Prompt on file open if name matches but extension does not

Prompts you to verify that you wish to open a file if the file name
you entered has an extension that does not match the file type for
the currently active window.

Prompt if a graphic is being converted from a different video
standard or file format

Displays a prompt any time you try to open a graphic file recorded
in a different resolution. This can happen if the graphic was
recorded under a different video standard (PAL, NTSC, PAL 16x9,
or NTSC 16x9) or imported from another file format (Windows
bitmaps, Targa files, etc.).

Although Deko500 automatically converts these graphics to the
current resolution, the conversion process takes time, which can
slow recall time and sequence playback. You may want to re-
record these files in the current resolution using the Save As (F12)
command from the File menu.

PATHS PREFERENCES

Current Directory

Specifies the three current directories based on file types:

graphics (.dko), sequences (.seq), automation (.aut)

styles (.sty), preset styles (.pst), shaders (.shd)

macros (.mcr)

Search Path

Specifies the three directory search paths based on file types:

graphics (.dko), sequences (.seq), automation (.aut)

styles (.sty), preset styles (.pst), shaders (.shd)

macros (.mcr)
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CURSOR PREFERENCES

Text cursor style

Controls how the text cursor is displayed, as an I - beam or as a
box. Does not affect how the cursor functions.

                                         
    I - beam cursor             Box cursor

Cursor movement

Determines how the cursor moves:

By pixels

The cursor moves in 1-pixel (fine) or 10-pixel (coarse)
increments. The status bar displays current dot and line
position with the origin at the top left corner. The number of
pixels on the full screen depends on the video standard:
720x486 for NTSC or 720x576 for PAL.

By screen units

The cursor moves in screen units. Increments are independent
of the current video standard, and equal either 1/500 (fine) or
1/50 (coarse) of screen height. The status bar displays current
x and y coordinates, with the origin at the center of the screen.

To select “coarse” or “fine”, choose Transform/Coarse or Fine
(Ctrl+spacebar) from the Options menu.

Show text cursor

Shows or hides the text cursor.

Moving cursor sets font and look

Automatically changes the current style, whenever you move the
text cursor, to reflect the style of the character to the left of the
cursor.
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Home and End key behavior

Determines whether the Home and End keys behave as they
typically do in Windows applications, or as they do on a traditional
television character generator.

KEY CHAR. GENERATOR WINDOWS

Home sends cursor to sends cursor to start
beginning of text field of row

Shift+Home selects text from selects text from
cursor to beginning cursor to beginning
of text field of row

Ctrl+Home sends cursor to sends cursor to
beginning of row beginning of text field

End sends cursor to right sends cursor to end
of last character in of row
text field

Shift+End selects text from cursor selects text from
through last character cursor through end
in text field of row

Ctrl+End sends cursor to end sends cursor to right
of row of last character in

                                                 text field

MARKER PREFERENCES

Show

Specifies whether to display (checked) or hide (unchecked) the
following markers:

Safe title area (% from edge of screen)

Specifies the top, bottom, right and left of the safe title area.
Values represent a percentage of the distance from the specified
edge of the screen to the opposite edge.
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ADVANCED PREFERENCES

Resolution

Specifies screen units, the number of vertical measurement units
per screen. Typical (but not mandatory) settings are 486 for NTSC
and 576 for PAL. This is a reference number only, not related to
the pixel resolution of the output frame buffer. You can set it to
any convenient value.

Text rendering

Specifies a time limit for Deko500 to render text. If Deko500 is
unable to fully render text within this time, it automatically
substitutes low-resolution text. Low-resolution text appears jaggy
on the desktop monitor, without details (such as edges and
shadows). Once Deko500 has finished rendering, it replaces the
low-resolution text with the fully rendered text

Note Deko500 never displays low-resolution text on video output,
only on the desktop.

Word wrap enabled

Enables word wrap automatically for all new text fields.

Font size based on

Deko500 allows you to specify whether to base font size on row
height or cap height.
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Managing Files

OPENING FILES

To open an existing file:
1. From the File menu, choose Open (Ctrl+O or F9).

2. In the Open dialog box, navigate to the drive and directory that contain
the file.

3. Choose the file from the File Name list box or type the file name in the
File Name text box, then click OK or press Enter.

4. The next time you call up the File Open dialog box, you will be
prompted with the name of the next file in the current directory. Use the
cursor up and down keys to scroll through other file names.

Warning Unlike many Windows applications, Deko500 does not always
open a new window when you open a file. If a window of the
appropriate type is already open, Deko500 opens the file into
that window, replacing the previous file. Be sure to save any
modified file before opening another file in the same window.

To open a new file:
1. Activate a window for the type of file you wish to open.

2. From the File menu, choose New (Ctrl+N). This command varies
depending on what type of window is active. For example, if a Style
window is active, the command is New Style.

Note When you open a new file, it is opened into a new window.
Other open files remain open behind the new file.

Deko500 only allows one Program Window to be open at a
time. You may have two open preset Style Windows.
Sequence, Macro, or Custom Typeface allow multiple open
windows.

.

To re-open the current file:
From the File menu, choose Revert.
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To open one of the four most recently opened files:
Choose a file from the list near the bottom of the File menu.

CLOSING FILES

To close the file in the active window:
1. Save the file, if desired.

2. Do one of the following:
� Double-click the control icon in the upper left corner of the active

window.

� From the File menu, choose Close (Ctrl+F4). This command is
different for each type of file. For example, if a Style window is
active, the command is Close Style.

To close all open files and exit Deko500:
1. Save any files, if desired.

2. Do one of the following:
� Double-click the control icon in the upper left corner of the

Deko500 application window.

� From the File menu, choose Exit (Alt+F4).

To have Deko500 prompt to save modified files before
closing them:

1. From the Options menu, choose Preferences.

2. In the Deko500 Preferences dialog box, choose Prompts.

3. Select “Prompt to save before closing,” then click OK or press Enter.

SAVING FILES

Deko500 always saves the file in the active window.

Deko500 automatically attaches the standard extension to the file name. For example,
a macro file named myfile is saved as myfile.mcr.

Standard extensions in Deko500 include:

Deko Graphic (.dko) Macro (.mcr)
Preset Styles (.pst) Sequence (.seq)
Preset Shader (.shd) Custom Typeface (.fac)
Style (.sty)
An asterisk (*) next to a file name on a window’s title bar indicates that the file has
been modified since it was last saved.

When you save a file under a new name, Deko500 prompts with the name of the most
recently saved file and appends a numeric suffix. Use up or down arrows to increment
or decrement this number.
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To save an untitled file or to save a file under a new
name:

1. From the File menu choose Save As (F12). This command varies
depending on what type of window is active. For example, if a Style
window is active, the command is Save Style As.

2. In the dialog box, navigate to the drive and directory where you will
save the file.

3. Type a file name in the File Name text box, then click OK or press
Enter.

To save an existing file:
From the File menu, choose Save (Ctrl+S or Alt+F12). Deko500
replaces the previous version of the file.

DELETING FILES

Warning This procedure permanently erases files from your computer’s
disk drive.

To delete a file or group of files:
1. From the File menu, choose Delete File (Ctrl+Delete).

2. In the dialog box, navigate to the drive and directory that contain the
file(s).

3. Choose the file(s) from the File Name list box or type the file name in
the File Name text box, then click OK or press Enter.

4. Click OK or press Enter to confirm the deletion.

SHARING FILES

If Deko500 is networked to other computers, you can share files with other users on
the network. Using File Manager, you can make any directory a shared directory,
allowing other users to access all files in that directory. By default, a directory is not
shared unless you explicitly share it, or one of its parent directories is already shared.

For more information, please refer to Sharing a Directory in File Manager Help.

CREATING A DIRECTORY

To create a directory:
1. From the File menu choose Create Directory.

2. In the dialog box, navigate to the drive and directory where you will add
the new directory.

3. Type a directory name in the Directory Name text box, then click OK or
press Enter.
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Note When you create a new directory, the new directory does not
automatically become the current directory.
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Working with Macros

INTRODUCTION TO MACROS

COMMANDS AND MACROS

A command is an instruction to Deko500 to perform a specific function.

The Deko500 user interface (menus, shortcut keys, etc.) implicitly executes
commands. Every time you strike a key or select a menu item, you invoke a command
that directs Deko500 to perform a function.

If you know the command name for the function you wish to perform, you can invoke
the command explicitly by entering its name on the Command Bar.

For example, the command to clear the current graphic is clear graphic. Try it.
Press F4 to select the Command Bar, type clear graphic, then press Enter.

Every command recognized by Deko500 is listed in the Deko500 Commands section
of this manual and described in detail in the accompanying Deko500 Command
Reference.

A macro is a sequence of Deko500 commands. You can name and store a macro by
saving it in a file. You can invoke a macro in the same way you can invoke a
command, by typing the macro name on the Command Bar and pressing Enter.

Once you learn Deko500’s macro language, you will be able to write and edit macros
directly in the Macro window. For now, you can follow the simple instructions in this
section to quickly begin creating macros using Deko500’s macro recorder.
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WORKING IN THE MACRO WINDOW

Whether writing a new macro or editing an existing macro, you will be working in the
Macro window:

To activate the Macro window:
Do either of the following:
� From the Window menu, choose Layouts, then Macro Edit.

� From the View menu, choose Macro (F2).

To open a new macro file:
1. Activate the Macro window

2. From the File menu, choose New Macro (Ctrl+N)

To open an existing macro:
1. From the File menu, choose Open (Ctrl+O or F9).

2. In the dialog box, navigate to the drive and directory that contain the
macro file.

3. Choose the macro from the File Name list box or type the macro name
in the File Name text box, then click OK or press Enter.

Warning Unlike many Windows applications, Deko500 does not
automatically open a new window when you open an existing
macro. If the Macro window is already open, Deko500 opens
the macro into that window, replacing any previous macro. Be
sure to save any modified macro before opening another
macro in the same window.

To append a macro to the active macro:
1. In the active Macro window, position the cursor where you will insert

the second macro.
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2. From the File menu, choose Append to Macro.

3. In the Append Macro dialog box, navigate to the drive and directory that
contain the macro (.mcr) file you wish to append.

4. Choose the file from the File Name list or type it in the File Name text
box, then click OK or press Enter

USING THE MACRO RECORDER

RECORDING A MACRO

To record a macro:
1. To turn the macro recorder on, do one of the following:

� Click the record button at the far right end of the text bar.

� Choose Record Macro (Ctrl+F2) from the Macro menu.

On the text bar, the button lights up red to indicate that the macro
recorder is on.

2. Use the keyboard and/or mouse to perform the sequence of actions that
will constitute the macro.

3. To turn the recorder off, do one of the following:
� Click off the record button on the text bar.

� Choose Record Macro (Ctrl+F2) from the Macro menu.

� Press F2 to turn the recorder off and activate the Macro window.

To view the macro you just recorded:
Do one of the following:
� From the Window menu, choose Select Layout, then Macro Edit.

� From the View menu, choose Macro (F2).

PLAYING A MACRO

To play the active macro:
Do one of the following:
� Click the play button near the right end of the text bar.

� Choose Play Macro (Alt+F2) from the Macro menu.

On the text bar, the play button lights up green to indicate that a macro
is playing.
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Notes The name of the macro that is currently playing appears on
the status bar.

If no Macro window or Sequence window is active, Deko500
plays the macro in the most recently activated Macro window.

To play a macro file:
1. If the Command Bar is not visible, choose Command Bar (F4) from the

View menu.

2. Click the text box on the Command Bar.

3. Type the macro file name. You do not have to type the .mcr extension.

4. To specify macro parameters, click the Prompt button and edit
parameters in the dialog box.

5. Click Play or Press Enter.

PAUSING A MACRO

To pause a macro:
Do one of the following:
� Click the pause button near the right end of the text bar.

� Choose Pause Macro (Pause) from the Macro menu.

On the text bar, the play button light goes off and the pause button lights
up yellow to indicate that a macro in progress has been paused.

To resume a paused macro:
Do one of the following:
� Click the pause button near the right end of the text bar.

� Choose Pause Macro (Pause) from the Macro menu.

On the text bar, the pause button light goes off and the play button lights
up green.
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STOPPING MACRO PLAYBACK

To cancel macro playback:
Do one of the following:
� Click the stop button near the right end of the text bar.

� Choose Stop Macro Playback (Ctrl+Pause) from the Macro menu.

SINGLE-STEPPING A MACRO

To advance a paused macro one step:
Do one of the following:
� Click the play button at the right end of the text bar.

� Choose Play Macro (Alt+F2) from the Macro menu.

The blinking cursor in the Macro window indicates where the macro is
paused.
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EDITING A MACRO

To open and edit a macro (.mcr) file:
1. Do one of the following, if necessary, to activate the Macro window:

� From the Window menu, choose Select Layout, then Macro Edit.

� From the View menu, choose Macro (F2).

2. From the File menu, choose Open (Ctrl+O or F9).

3. In the dialog box, navigate to the drive and directory that contain the
macro file.

4. Choose the file from the File Name list or type it in the File Name text
box, then click OK or press Enter.

5. Edit the macro as desired.

Note You may import a text (.txt) file as a macro just by opening it
in the Macro window.

To edit macro parameters:
1. If the Command Bar is not visible, choose Command Bar (F4) from the

View menu.

2. Click the text box on the Command Bar.

3. Type the macro file name.

4. Click the Prompt button on the Command Bar.

5. Specify parameters in the dialog box, then click OK or press Enter.

SAVING A MACRO

To save a macro under a new name:
1. Activate the Macro window.

2. From the File menu, choose Save Macro As (F12).

3. In the dialog box, navigate to the drive and directory where you will
store the file.

4. Type a new file name in the File Name text box, then click OK or press
Enter.

Note When you save a macro, Deko500 automatically attaches
“.mcr” to the file name. Do not type a different extension.
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To save a modified macro:
1. Activate the Macro window.

2. From the File menu, choose Save Macro (Ctrl+S or Alt+F12) to replace
the previous version of the .mcr file.

APPENDING TO A MACRO

To append a macro to the active macro:
1. In the active Macro window, position the cursor where you will insert

the second macro.

2. From the File menu, choose Append to Macro.

3. In the Append Macro dialog box, navigate to the drive and directory that
contain the macro (.mcr) file you wish to append.

4. Choose the file from the File Name list or type it in the File Name text
box, then click OK or press Enter.

CONVERTING A GRAPHIC OR SEQUENCE INTO A MACRO

To convert a graphic or sequence into a macro:
1. Open the graphic or sequence you wish to convert.

2. Do one of the following:
� From the Macro menu, choose Convert Graphic to Macro.

� From the Sequence menu, choose Convert Sequence to Macro.

3. Deko500 determines the sequence of macro commands needed to
recreate the graphic or sequence and inserts them into the active macro.

To view the macro:
Do one of the following:
� From the Window menu, choose Select Layout, then Macro Edit.

� From the View menu, choose Macro (F2).
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MACRO PROGRAMMING LANGUAGE
The Deko500 Macro Programming Language combines many of the features of C and
BASIC. It supports many standard programming constructs such as real and integer
arithmetic, variables, arrays, objects, loops, conditional statements and subroutines.

Since each topic in this chapter builds upon information covered in previous topics,
we suggest you read the topics in the order presented, especially if you are new to
programming.

If you have done some programming, a quick review of this section may be all you
need to start writing your own Deko500 macros.

COMMANDS

Commands are the basic building blocks of any macro. In macros, commands are
similar to the verbs, or action words, we use in speech.

A command is a direct instruction to Deko500 to perform a function. A Deko500
command may include alphanumeric characters and underscores (_). The first
character may not be a number. A few examples of valid commands are:

justify

rotate

str2num

edge_shader

Deko500 commands fall into several categories. Some categories correspond directly
with items on the Deko500 menu bar (e.g., File, Edit, Channel, Layer, Macro,
Sequence, etc.). Other categories exist for commands that are language specific, such
as program flow commands (e.g. if, while, return) and mathematical
functions (e.g., sqrt, cosine).

The Deko500 Commands section in this manual lists all Deko500 commands by
category.

COMMAND SYNTAX

Earlier, we compared commands to verbs. Just as adverbs modify a verb, parameters
modify a command.

Each command’s parameters are specified in an order particular to that command.
The example below shows the usual order of parameters for the justify command:

justify [horizontal=] [vertical=]

In addition to a specific position, each parameter has a name, a keyword, such as
“horizontal”, “vertical”, etc. Because each parameter has a specific position in
command declaration, however, using a keyword to assign a value is necessary only
when the parameter is specified out of its usual order.

Even then, you may abbreviate a keyword to only as many characters as necessary to
avoid ambiguity.

Here are several possible variations of the justify command:

justify default (unchanged) justification

justify left bottom horizontal left; vertical bottom
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justify vertical=top top vertical justification;
horizontal unchanged

justify v=top top vertical justification;
horizontal unchanged

Most parameters are optional parameters; they have default values and do not
require specification unless you are assigning new values to them.

The justify command has two optional parameters.

justify [horizontal=] [vertical=]

Brackets are a convention used throughout this manual and in on-line help to indicate
that a parameter is optional. Do not use brackets when writing an actual macro.

A required parameter has no default value, so you must specify its value. The
file_open command is a command with a required parameter:

file_open name=

You must supply the name of the file to satisfy the name parameter:

file_open myfile

A command and its parameters normally occupy one line of a macro, and a space
separates one parameter from the next. If a command and its parameters do not fit on
one line, a backslash (\) at the end of the line indicates that the command continues on
the next line:

file_save [name=] [comment=] [type=] [number=] \

[channel=] [-all] [glyphs=] [-bitmap] \

[-auto_comment] [-compress]

Note that the second and third lines are indented. This is just a matter of good
penmanship; indentation and blank lines do not affect macro execution, but make the
macro easier to read and edit.

Use semicolons (;) to separate multiple commands that appear on one line:

type "Hello there";newline

As in the above example, if a parameter value is a string that includes a space, enclose
the value in quotation marks.

PARAMETERS

Parameters fall into several categories based on value type.

Real

A real parameter specifies any numeric value, whole or fractional, e.g. 3, 9.7, -0.9,
etc.

Very large or small real values may be expressed in exponent form. For example,
2.5e-10.

An example of a real parameter is the input parameter of the sqrt (square root)
command:

sqrt input=
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Integer

An integer parameter specifies a whole number value, either positive or negative,
e.g., 3, 12967, -14, 0, etc.

If you specify a real value for an integer parameter, Deko500 ignores the fractional
component.

An example of an integer parameter is the number parameter of the
select_style_preset command, which sets the current style from the list of
preset styles:

select_style_preset [number=]

Switch

A switch parameter specifies a parameter that is either true or false. A true parameter
is either preceded by a hyphen (-) or followed by =1, while a false parameter is either
preceded by -no or followed by =0.

The following illustrates examples of the all switch parameter of the tab_clear
command:

tab_clear -all or tab_clear all=1

tab_clear -noall or tab_clear all=0

String

A string parameter specifies one or more alphanumeric characters (e.g., a letter, word
or sentence).

A string that contains spaces or non-alphanumeric characters must be enclosed in
quotation marks.

A typical string parameter is the name parameter of the file_open command,
which opens the file specified by name:

file_open name=

For example, to open the file named “my file”, the value of the parameter would be
the string, “my file”:

file_open “my file”

Choice

A choice parameter specifies one item from a list of possible choices.

Both parameters of the justify command are choice parameters:

justify [horizontal=] [vertical=]

Possible choices for horizontal are: left, right, center, full, spread,
off and unchanged; and for vertical: top, bottom, center, full,
baseline, off and unchanged.

Object

An object parameter specifies an object, a collection of values that is treated as a
single item. Typical objects in Deko500 include colors, shaders, ellipses, rectangles,
boxes, fonts and looks.

The letter command, which adds a letter to a text field, includes two object
parameters, font and look:

letter [character=] [font=] [look=] [tx=]\

[ty=] [code=] [insert=] [-show] [-attach]
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The font parameter specifies an object created by the font command, and the
look parameter specifies an object created by the look command.

You create an object with a command. For example, the rgb command creates a
color object:

rgb red= green= blue=

The elements of an object correspond exactly with the of the command that created it.
The parameters of the rgb command represent the amounts of red, blue and green
that make up the color.

You can assign an object to a variable:

$gold = rgb 100 100 0

You can specify an object parameter with an embedded command, using parentheses:

ramp top_left=(rgb 60 60 0)

Accessing Object Elements
To access an element to edit its value or to assign it to a variable for use elsewhere,
use the element operator.

To edit $gold to re-specify the amount of green:
$gold:green = 80

To assign the green element of $gold to the variable $grn:
$grn = $gold:green

List

A list parameter, also known as a repeating parameter, specifies a list of one or
more values. Depending on the command, the values on the list may or may not be of
the same type. A command can have no more than one list parameter, which is
usually the last parameter.

The message command has a list parameter that specifies a list of
strings to output on the Status Bar:

message list=

message "Enter" "file" "name" "of" $song

VARIABLES

In Deko500, a variable name can include any upper or lower case alphanumeric
character as well as the special character, underline (_). The first character is always a
dollar sign ($), and the character immediately after the dollar sign cannot be a
number.

To make macros easier to read and understand, it’s a good idea to use variable names
that are readily associated with the values they represent. For example, it’s easy to
guess what these variables are used for:

$age

$name

$phone

You do not explicitly declare a variable’s data type; the data type is determined when
a value is assigned to the variable.

These examples illustrate how variable assignment determines data type:
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$i = 1
Integer

$XY = 3.5 Real

$message = "Goodbye Cruel World" String

If you try to use an uninitialized variable, Deko500 stops executing the command or
macro and displays an error prompt.

A variable may be an element of an array, in which case its name is the name of the
array followed by a subscript that identifies its location in the array. A subscript must
be an integer or an expression that returns an integer.
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For example, an array named $table might include these elements:

$table[3]

$table[42]

$table[$count+1]

$table[9999]

Deko500 allocates array elements as needed. The subscripted variables in the above
example will occupy only four variable slots, not ten thousand.

By default, most variables are local variables. A local variable is allocated
temporarily during macro playback, then deleted automatically when the macro stops.
One macro cannot reference a second macro’s local variables, even if the second
macro is a subroutine of the first.

Global variables must be declared with the global command, and can be shared
among multiple macros. Once declared, a global variable remains until you either
delete it by using the free command, or exit Deko500.

Deko500 has a set of built-in global variables, known as system variables, which
provide information about the state of your system. System variables are preceded by
the at-sign symbol (@), and are often referred to as at-sign variables.

Some system variables are read-only; you cannot change their values. Examples of
read-only system variables are @lines and @dots, which describe the current video
standard, and the pre-defined colors @red, @blue and @green.

Other system variables may be assigned values. For example, the system variable
@wordwrap can be set to 0 to disable word wrap, or 1 to enable it

OPERATORS

In the previous topic, you saw that variable assignment is indicated by the equal sign
(=), which is just one of many symbols, known as operators, that represent operations
performed on data.

The Deko500 Macro Programming Language uses a subset of the operators available
in C, as well as a few additions specific to Deko500.

Arithmetic operators perform mathematical operations within expressions:

Operator Expression Operation

+ $a + $b adds $a and $b

- $a - $b subtracts $b from $a

* $a * $b multiplies $a by $b

/ $a / $b divides $a by $b

% $a % $b calculates remainder of $a/$b

- -$a negates the value of $a

You can perform arithmetic operations on one-character strings by adding or
subtracting integer values to the character. For example, the expression "A"+1 has
the value "B".

Using single quotation marks in an expression yields the numerical value of the
character key. For example, ’A’+1 has the value 66.
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Comparison operators compare values and determine whether an expression is true
or false. An expression is any combination of variables, commands and operators that
results in a single value.

An expression is true if its value is non-zero; it is false if its value is 0.

Operator Expression Value

== $a == $b True if $a equals $b

> $a > $b True if $a is greater than $b

>= $a >= $b True if $a is greater than or equal to $b

< $a < $b True if $a is less than $b

<= $a <= $b True if $a is less than or equal to $b

!= $a != $b True if $a does not equal $b

! !$a True if $a is false (equals 0)

&& $a && $b True if both $a and $b are true

|| $a || $b True if either $a or $b is true

There is one string operator, for concatenation of strings:

Operator Expression Operation

%% $a %% $b joins string $b to the end of string $a

Strings can be compared for equality and inequality using the comparison operators
== and !=.

Additional string operations are performed by commands. Please refer to the Deko500
Commands section of this manual.

The index and element operators allow direct access to values that are elements of
arrays or elements of objects:

Operator Expression Data Accessed

[ ] $a[$b] item $b of array $a

: $a:$b $b element of object $a

Bitwise operators perform operations on integers based on bit position:

Operator Expression Operation

<< $a << 2 shifts $a left by 2 bit positions

>> $a >> 4 shifts $a right by 4 bit positions

~ ~$a complements 1 bits to 0; 0 bits
to 1

& $a & $b bitwise AND of $a and $b

| $a | $b bitwise OR of $a and $b

^ $a ^ $b exclusive OR of $a and $b
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The assignment operator assigns a value to a variable, and may simultaneously
perform other operations:

Operator Expression Operation

= $a = $b assigns the value of $b to $a

+= $a += 1 adds 1 to $a, assigns total to $a

-= $a -= 5 subtracts 5 from $a, assigns total to $a

*= $a *= 2 multiplies $a by 2, assigns product to $a

/= $a /= 2 divides $a by 2, assigns quotient to $a

%= $a %= 3 divides $a by 3, assigns remainder to $a

>>= $a >>= 4 shifts $a right 4 bits

<<= $a <<= 4 shifts $a left 4 bits

%%= $a %%= "ok" concatenates “ok” to $a, assigns string to $a

&= $a &= 2 bitwise AND $a and 2, assigns result to $a

|= $a |= 2 bitwise OR $a and 2, assigns result to $a

^= $a ^= $b bitwise exclusive OR $a and $b, assigns result to
$a

Deko500 uses the same order of operator precedence used by C:

[] subscript, element

() parentheses

! ~ - logical not, one’s complement, unary minus

* / % multiply, divide, modulo

+ - plus, minus

<< >> left shift, right shift

%% concatenate strings

< <= > >= comparisons

== != equality, inequality

& bitwise AND

^ bitwise exclusive OR

| bitwise OR

&& logical AND

|| logical OR

= += -= etc. assignments

Use nested parentheses to avoid ambiguity in expressions. For example:

$inc = ( ($i+1) * ($j+1) ) / 100
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COMMENTS

A comment is text within a macro that does not affect the function of the macro.

Comments make macros easier to analyze and edit, especially if the macro was
written some time ago or written by another programmer. Many programmers
consider a program incomplete without comments. You may find the same to be true
of your macros.

A single-line comment starts with a pound sign (#). Deko500 ignores text to the right
of the pound sign.

# This comment is on a line by itself.

command # This one shares a line with a command.

Another way to create a comment is to precede the comment with /* and close it
with */. Deko500 ignores text between /* and */. This way, you can create
multiple-line comments.

/* This is a multiple-line comment.

None of this text affects the function

of this macro; Deko500 ignores

every line of it */

CONDITIONAL COMMANDS AND LOOPS

Conditional commands instruct Deko500 to execute specific commands only under
certain circumstances. Deko500 supports the conditional commands if, else and
elseif.

The if command includes a test expression, which evaluates to zero (false) or non-
zero (true). A list of one or more commands, then an end command, follows the if
command:

if expression=

# commands

end

If the expression is true, Deko500 executes the commands between if and end.

The if command is often used with the else command:

if expression=

# commands

else

# commands

end

If the expression is true, Deko500 executes the commands between if and else;
otherwise, the commands between else and end are executed.

You can introduce more conditional actions by nesting conditions…

if $a==1

type "Hello"
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else

if $a==5

type "Good-bye"

else

type "Wish you were here"

end

end

…or more elegantly by using the elseif command:

if $a==1

type "Hello"

elseif $a==5

type "Good-bye"

else

type "Wish you were here"

end

Notice how indentation makes conditional statements easier to read. Indenting the
commands between if and its corresponding end is a good practice.

Loop commands instruct Deko500 to execute a series of commands multiple times.
Loop commands include loop, while and for.

The easiest way to define a loop is to use the loop command and specify the number
of iterations:

loop [count=]

# commands

end

The macro executes the command sequence between loop and end the number of
times specified by the count parameter. After the loop, the macro continues with the
first command after end.

If you do not supply a count, the loop will go on forever or until you cancel macro
playback or use a conditional statement to end the loop.

The following macro types “hello” five times, then breaks out of the loop:

$a=1

loop

type "hello";newline

$a = $a+=1

if $a>5

break

end
end

You also can break out of a loop with the continue command, which restarts a
loop at the top without executing commands after continue.



Macro Programming Language 126

Deko500 User’s Guide

This macro uses such a loop to test for and skip odd numbers and, as a result, types
only the even numbers from 1 through 10:

$a=0

loop 10

$a = $a+=1

if $a&1

continue # skip odd numbers

end

type $a

end

Conditional loop commands define both the loop and its conditional test.

The while command continues looping as long as its test expression is true.
Deko500 evaluates the test expression prior to each iteration of the loop, and as long
as the result is true, continues the loop:

$a=1

while $a<=5

type "hello";newline

$a+=1

end

The for command, for makes an incremental loop, such as the one above, more
concise:

for $a=1 $a<=5 $a+=1

type "hello";newline

end

The initial expression $a=1 is executed once. The test expression $a<=5 is
evaluated prior to each iteration of the loop; if the test result is true, the loop
continues. The increment expression $a+=1 is executed after each loop iteration.

SUBROUTINES

To a user, there is no practical difference between Deko500’s built-in commands and
the macros that you write and store under file names. You can have one macro run
another macro, simply by using the macro file name in the same way you would use a
command.

When one macro “calls” another, the second macro is considered a subroutine of the
first. You can call an existing macro as a subroutine or create one within your macro.

The command command defines a local subroutine, which ends with the end
command.

The following macro creates, then runs the macros “boy” and “girl” as subroutines.

command boy
type "It’s a boy!"

end
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command girl
type "It’s a girl"

end

if $name == "Amy"
girl

elseif $name == "Meg"
girl

elseif $name == "Mickey"
boy

end

The subroutines “boy” and “girl” are local to this macro. When the macro ends, the
subroutines, like the variables, vanish.

RETURN VALUES

The return command directs Deko500 to stop the current macro or subroutine and
return the value of its expression parameter to the macro that called it.

return [expression=]

For example, you might have a simple command called test that returns 1 if
successful, or 0 if not:

command test
if $name == "Amy"

return 1
else

return 0
end

The subroutine test can then be called from another macro:

$result = test
if $result == 1

type "It’s a girl"
end

Here are a few examples of Deko500 commands that return values:

$squareroot = sqrt 4.

sqrt returns the real value 2.

$test = file_open "moon over miami"

file_open returns 1 if Deko500 successfully opens "moon over miami", or 2 if
not.

$color = rgb 0 0 100

The rgb command creates and returns a color object that is then assigned to the
variable $color.

OBJECTS

An object is a data structure created by a command. Typical objects in Deko500
include colors, shaders, ellipses, rectangles, fonts and looks.

The elements of an object correspond exactly with the parameters of the command
that created it. Consider the rgb command, which creates a color:



Macro Programming Language 128

Deko500 User’s Guide

rgb red= green= blue=

The parameters represent the amounts (from 0 to 100) of red, blue and green that
make up the color created by the rgb command.

You can assign an object to a variable:

$yellow = rgb 100 100 0

It is not necessary to assign objects to variables before passing them to other
commands. You can specify an object parameter with an embedded command,
indicated by parentheses:

ramp top_left=(rgb 100 100 0)

You can access any element of an object with the element operator (:), to edit the
element’s value or to assign it to a variable for use elsewhere.

To edit $yellow to make it a little less green:

$yellow:green = 80.

The green level of $yellow was 100. It is now 80.

To assign the green element of $yellow to the variable $grn:

$grn = $yellow:green

To determine the data type of an object, use the objtype command:.

objtype object=

DATA TYPE CONVERSIONS

You may encounter situations in which you must convert a value of one data type to
another data type. Use the following processes to convert various types of data.

To convert an integer value to a real value:
Add the integer to 0.0 or multiply it by 1.0.

$a = 123

$b = $a*1.0

$b equals 123.0

To convert a real value to an integer value:
1. Use the command: integer

2. Deko500 truncates the real number. To round numbers accurately, add
.5 to the real number.

$a = 12.7

$b = integer $a+.5

$b equals 13

To convert a number value to a string:
Do one of the following:
� Use the command: num2str
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$a = 123.45

$b = num2str $a

$b equals "123.45"
� Concatenate a null string to the number

$a = 123.45

$b = $a%%""

$b equals "123.45"

To convert a string to its numeric equivalent:
Use the command: str2num

$a = "123"

$b = str2num $a

$b equals 123

To convert a string (up to 4 characters) to ASCII code
(integer):

Use the command: str2ascii

$a = "a"

$b = str2ascii $a

$b equals 97

To convert ASCII code (integer) to a string:
Use the command: ascii2str

$a = 97

$b = ascii2str $a

$b equals "a"

To convert an object to a string:
Use the command: obj2str

$a = @black

$b = obj2str $a

$b equals "yuv 16 0 0"
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Deko500 Options

ABOUT DEKO500 OPTIONS

Deko500 options currently available for purchase include:

Automation SportsWare

Chyron Import StillDeko

FastAction Keyboard

To see what software options are enabled on your
system:

From the Options menu, choose Enabled Options. A check mark
next to an option indicates that it is enabled on your system. The
FastAction Keyboard is a hardware option, not a software option,
so do not be concerned that it does not appear in this window.

AUTOMATION
The Automation option allows you to control Deko500 externally, in two ways:

� By any external computer, using a serial input port. You can
use macro commands to input and output arbitrary bytes and
strings.

� By a newsroom automation system, such as Basys, NewStar,
Comprompter, AP News Wire or DCM

This option also includes timecode control, which allows you to control
sequences via SMPTE timecode.

Note The Automation option is not necessary to control Deko500
externally using Grass Valley Group protocols EMEM and
PEGS.

THE AUTOMATION WINDOW

To open the Automation window:
From the View menu, select Automation.
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Automation window fields:
Automation Enabled

Enables/disables the automation interface.

Type

The automation protocol.

EMEM

The protocol used with Grass Valley Group 200 and 300
switchers.

DEKO

The protocol used for NetDeko.

PEGS

The protocol used with Grass Valley Group editors.

III

The optional protocol for using non-Deko500 commands.

ID

Identifies your Deko500. If only one Deko500 is connected to the
automation host, the ID setting is 1.

Port

The COM port or the name of the network pipe used for the
automation interface.

Status

Current connection status and message history.

Clear

Clears the data in the Status box.

To start Automation immediately every time you start
Deko500:

1. In the Automation window, check Automation Enabled.

2. In the Options Menu, select Save Settings on Exit.

AUTOMATION GRAPHICS

To use a Deko graphic with automation, you must define the graphic’s layers to
accept text data from the automation host. There are two ways a layer can accept
automation data:

Query

A query field causes the Automation interface to request
updates from the host at user-specified intervals.

Replace

A replace field gets its data from an automation (.aut) file.
When you read an .aut file, Deko500 replaces the graphic’s
replace fields with the data in the .aut file.
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To define a layer for automation:
1. Open the Automation window, de-select Automation Enabled, then

close the window.

2. Select the layer.

3. From the Layer menu, choose Properties.

4. At the bottom of the Text dialog box, click More.

5. Under Text Initialization, click the Usage text box, then do one of
the following:
� Select query, then enter an update frequency.

� Select replace.

Note For a description of other Text Initialization options, see Text
Field Properties.

The query update frequency specifies the number of seconds
between requests to the automation host for updates. If update
frequency is set to zero, the automation interface will issue the
request only once, when the file is opened.

TIMECODE CONTROL

To specify timecodes to begin and end an effect:
1. Open the sequence file.

2. In the Control column of the Sequence Window, choose tcode.

3. In the In Time column, do one of the following:
� Press Alt+Shift+I to enter the current input timecode.

� Type a timecode.

4. In the Out Time column, do one of the following:
� Press Alt+Shift+O to enter the current output timecode.

� Type a timecode.

To set intime to outtime:
1. Open the Sequence file.

2. In the Sequence Window, select the event.

3. From Timecode Menu, choose Set Intime to Outtime.

To set outtime to intime:
1. Open the Sequence file.

2. In the Sequence Window, select the event.

3. From Timecode Menu, choose Set Outtime to Intime.
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To offset in/out times:
1. Open the sequence file.

2. In the Sequence window, choose Add Offset to In/Out Times.

3. In the dialog box, enter the amount of time to add or subtract.

4. Choose whether to add or subtract the offset time, then click OK or
press Enter.

To find event closest to current output timecode:
1. Open the Sequence file.

2. From the Timecode menu, choose Find Event Closest to
Timecode.

To specify timecode settings:
1. From the Timecode menu, choose Timecode Settings.

2. Change Com Port and Drop Frame Mode settings as desired.

3. Click OK or press Enter.

DATABASE CONNECTION

The Automation option includes a dynamic feature that enables Deko500 to read
and display information from a database. This means you can set up a layer to
query a database and display the value of a field within that database.

A database query differs from Deko500’s existing query feature, which sends
inquiries to a newsroom automation system. Database queries send inquiries to
database files, which may be stored on a local system drive or accessed by a
LAN or WAN.

To use the database connection feature, you must have the ODBC driver
installed to support the database source. The ODBC driver is automatically
installed during installation and setup of your database software package. You
must also specify a data source name (DSN).

To view installed ODBC drivers:
1. Click Start at the bottom of your desktop, choose Settings, then

double-click Control Panel.

2. Double-click the ODBC icon to open the ODBC Data Source
Administrator dialog box.

3. Click the ODBC Drivers tab.
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To specify a DSN:
1. Click Start at the bottom of your desktop, choose Settings, then

double-click Control Panel.

2. Double-click the ODBC icon to open the ODBC Data Source
Administrator dialog box.

3. Click one of the following:
� User DSN

to create a data source which is visible only to you and can
only be used on the current machine.

� System DSN
to create a data source which is visible to all users on the
current machine.

� File DSN
to create a data source which allows you to connect to a data
provider and which can be shared by multiple users who have
the correct driver installed.

4. Click the Add button, select the driver for which you want to set up
a data source, then click Finish.

5. Type in a Data Source Name.

6. Click the Select button, navigate to the database file, then click
OK. Click OK two more times to close the dialog box.

To set up a layer to query a database:
1. Select the layer.

2. From the View menu, select Database to open the Database
window.

3. In the window, choose a Database Name, then check the
Connect box.

4. Choose a Table In Database.

5. Specify a record within that table, by selecting a Field Name and
entering a Field Value for that field.

6. In Display Field, choose the field whose data to display in the
layer.

7. Enter a value in the Frequency box to specify how many seconds
to wait between requests to the data source for updates. If
Frequency is set to zero, the automation interface will issue the
request only once.

8. Click Create Query.
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DATABASE WINDOW OPTIONS:
Database Name
A database name defined in the ODBC Data Source Administrator.
Connect
Connects Deko500 to the specified database.
Table In Database
A table within the database.
Field Name
The field used to identify a data record within the database.
Field Value
A value of the specified Field Name field. This can be “hard-coded” as
a specific value, or you can enter the variable, $FieldValue, then
use the Command Bar to update the value of the variable. See the topic,
To use a variable Field Value, later in this section.
Display Field
The field whose value to display in the layer.
Create Query
Associates this database query with the current layer.
Read Query
Reads query associated with the current layer into the Database
window. Select a layer that has been previously set up for database
query, then use this button to display options already specified for that
layer in the Database window.

To use a variable Field Value ($FieldValue):
1. From the View menu, select Command Bar to open the command

bar at the bottom of the desktop.

2. Click the text box on the command bar and type
$FieldValue=n (where n is the value), then click Play.

3. Set up a graphic layer to query a database, and choose
$FieldValue in the Field Value in the Database window.

CHYRON IMPORT
The Chyron Import option gives you the ability to read Chyron Infinit family
files and work with them in the Deko500 environment. The members of the
Infinite family include Maxine, Max, Winfinit, and Infinit. These files come in
two flavors:

message
Message directories contain message and RGBA files that Deko500 can read
into a Program window. These files usually refer to fonts, which you can
associate with True Type fonts for viewing and editing within Deko500.

machine
Machine directories contain logo font files that Deko500 can convert into Deko
custom typeface (.fac) files.

To open the Chyron Import window:
1. Insert the Chyron disk into the appropriate drive and close the

drive door.
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2. Activate a Program window.

3. From the View menu, choose Chyron import.

To import a Chyron message file:
1. Open the Chyron Import window.

2. Navigate to the drive and directory that contain the message file.

3. Double-click the file name to open the file in the active Program
window.

Note Once you have imported a Chyron message file, you can save
it as a Deko (.dko) file. The sample file, Chyron2.dko, is a
Chyron message file with logo fonts that was saved as a .dko
file.

To map a Chyron bitmap font onto a TrueType font:
1. Open the Chyron Import window.

2. Navigate to the drive and directory that contain the message file.

3. lick the file name to open its Font Mapping list in the window.

4. Double-click an item in the Font Mapping list to open the list of
available fonts.

5. Select a TrueType font, then click Accept to add the font to the
mapping file for the current Deko500 session.

To save the current font mapping file for future
Deko500 sessions:

1. In the Chyron Import window, click Details.

2. Click Save.

3. Enter a name for the mapping file, then click Save.

4. Click OK or press Enter. Deko500 saves the font mapping file as a
text (.txt) file.

To open a font mapping file:
1. In the Chyron Import window, click Details.

2. Click Open, then navigate to the mapping file.

3. Double-click the file name, or click Open.

4. Click OK or press Enter.

To convert a Chyron logo font into a custom typeface:
1. Open the Chyron Import window.

2. Navigate to the drive and directory that contain the machine file.
Note that the file description appears.
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3. Double-click the file name to open and import the file into a
Custom Typeface window.

4. From the File menu, choose Save Custom Typeface As.

5. Navigate to the drive and directory where you will store the file.

6. Type a new file name in the File Name text box, then click OK or
press Enter.

FASTACTION KEYBOARD
The FastAction Keyboard (FAK) enables you to perform common tasks in
Deko500 with a single keystroke. It is designed for use in real-time on-air
environments, where speed is critical. Based on a standard PC 101 keyboard, the
FAK provides additional keys for one keystroke accessibility to many of
Deko500’s functions. The FAK also provides an alphanumeric display so you
can enter or view the filename of the next graphic to be read.

An enhanced version of the standard PC keyboard, the FAK works like a
standard keyboard when using other Windows applications. It provides the
standard PC 101 keyboard layout, function keys (F1 - F12), and numeric
keypad.

The function keys can be enabled to access the functions engraved on the
keycap  (i.e., F9=Bold, etc.). The enhanced function keys mirror the text bar
functions on the Deko500 desktop.

The numeric keypad can be enabled to provide FastAction access to reading
files. You can quickly call up graphics with numerical filenames by typing the
filename on the numeric keypad. The alphanumeric display shows the filename
as it is being typed, then advances to display the next sequential file.

ENABLING THE FASTACTION KEYBOARD

To enable/disable FastAction function keys (F1 - F12):
1. From the Options menu, choose Preferences, then Common.

2. Under Keyboard click FastAction Function Keys.

1. Click OK or press Enter.

Note When the FastAction Function Key box is checked, the F1 -
F12 keys access the functions engraved on the keycaps, which
mirror Deko500 text bar functions. When the box is
unchecked, the keys function as on a standard Deko500
keyboard.

To enable the FastAction numeric keypad:
1. From the Options menu, choose Preferences, then Common.

2. Under Keyboard click Enhanced.

3. Click OK or press Enter.

Note Once enabled, the numeric keypad provides FastAction access
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to reading files.

To quickly call up graphics with numerical filenames, type the
filename on the keypad and press Read. The display shows the
filename as it is being typed, and advances to the sequential
file when you press Read.

The keyboard will display any alphanumeric filename, but
only numeric filenames can be entered on the numeric
keypad. To read in any filename, pressing Clear to clear the
display, then press Read. In the Read dialog box, type the
filename.

SPECIAL FASTACTION KEYBOARD FUNCTION KEYS

Browse Graphics

Activates/deactivates the Graphic Browser Window.

Browse Typeface

Activates/deactivates the Typeface Browser Window.

Center Row

Toggles centering on current cursor row.

Char

In conjunction with arrow keys, moves, scales, rotates, skews, or
kerns characters, depending on which tool is selected.

Clear

Clears the alphanumeric display.

Clear Preview

Does not apply to Deko500.

Clear Program

Erases the graphic in the Program window.

Cmd

Activates the macro or command bar.

Color 1 - Color 8

Selects the face shader for the current style from the first eight
preset shader chicklets.

Delete File

Deletes file open in the active window.

Font

Activates the Style/Font Window.

Help

Activates Deko500 Online Help.

Justify

Activates the Justify dialog box.
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Kern

Selects the kerning tool.

Layer

In conjunction with arrow keys moves, scales, rotates, skews or
kerns layers, depending on which tool is selected.

Learn

Turns macro learn mode on.

Look

Activates Style/Look Window.

Lower Third

Justifies text in current field as a lower third.

Macro Edit

Activates the Macro Edit layout.

Move

Selects the move tool.

Pause

Pauses sequence playback.

Pick Style

Picks up the style of the character the cursor is on.

Play

Starts a sequence playback.

Preview

Does not apply to Deko500.

Print Screen

Provided for standard PC keyboard.

Program

Activates the Program Window.

Read

Reads in the file shown in the alphanumeric display or, if the
display is cleared, activates the read dialog box. Functions as the
Enter key when Enhanced Keyboard is off.

Read Preview

Does not apply to Deko500.

Read Program

Reads the graphic whose filename appears in the alphanumeric
display into the Program window.

Redo

Undoes Undo.

Rot/Skw

Selects the Rotate/Skew tool.
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Row

In conjunction with the arrow keys, moves, scales, rotates, skews
or kerns rows, depending on which tool is selected.

Save File

Saves the file open in the active window.

Scale

Selects the Scaling tool.

Scroll Lock

Provided for standard PC keyboard.

Seq Edit

Activates the Sequence Playback layout.

Shader

Activates the current Shader Window.

Stop

Stops a sequence playback.

Style 1 - Style 8

Selects preset styles from the currently active Preset Window.

Tab Set

Sets a tab stop at the current cursor position.

Undo

Undoes changes to the current graphic, style, style presets, shader,
or sequence. If  the most recent action is not reversible, Undo is
unavailable.

SPORTSWARE
The SportsWare option includes two powerful features to enhance fast-track
character generation: Macro Autoplay and Pops.

ABOUT MACRO AUTOPLAY

Macro Autoplay automatically plays macros when they are opened. Autoplay
macros, such as the samples we’ve included, have as their first line:
#autoplay

If you have the SportsWare option, when you open one of these macros, it will
play automatically. If you want Deko500 to automatically play any macro that
you open, all you have to do is follow a one-time process to enable macro
autoplay.

To enable Macro Autoplay:
1. In the Options menu, choose Preferences.

2. In the Preferences dialog box, choose Common, then check
Automatically play macros when opened.
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3. Click OK or press Enter.

4. In the Options menu, choose Save Settings Now.

ABOUT POPS

The Pops feature allows you to create and “pop” a text selection onto an open
graphic. These text selections are saved as text files or as special graphic files,
which you can use like any other graphic file. You can even specify pop files,
including text (.txt) files, in sequences.

There are three ways to pop text onto the CG page:

text pop
pops in text only (from a .txt file) at the cursor position. Text is rendered in the
current style. For example, during a baseball game, you can pop stats into a
lower third.

style pop
pops in text and font at the cursor position. This works like a text pop, except it
renders text in the stored style associated with the pop rather than the current
style.

place pop
pops in text and style onto a specific position of the graphic, regardless of where
the cursor is. You can, for instance, pop “Final Results” in the center of an on-
air election graphic, even if the cursor is at the top of the page.

CREATING POPS

To create a text pop:
1. Open a word processing program.

2. Type the text.

3. Navigate to the drive and directory where you will store the file
and save the file as a text (.txt) file.

To create a style pop:
1. Activate a Program window.

2. Choose a preset style or create a new style for the text.

3. Type the text.

4. Select the text, not the layer.

5. Navigate to the drive and directory where you will store the file,
and type a name in the File name text box.

6. Choose Save Selection.

To create a place pop:
1. Activate a Program window.

2. Create a layer for the text or use the default layer.

3. Choose a preset style or create a new style for the text.
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4. Type the text.

5. Select the layer, not the text.

6. Navigate to the drive and directory where you will store the file,
and type a name in the File name text box.

7. Choose Save Selection.

Note When you use Save Selection to save a graphic, the Graphic
browser indicates next to the graphic file name that the
graphic is a pop file. Likewise, the File Info section of the File
Open dialog box will tell you if a file is a pop file.
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USING POPS

To pop text onto a graphic using a text pop or style
pop:

1. Open the graphic file and position the cursor or select the layer
where you will pop in the text.

2. From the File menu, choose Open (F9).

3. In the dialog box, navigate to the drive and directory containing the
text pop (.txt) or style pop (.dko) file.

4. Choose the file from the File Name list box or type it in the File
Name text box, then click OK or press Enter.

Note Deko500 pops the text into the current or selected layer of the
graphic, then automatically selects the next layer behind it. It
does not create a new layer for the pop.

To place pop text onto a graphic:
1. Open the graphic file onto which you will pop the text.

2. From the File menu, choose Open (F9).

3. In the dialog box, navigate to the drive and directory containing the
place pop (.dko) file.

4. Choose the file from the File Name list box or type it in the File
Name text box, then click OK or press Enter.

Note Deko500 creates a new layer for the place pop in front of the
current or selected layer, then automatically activates the layer
behind the previously current or selected layer..
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STILLDEKO
The StillDeko option integrates Deko500 with Lightning, Pinnacle’s high
performance, network based, image storage and management system for on-air
broadcast and production. This means you can open and edit a Lightning image
in Deko, or store Deko files in a Lightning database.

SETTING UP LIGHTNING INTEGRATION

Deko500 must be networked and the hard drive where your databases will reside
must be set up for file sharing, for StillDeko to work properly. If your Deko is
not networked or if you are unsure, check with your network administrator.

To set up file sharing on the hard drive:
1. Exit Deko500, then at the bottom left corner of the desktop, click

Start, Programs, Windows Explorer.

2. Right-click the drive where you will store Lightning databases
(probably C:), then choose Sharing.

3. Under the Sharing tab, click the New Share button.

4. Type the drive designation letter, such as c, in the
Share Name text box, then click OK twice.

To install Lightning:
1. Connect the Lightning dongle to the parallel port on the back of

your Deko. If you have any other dongle already connected,
connect the Lightning dongle to the back of the already connected
dongle.

2. Insert the Lightning CD in your Deko’s CD drive.

3. In the bottom left corner of desktop, click Start, then Run.

4. Click the Browse button and navigate to the Setup.exe file on the
Lightning CD, then click OK.

5. Follow the on-screen prompts to complete the installation. During
the installation, you will be prompted to choose Lightning or
Lightning Browse. Choose Lightning Browse.

6. Once the installation is complete, you must shut down and re-start
your Deko. From the desktop, click Start, then Shut Down, and
select Restart.

7. From the desktop, click Start, Programs, Lightning Browse.

Lightning prompts you to enter the Options Enable password.
Refer to the Important Notice, included with your Deko
documentation, for the password (which is case sensitive). Enter
the password and click OK. This will activate your enabled
Lightning options and open the Lightning Browser.
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To create and open a database:
1. Open Lightning Browse.

2. In the File menu, click Advanced, then Create New Database.

3. Enter your Deko’s System Name. If you don’t know what it is,
open the Control Panel (Start, Settings, Control Panel) and double-
click Network.

4. Enter a Name for the database.

5. Enter a Database Path,  unique to the new database, that contains
the full path name of the directory where the new database will
reside.

6. Lightning automatically enters other field values for you. Just click
Create.

 7. From the File menu, choose Open, navigate to the new
database (.pff) file, then click Open.

To set up a default database:
1. In the Lightning Browser Tree, navigate to the database, then right-

click the database name.

2. In the drop-down menu, click Set Default Database.

OPENING LIGHTNING IMAGES

To open a Lightning image from Deko:
1. In Deko, activate a graphic (Program) window.

2. From the File menu, choose Open From Lightning.

3. In the Open From Lightning dialog box, double-click the anywhere
on the image data line.

Note You can re-sort images alphanumerically by StillNum, Date,
Title, Category, User, or Memo, by clicking the appropriate
sort button.
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To use the Lightning Browser:
1. Hold Alt and use the Tab key to find Lightning, then release Alt to

open the Lightning Browser. The Lightning Browser can be set in
the View menu to display thumbnail images in several sizes; with
or without file details; and with or without the Tree, for quick
navigation to other open databases.

2. To edit an image detail other than Date, double-click the detail,
edit it, then press Enter.

3. Right-click a thumbnail image, then choose Title in the drop-down
menu to open the image in the active Deko graphic window.

Note You can drag and drop an image from the Lightning Browser
right into the Deko Program window.

CONNECTING TO A REMOTE LIGHTNING SYSTEM

To access Lightning databases on another system in your network, you must
first connect to that system. After you follow this one-time connection process,
the other system will always appear in the Lightning Browser Tree.

To connect to a remote Lightning system:
1. From Lightning’s File menu, choose Open.

2. In the Open dialog box, click Network Neighborhood.

3. Double-click the remote system name, the exported drive (usually
D), the Lightning directory, then the databse (.pff) file you wish to
open.

4. Exit and re-start Lightning.

STORING IMAGES IN A LIGHTNING DATABASE

To save a Deko graphic to a Lightning database:
1. Start Deko and open the graphic in an active Program window.

2. From the Deko File menu, choose Save To Lightning.

3. In the Save To Lightning dialog box, the default Number is the
first unused number, either within the database or at the end of the
workspace, depending on Database options set in Lightning under
Preferences. You can change this value or edit any of the file
details, which default to the details of the last saved image.

4. Click OK. The image now appears in the Lightning Browser.

Note You can drag and drop one or more images from Windows
Explorer into the Lightning Browser.
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Menus

BASELINE

Accept Baseline
Applies the baseline to the selected layer of the current graphic and
closes the Baseline Edit window.

Apply Baseline
Applies the baseline to the selected layer of the current graphic.

Bezier
Changes the selected point to a Bezier point. The section from the
previous point to this point is now a curve.

Cancel
Cancels changes to the Baseline and closes the Baseline Edit
window.

Cusp
Specifies no continuity between the Bezier curve control points on
either side of the selected point.

Delete Selected Point
Deletes the selected point from the baseline.

Draw Curve
Enables the curve drawing tool for drawing in the Baseline Edit
window.

Edit Curve
Enables the curve editing tool for changing the existing baseline in
the Baseline Edit window.

Insert Point
Activates the “insert point” mode, in which you can insert points
by clicking on the baseline where you wish to insert them.

Line to
Changes the selected point to a “line to” point. Deko500 draws a
straight line from the previous point to the line to point.

Loose Fit
Filters out “wobbles” caused by an unsteady drawing hand, for a
smoother curve.

Move to
Changes the selected point to a “move to” point. A move to point
begins a new section of the baseline.
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Next Point
Selects the next baseline point after the currently selected point.

Prev Point
Selects the baseline point previous to the currently selected point.

Reverse Baseline
Switches the beginning and end points of the baseline, so that text
travels on the opposite side of the curve and in the opposite
direction.

Smooth
Specifies C1 continuity between two Bezier curves that share the
selected point.

Symmetric
Specifies C2 continuity between two Bezier curves that share the
selected point.

Tight Fit
Specifies that Deko500 will not filter out a curve’s “wobbles”
caused by an unsteady drawing hand.

CHANNEL

Color Bars
Displays color bars in the active graphic window.

Four Field Grab
Grabs 2 frames (4 fields) from an input video source and averages
them.

Frame Grab
Grabs a frame (2 fields) from an input video source.

Keyer Freeze
Freezes input video.

Keyer Off
Turns off Deko500’s built-in keyer.

Keyer On
Turns on Deko500’s built-in keyer.

Keyer Test
Displays a test pattern in the Program window. Use this pattern to
help time Deko500’s video and key outputs at a downstream keyer
or switcher.

Keyer Thaw
Un-freezes input video.

Offline
Disables video output.

Read Next (F10)
Reads  the next graphic in the current directory into the Program
window.

Show Key Output
Shows key in the Program window.

Single Channel
Enables single-channel video output.
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EDIT

Clear All  (Alt+F8)
Clears the active Graphic or Macro.

Clear Background  (Ctrl+F8) 
Replaces the current background of the active graphic with a
transparent background.

Clear Baseline
Clears the active Baseline Edit window.

Clear Layers  (F8)
Removes all layers from the active graphic and replaces them with
a single, empty text field. Does not affect the graphic’s
background.

Clear Selected Text
Removes selected text from the active graphic.

Copy  (Ctrl+C)  Font
Copies the selected or current font to the clipboard.

Copy  (Ctrl+C)  Look
Copies the selected or current look to the clipboard.

Copy  (Ctrl+C)  Selected
Copies selected text to the clipboard.

Copy  (Ctrl+C)  Style
Copies the selected or current style to the clipboard.

Copy  (Ctrl+C)  Tabs
Copies the selected tabs to the clipboard.

Copy Color  (Ctrl+C) 
Copies the current color to the clipboard.

Copy Detail  (Ctrl+C)  
Copies the selected detail in the active Style window to the
clipboard.

Copy Events  (Ctrl+C)  
Copies selected events from the active Sequence window to the
clipboard.

Copy Shader  (Ctrl+C)  
Copies the active shader to the clipboard.

Cut  (Ctrl+X)  
Removes the selected text from a file and copies it to the clipboard.

Cut Detail  (Ctrl+X)  
Removes the selected detail from the active style and copies it to
the clipboard.
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Cut Events  (Ctrl+X)  
Removes selected events from the active Sequence window and
copies them to the clipboard.

Delete Events  (Delete)
Deletes selected events from the active Sequence window.

Find  (Ctrl+F)
Searches the active graphic or macro for a user-specified character
string.

Find Next  (Ctrl+G)
Searches the active graphic or macro for the next occurrence of a
user-specified character string. To redefine the current search
string, choose Find from the Edit menu.

Paste  (Ctrl+V)  
Inserts a copy of clipboard contents at the insertion point.

Paste Detail  (Ctrl+V)  
Inserts a cut or copied detail from the clipboard into the active
Style window.

Paste Events  (Ctrl+V)  
Inserts cut or copied events from the clipboard into the active
Sequence window.

Paste Still Names
Inserts cut or copied still names into the active Sequence window.

Redo (Ctrl+Y)
Restores changes that have been canceled using Undo.

Replace  (Ctrl+H)
Replaces an existing character string with a new character string.

Select All  (Ctrl+A)
Selects all text in all layers of the active graphic.

Select Field
Selects all text in the current field.

Select Layers
Selects all layers in the active graphic.

Select More
Activates the “select more” mode, in which you can cumulatively
select layers or characters randomly.

Select Style
Selects from the active graphic all text in the current style.

Undo  (Ctrl+Z)
Undoes changes to the current graphic, style, style presets, shader
or sequence. If the most recent action is not reversible, Undo is
grayed out.

Undo enabled
Enables Undo. See Using Undo.
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FILE

1, 2, 3, 4
Opens one of the four most recently opened files.

Append Layers  (Alt+F9)
Appends the layers in a graphic file to the active graphic.

Append to Macro
Appends a macro file to the active macro.

Append to Sequence
Appends a sequence file to the active sequence.

Change Directory
Changes the browsing directory.

Close  (Ctrl+F4)
Closes the active window.

Copy Directories
Opens a dialog box for copying directories to a different drive or
parent directory.

Copy Files
Opens a dialog box for copying files to a different directory.

Create Directory
Creates a new directory. The new directory does not automatically
become the current directory.

Delete File
Deletes a file.

Delete Selected File
Permanently erases the selected file from your computer's disk.

Exit
Closes all Deko500 windows and ends the current Deko500
session.

Import Character
Imports the graphic from the Program window into the active
Character window of the current custom typeface.

Import Character From File
Imports a file into the active Character window of the current
custom typeface.

Import Chyron
Opens the Chyron Import dialog box for reading Chyron message
files or converting Chyron machine files to Deko custom
typefaces.

Information
Provides file information, such as location, creation date and time,
for the active file.

New  (Ctrl+N)
Opens a new window.

Open  (Ctrl+O)  (F9)
Opens an existing file.

Open From Lightning
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Opens a graphic from the Lightning Browser into a Deko graphic
window.

Print  (Ctrl+P)
Prints the active graphic or macro. Print is available only if you
have installed a printer using the Windows NT Print Manager.
Refer to your Windows NT documentation for details.

Print Setup
Controls current printer settings.

Render and Save Style
Renders and saves the current style as a pre-rendered style (.sty)
file.

Replace Background  (Alt+F10)
Replaces the active graphic’s background with a user-specified
texture file.

Replace Background Key  (Alt+F10)
Replaces the active graphic’s background key with a user-specified
texture file.

Replace Layers  (Alt+F10)
Replaces the active graphic’s layers with layers from a specified
graphic (.dko) file. The background remains intact.

Revert
Re-opens the current file.

Save  (Ctrl+S)  (Alt+F12)
Saves the active file. Overwrites the previous version of the same
file.

Save As  (F12)
Saves the active file under a user-specified name. Overwrites any
existing file with the same file name.

Save To Lightning
Saves the active graphic to the current Lightning database.

HELP

About Deko500
Displays your Deko500 software version and ID numbers as well
as Deko500 copyright information.

Help Contents
Opens the Deko500 Help Window.

Tool Tips
Turns on and off Deko500’s tool tips.

Using Help
Provides instructions for using Deko500’s on-line Help.

LAYER

1,2,3,...
Selects a layer in the current graphic.

Add Ellipse  
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Adds an ellipse to the current graphic, as the frontmost layer.

Add Rectangle  
Adds a rectangle to the current graphic, as the frontmost layer.

Add Text Field  
Adds a text field to the current graphic, as the frontmost layer.

Background to Layer
Turns the background of the active graphic into a layer.

Bring Forward One Layer
Swaps the selected layer with the layer in front of it.

Bring to Front
Brings the selected layer to the frontmost position.

Clear Text
Removes all characters from the selected text layer, but leaves the
layer in the graphic.

Delete Layer
Removes the selected layer and its contents.

Edit Baseline
Activates the Baseline Edit window. See Typing on a Curve.

Layers to Background
Combines and copies all layers into the background. Original
layers remain until you clear them.

Properties
Displays the Layer Properties window. Allows a user to view or
change properties of the selected layer in the current graphic.

Select Next Layer  (Alt+Page Down)
Selects the layer behind the currently selected layer.

Select Previous Layer  (Alt+Page Up)
Selects the layer in front of the currently selected layer.

Send Back One Layer
Swaps the selected layer with the layer behind it.

Send to Back
Sends the selected layer to the backmost position.

Show Background  
Toggles the background on and off.

MACRO

Convert Graphic to Macro
Converts the current graphic into its equivalent macro. Playback of
the resulting macro recreates the graphic.

Convert Sequence to Macro
Converts the current sequence into its equivalent macro. Playback
of the resulting macro recreates the sequence.

Pause Macro  (Pause)  
Pauses or resumes playback of the currently playing macro.
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Play Macro  (Alt+F2)  
Plays the current macro.

Record Macro  (Ctrl+F2)  
Toggles the macro recorder on or off.

Stop Macro Playback  (Ctrl+Pause)  
Stops playback of the currently playing macro.

OPTIONS

Enabled Options
Provides a list of Deko500 options. Marked check boxes indicate
enabled options.

Factory Defaults
Resets Deko500 options to their original (factory default) settings.

Hardware Settings
Opens the Deko500 Hardware Settings dialog box. See Hardware
Settings.

Preferences
Allows a user to customize Deko500’s configuration. See User
Preferences.

Save Settings Now
Saves Deko500’s current settings.

Save Settings on Exit
Saves changes to Deko500 option settings automatically, every
time you exit Deko500.

Transform Coarse  (Ctrl+spacebar toggles Coarse and
Fine)
Selects coarse increment. Causes Alt+arrow keys to transform the
selected text or layer in large increments.

Transform Fine  (Ctrl+spacebar toggles Coarse and Fine)
Selects fine increment. Causes Alt+arrow keys to transform the
selected text or layer in small increments.

Transform Kerning & Leading  (Ctrl+K)  
Selects “kerning and leading” mode. In this mode, Alt+→ and
Alt+← affect the spacing between characters of selected text
(kerning), and Alt+↑ and Alt+↓  affect the spacing between rows
(leading).

Transform Move  (Ctrl+M) 
Selects “move” mode. In this mode, Alt+arrow keys moves the
selected text or layer. If no text or layer is selected,  Alt + → and
Alt + ← move all characters from the text cursor through the end
of the row, right or left. Alt + ↑  and Alt + ↓ move the cursor row
and all rows beneath it up or down.

Transform Rotate & Skew  (Ctrl+R) 
Selects “rotate and skew” mode. In this mode, Alt+↑  and Alt+↓
rotate the selected text or layer, and Alt+←  and Alt+→ skew it.
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Transform Scale & Width  (Ctrl+W)  
Selects “scale and width” mode. In this mode, Alt+↑  and
Alt+↓ scale the selected text or layer, and Alt+← and
Alt+→ change its width.

PRESETS

Pick Pick Font
Applies the font of the character to the left of the text cursor to the
current style.

Pick Pick Look
Applies the look of the character to the left of the text cursor to the
current style.

Pick Pick Presets
Assigns each of up to eight styles in the current graphic to a preset
style button.

Pick Pick Style
Applies the style of the character to the left of the text cursor to the
current style.

Preset Style Select  (Shift+F1 through Shift+F8)
Selects the current style from a list of presets. A check mark
indicates the current style.

Preset Style Set
Assigns the current style to one of eight user-specified preset
styles. A check mark indicates the current style.

Reset to Defaults
Resets the active Preset Style window to its default styles.

SEQUENCE

Auto Advance From Browser
Causes the current event to be advanced to the next event, after a
graphic file has been entered into a sequence from the browser.

Browse for Files  (Ctrl+L)
Opens the Graphic Browser window, also referred to as the
“browser”, used to add graphic (.dko) or typeface (.fac) files to a
sequence.

Clear Sequence
Removes all events from the active Sequence window.

Delete Event  (Alt+Delete)
Deletes the current event from the active sequence.

GPI Settings
Displays current GPI Trigger settings.

Insert Event  (Alt+Insert)
Inserts a blank event above the current event of the active
sequence.

Pause Sequence  (Pause)  
Pauses or resumes sequence playback.
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Playback Rate
Specifies the playback rate of the selected event in the current
sequence.

Play Sequence  (Alt+Enter)  
Sequentially performs the events in the active Sequence window.
Sequence playback begins with the current event, indicated by its
highlighted event number.

Play Sequence From Nearest Timecode (Alt+Enter)
Finds the event closest to the current timecode and sequentially
performs the events in the active Sequence window, beginning
with that event.

Smooth Roll Playback Adjustment
Specifies that Deko500 either accepts playback rates or suggests
adjustments to achieve half or full resolution rate, or full resolution
rates only.

Stop Sequence Playback  (Ctrl+Pause or Esc)  
Stops playback of the current sequence.

SHADER

Background  
Shows or hides the current graphic’s background. A check mark
means the background is currently being shown.

Background Shader
Displays the current graphic’s background shader in the Shader
window.

Edge  
Adds or removes the first edge in the current look.

Edge Shader
Displays the edge shader for the first edge in the current look. If
there is no edge in the current look, Deko500 automatically adds
one.

Face  
Adds or removes the first face in the current look.

Face Shader
Displays the face shader for the first face in the current look. If
there is no face in the current look, Deko500 automatically adds
one.

Frame  
Adds or removes the first frame in the current look.

Frame Shader
Displays the frame shader for the first frame in the current look. If
there is no frame in the current look, Deko500 automatically adds
one.

Preset Shader Select
Selects the current shader from the list of current preset shaders.
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Preset Shader Set
Assigns the current shader to a preset shader button.

Reset to Defaults
Resets the active Shader window to its default values.

Set Ramp Bottom Left Color
Deposits the current color into the bottom left corner of the current
ramp shader.

Set Ramp Bottom Right Color
Deposits the current color into the bottom right corner of the
current ramp shader.

Set Ramp Hilite Color
Deposits the current color into the current ramp shader’s highlight.

Set Ramp Top Left Color
Deposits the current color into the top left corner of the current
ramp shader.

Set Ramp Top Right Color
Deposits the current color into the top right corner of the current
ramp shader.

Set Shader Color
Deposits the current color into the current color shader.

Shadow  
Adds or removes the first shadow in the current look.

Shadow Shader
Displays the shadow shader for the first shadow in the current
look. If there is no shadow in the current look, Deko500
automatically adds one.

Underline  
Adds or removes the first underline in the current look.

Underline Shader
Displays the underline shader for the first underline in the current
look. If there is no underline in the current look, Deko500
automatically adds one.

STYLE

Pick Pick Font
Applies the font of the character to the left of the text cursor to the
current style.

Pick Pick Look
Applies the look of the character to the left of the text cursor to the
current style.

Pick Pick Presets
Assigns each of up to eight styles in the current graphic to a preset
style button.

Pick Pick Style
Applies the style of the character to the left of the text cursor to the
current style.

Preset Style Select  (Shift+F1 through Shift+F8)
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Selects the current style from a list of presets. A check mark
indicates the current style.

Preset Style Set
Assigns the current style to one of eight user-specified preset
styles. A check mark indicates the current style.

Reset to Defaults
Resets the active Style window to its default values.

TEXT

Capitalize
Changes the first character of each word of selected text to upper
case. If no text is selected, capitalizes all text in the current text
field.

Center Row
Horizontally centers the current row of text.

Exchange Down
Exchanges the current row of text with the row below it.

Exchange Up
Exchanges the current row of text with the row above it.

Horizontal Scrolling
Turns horizontal scrolling on or off for the active graphic.

Justify
Sets the justification rules for the current text field.

Lower Case
Changes every character of selected text to lower case. If no text is
selected, affects all text in the current text field.

Pick Pick Font
Applies the font of the character to the left of the text cursor to the
current style.

Pick Pick Look
Applies the look of the character to the left of the text cursor to the
current style.

Pick Pick Presets
Assigns each of up to eight styles in the current graphic to a preset
style button.

Pick Pick Style
Applies the style of the character to the left of the text cursor to the
current style.

Preset Style Select  (Shift+F1 through Shift+F8)
Selects the current style from a list of presets. A check mark
indicates the current style.

Preset Style Set
Assigns the current style to one of eight user-specified preset
styles. A check mark indicates the current style.

Tab Clear
Clears the tab stop at the cursor location in the current text field.

Tab Clear All
Clears all tab stops in the current text field.
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Tab Set
Sets a tab stop at the cursor location in the current text field.

Text to Field
Puts all selected text into a single new field.

Text to Multiple Fields
Puts each discrete group of selected text into its own new field.

Upper Case
Turns every character of selected text to upper case. If no text is
selected, affects all characters in the current text field.

Vertical Scrolling
Turns vertical scrolling on or off for the active graphic.

Word Wrap
Turns word wrap on or off. A check mark means that word wrap is
currently on.

TIMECODE

Add Offset to In/Out Times
Specifies an amount of time to add or subtract to in/out times.

Find Event Closest to Timecode
Detects which event of the open sequence is closest to the current
output timecode.

Set Intime to Current Timecode
Specifies the current output timecode in the In Time column of the
Sequence window.

Set Intime to Outtime
Copies the current  In Time timecode to the Out Time column of
the Sequence window.

Set Outtime to Current Timecode
Specifies the current output timecode in the Out Time column of
the Sequence window.

Set Outtime to Intime
Copies the current Out Time timecode to the In Time column of
the Sequence window.

Timecode Settings
Specifies the com port and drop frame mode settings for timecode
control.

VIEW

Automation
Displays or hides the Automation window, for viewing or
specifying Deko500 automation options. A check mark indicates
that the Automation window is displayed on the desktop.

Browser  (Ctrl+L = display, Alt+F4 = close)
Displays or hides the browser, used for selection of graphic (.dko)
or typeface (.fac) files. A check mark indicates that the browser is
displayed on the desktop.

Chyron Import
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Opens the Chyron Import window for reading in Chyron message
files or converting Chyron machine files into Deko custom
typefaces. A check mark indicates that the Chyron Import window
is displayed on the desktop.

Command Bar  (F4 = display)
Displays or hides the Command Bar. A check mark indicates that
the Command Bar is displayed on the desktop.

Current Style
Displays or hides the Current Style window. A check mark
indicates that the Current Style window is displayed on the
desktop.

Custom Typeface
Displays or hides the Custom Typeface window. A check mark
indicates that the Custom Typeface window is displayed on the
desktop.

Database
Displays or hides the Database window, used for specifying ODBC
automation. A check mark indicates that the Database window is
displayed on the desktop.

International
Displays or hides the International window, used for typing
characters from international character sets. A check mark
indicates that the International window is displayed on the desktop.

Macro  (F2 = display, Alt+F4 = close)
Displays or hides the Macro window. A check mark indicates that
a Macro window is displayed on the desktop.

Preset Styles  (Alt+F7 = display, Alt+F4 = close)
Displays or hides the Preset Style window. A check mark indicates
that a Preset Style window is displayed on the desktop.

Program  (Alt+F6 = display, Alt+F4 = close)
Displays or hides the Program graphic window. A check mark
indicates that the Program window is displayed on the desktop.

Sequence  (F11 = display, Alt+F4 = close)
Displays or hides the Sequence window. A check mark indicates
that the Sequence window is displayed on the desktop.

Shader  (F7 = display, Alt+F4 = close)
Displays or hides the Shader window. A check mark indicates that
the Shader window is displayed on the desktop.

Status Bar
Displays or hides the status bar. A check mark indicates that the
Status Bar is displayed on the desktop.

Stills
Displays or hides the Stills window, which contains thumbnail
images of graphics included in the current sequence. A check mark
indicates that the Stills window is displayed on the desktop.

Style  (F6 = display, Alt+F4 = close)
Displays or hides the Style window. A check mark indicates that a
Style window is displayed on the desktop.

Text Bar
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Displays or hides the text bar. A check mark indicates that the text
bar is displayed on the desktop.

Tools
Displays or hides the Tools window. A check indicates that the
Tools window is displayed on the desktop.

WINDOW

1, 2, 3...
Activates one of the currently open windows.

Auto Cascade
Toggles auto-cascade mode on and off. A check next to Auto
Cascade indicates that it is on. In auto-cascade mode, Deko500
automatically arranges windows so that windows of the same type
overlap and each title bar is visible. If you activate a window while
in auto-cascade mode, it automatically becomes the frontmost
window.

Cascade
Arranges open windows so that multiple windows of the same type
overlap and each title bar is visible. Cascade is available only when
Auto Cascade is checked in the Window menu.

Freeze Windows
Locks windows in their current position. A check next to Freeze
Windows indicates that windows are frozen. To un-freeze
windows so you can move them about on the desktop, un-check
Freeze Windows.

Reset Current Layout
Returns windows to their default positions in the current layout.

Select Layout
Lists standard desktop layouts to choose from. A check next to a
layout indicates that it is the current layout.
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Shortcut Keys

WINDOW SELECTION
Background Shader Ctrl+F7
Browser Ctrl+L
Command Bar F4
Graphic F5
Macro F2
Preset Styles Alt+F7
Program Alt+F6
Sequence F11
Shader F7
Style F6
Next Window Ctrl+Tab
Close Window Ctrl+F4

BACKGROUND AND LAYERS
Clear Layers F8
Clear Background Ctrl+F8
Clear Layers and Background Alt+F8 or F8 F8
Bring Layer Forward One Ctrl + (plus key)
Send Layer Back One Ctrl + (minus key)
Bring Layer To Front Alt + (plus key)
Send Layer To Back Alt + (minus key)
Next Layer Alt+PageUp
Previous Layer Alt+PageDown
Append Layers (Alt Read) Alt+F9
Replace Layers Alt+F10
Replace Background Ctrl+F9

CHANNEL CONTROL
Transfer and Read Next File F10
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CUT AND PASTE
Cut Ctrl+X
Copy Ctrl+C
Paste Ctrl+V

FILES
Open (Read) F9 or Ctrl+O
Save As (Record) F12
Save (Alt Record) Alt+F12 or Ctrl+S
Read Next F10
New Ctrl+N
Delete File Ctrl+Delete
Create Directory Ctrl+F12
Print Ctrl+P

FIND AND REPLACE
Find Ctrl+F
Find Next Ctrl+G
Replace Ctrl+H

FORMATTING TEXT
Bold Ctrl+B
Italic Ctrl+I
Underline Ctrl+U

JUSTIFYING TEXT
Justification Off Ctrl+NumPad0
Bottom Left Ctrl+NumPad1
Bottom Center Ctrl+NumPad2
Bottom Right Ctrl+NumPad3
Middle Left Ctrl+NumPad4
Middle Center Ctrl+NumPad5
Middle Right Ctrl+NumPad6
Top Left Ctrl+NumPad7
Top Center Ctrl+NumPad8
Top Right Ctrl+NumPad9

MACRO
Record Macro Ctrl+F2
Play Macro Alt+F2
Pause Macro Pause
Cancel Macro Playback Ctrl+Pause

MISCELLANEOUS
Help F1
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Undo Ctrl+Z
Exit Deko500 Alt+F4

PRESET STYLES
Preset Style 1 Shift+F1
Preset Style 2 Shift+F2
Preset Style 3 Shift+F3
Preset Style 4 Shift+F4
Preset Style 5 Shift+F5
Preset Style 6 Shift+F6
Preset Style 7 Shift+F7
Preset Style 8 Shift+F8

SELECTING TEXT
Select Character Shift+arrow keys
Select All Ctrl+A

SEQUENCE
Pause Sequence Pause
Cancel Sequence Ctrl+Pause
Play Sequence Alt+Enter

TRANSFORMING TEXT/LAYERS
Kerning Mode Ctrl+K
Move Mode Ctrl+M
Rotate Mode Ctrl+R
Scale/Width Mode Ctrl+W
Toggle Coarse/Fine Ctrl+spacebar
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F1 - F12 Keys

F1 F2 F3

Help Macro Swap

Shift+ Style 1 Style 2 Style 3

Alt+ Macro Play

Ctrl+ Help On Macro Record Transfer

F4 F5 F6

Cmd Graphic Style

Shift+ Style 4 Style 5 Style 6

Alt+ Exit Deko Program

Ctrl+ Close Window Pick Style

F7 F8 F9

Shader Clear Read (Open)

Shift+ Style 7 Style 8

Alt+ Preset Styles Clear All Append Layers

Ctrl+ Bgd Shader Clear Bgd Read Bgd

F10 F11 F12

Read Next Seq Record (Save As)

Shift+ Record (Save As)

Alt+ Replace Layers Style Edit Save

Ctrl+ Graphic Compose Create Directory
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Glossary

active window

The active window is the window with a highlighted (usually blue)
title bar. A window must be active for you to perform tasks in it.

To open and activate a window, choose the window type from the
View menu.

To activate a window that is already open, select it from the list at
the bottom of the Window menu, or click anywhere on the
window.

application window

In Windows NT, an application window is the window frame
surrounding the application workspace on the desktop.

Deko500’s application window is its main window, with
“Deko500” on the title bar. When Deko500 is active, this title bar
is highlighted, usually in blue (unless you’ve changed the
Windows NT color scheme).

arithmetic operator

An arithmetic operator is a symbol (+, -, *, /, %) that
performs a mathematical operation, such as addition, subtraction,
multiplication, or division, within an expression.

array

An array is a set of data values. In Deko500, elements of an array
are referenced as variables that include the array name and an
index number (which must be an integer or an expression that
returns an integer), e.g. $a[0], $a[2+3], and $a[9999].

assignment operator

The assignment operator is a symbol (=, +=, -=,etc.) that assigns a
value to a variable. For example, $a = 3.

at-sign variable

An at-sign variable, so called because its initial character is always
@, is a pre-defined global system variable that is always accessible
to commands and macros.
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Automation window

The Automation window shows automation options.

background

The background is the backmost part of a graphic. It is a full-
screen rectangle located behind the last layer, furthest from the
viewer.

The background can be turned on and off. When off, it is
transparent — live video “shows through” the background when
you use a keyer.

When the background is on, the background shader determines its
color. Like all Deko500 shaders, the background can be a solid
color, a ramp or a texture.

bitmap

A bitmap is a set of numerical values specifying the colors of the
pixels in a graphic image.

bitwise operator

A bitwise operator is a symbol (<<, >>, ~, &, |, ^) that
performs an operation on an integer value based on bit position.

C1 continuity

C1 continuity is a smoothness setting that maintains a straight line
between two connected Bezier curves. If you move one control
point, the control point on the other side of the shared point will
move in concert to maintain the linear connection.

C2 continuity

C2 continuity produces the smoothest continuity between two
connected Bezier curves. This setting maintains a straight line
between the curves, as well as equal distance from control point to
the shared point for each curve. If you move one control point, the
other one will move in concert to maintain the equidistant, linear
connection.

character set

A character set is a set of 256 characters in a TrueType or
Postscript font. A font may contain more than 256 characters, but
Windows NT can access only 256 at a time. By choosing a
character set, you are choosing which 256 characters you wish to
use.

Not all character sets are supported by every font. See Using an
International Character Set.

choice parameter

A choice parameter specifies one item from a list of possible
choices. For example, both parameters of the justify command are
choice parameters:
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justify [horizontal=] [vertical=]

Possible choices for horizontal are: left, right, center, full, spread,
off and unchanged; and for vertical: top, bottom, center, full,
baseline, off and unchanged.

click

To click the mouse, position the selection cursor over the desired
item on the screen and tap the left mouse button once.

clipboard

The clipboard is the Windows NT temporary holding area for text
or other data that has been cut or copied from a Deko500 graphic,
macro, style or sequence.

When you cut or copy a selection, it replaces any previous contents
of the clipboard.

When you paste, you are pasting the contents of the clipboard. You
can paste multiple times without re-cutting or re-copying—the
contents of the clipboard remain the same until you cut or copy
something different.

Since most Windows NT applications support the clipboard, it is
possible to cut and copy a selection from one Windows NT
application—a word processor or a spreadsheet program, for
example—and paste it into another Windows NT application.

color shader

A color shader is used to apply a solid color to a detail. You
specify the color in terms of Red, Green and Blue amounts, or in
terms of Hue, Saturation and Value. A color also has an opacity,
from 0 (transparent) to 100 percent (opaque).

command

A command is an instruction, optionally modified by parameters,
to Deko500 to perform a specific function.

command bar

The command bar allows direct entry of Deko500 commands and
macros. Press F4 to call up the command bar, type the name of a
command or macro, then press Enter or click Play. Click Close to
close the command bar.

comment

A comment is a string of text that is used to annotate a macro, but
does not affect the function of the macro.

comparison operator

A comparison operator is a symbol (==, >, >=, <, <=,
!=, !, &&, ||) that compares two values to determine whether
a specified relationship between them, such as equality, is true or
false.

If an expression is true, its value is non-zero; if false, its value is
zero.

conditional command
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A conditional command tells Deko500 to execute a block of
statements based on whether a test expression is true or false.

conditional loop command

A conditional loop command defines both a loop and the test that
determines whether to iterate or exit the loop.

control icon

Use the control icon to move, close or change the size of a
window. Click the icon to display a menu of these options.
Double-click it to close the window.

control point

A control point is the point at either end of a Bezier curve or a line
segment. In Deko500, you can move control points to change the
curvature or length of a baseline segment.

creation station

A creation station is a workstation where you can create, edit and
store graphics, but which does not contain video input/output
hardware.



Glossary 171

Deko500 User’s Guide

current directory

The current directory is the directory in which files are saved and
from which files are opened.

Deko500 maintains four different current directories based on file
types:

custom typefaces (.fac)

graphics (.dko), sequences (.seq), automation (.aut)

styles (.sty), preset styles (.pst), shaders (.shd)

macros (.mcr)

The current directories are remembered whenever you exit
Deko500, and restored when you restart Deko500.

current event

The current event of a sequence is the event you are editing or
playing back.

Deko500 indicates the current event by highlighting its event
number.

current style

The current style is based on current Font and Look settings in the
Style window. Deko500 displays the current style in the Current
Style window. Any text you type in a graphic appears in the
current style.

When text is selected, the current style becomes the style of the
first character of selected text.

When a layer is selected, the current style becomes the style of the
layer.
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Current Style window

The Current Style window shows the current style.

custom typeface

A custom typeface is a typeface made in Deko500 for typing
graphical (logo) characters.

You create a custom typeface by importing graphics and assigning
each graphic to a key. Custom Typeface characters can be typed,
positioned, scaled, and even given looks like normal TrueType
characters.

Custom Typeface window

The Custom Typeface window shows the currently open custom
typeface.

default value

A default value is the value that Deko500 uses for a parameter with
no explicitly specified value.

desktop

Desktop is the Windows NT term for everything appearing on your
computer’s color monitor — windows, icons, cursors, buttons, etc.

detail

A detail is one element of a look. It controls how a font is
rendered. There are five kinds of details: face, edge, shadow,
underline and frame.
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double-click

To double-click, move the selection cursor over the desired item
on the screen and tap the left mouse button twice in rapid
succession without moving the cursor.

drag

To drag the mouse, press and hold the left mouse button down and
move the mouse in the desired direction.

Release the mouse button to stop dragging.

element operator

An element operator (:) accesses a value that is an element of an
object.

event

An event is one element of a sequence. It describes the playback of
a single graphic file using an effect.

expression

An expression is a combination of variables, commands and
operators that results in a single value.

eyedropper

The eyedropper is a button used to pick colors from anywhere on
the desktop. It is located in the Shader window, on the color
picker.

font

A font is a typeface of specified size, shape and orientation.

frame buffer

A frame buffer is an area of computer memory that produces an
output picture, which can be viewed on a monitor.

A frame buffer consists of an array of pixels, short for “picture
elements.” Each pixel is assigned separate amounts of red, green,
blue and transparency, from 0 to 255.

The number of rows and columns of pixels determines the
resolution of the frame buffer. In NTSC, Deko500’s frame buffer
has 720 pixels in each of 486 rows. In PAL, it has 720 pixels in
each of 576 rows.

full justification

Full horizontal justification makes selected text, except any row
with a newline character (hard return), flush with the left and right
sides of the text field box.
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Full vertical justification makes the top and bottom lines of text
flush with the top and bottom of the field box.

global variable

A global variable can be shared among different macros. Global
variables remain active until explicitly deleted using the free
command or until Deko500 is exited.

glyph

The word glyph comes from the Greek “glyphe,” meaning a
pictograph or other symbolic character or sign.

In Deko500, glyphs are actual renderings of characters, in a
particular style (font and look).

Deko500 normally renders characters as you type them. For a style
with a large font or complicated look, you can increase the speed
of typing by pre-rendering the style.

graphic

A graphic is one video page of text and/or background art, created
and displayed using Deko500. A graphic is created in the Program
window and can be saved on disk as a graphic file.
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Graphic Browser window

The Graphic Browser window, also referred to as the “browser”,
shows thumbnails of all the graphics in the current directory.
Depending on how it is invoked, this window shows graphics that
will be read into Program, put into a sequence, or used as texture
shaders.

You can size and position the browser anywhere, to see as many
thumbnails as you like.

graphic file

A graphic file is a Deko500 graphic that has been saved on disk
with a file name and the ".dko" extension, for example,
"mypict.dko".

history

The history is a drop-down list of commands that have been
executed since the last time Deko500 was rebooted.

index operator

An index operator ([]) accesses a specific value from an array
variable.
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insertion point

In a text field, the insertion point is indicated by the text cursor. As
you type, Deko500 inserts each character into text at the insertion
point, and shifts the insertion point to the right.

To move the text cursor, use arrow keys (↑ → ↓ ←)  or click on a
new position.

integer parameter

An integer parameter specifies a whole number value, either
positive or negative, e.g. 3, 12967, -174, 0, etc.

if you specify a real value for an integer parameter, Deko500
ignores the fractional component of the value.

An example of an integer parameter is the number parameter of the
select style preset command, which sets the current style from the
list of preset styles:

select style preset (number =)

International window

The International window shows all the characters in the current
character set. Click any character to insert it into the active
graphic.

kerning

Kerning refers to the spacing between the characters within a
word. The higher the kerning amount, the more space between
characters. A negative kerning amount tightens the spacing
between characters.

key signal

A key signal is a black-and-white video signal that, when used
with a keyer, tells the keyer how to combine two video signals.
Deko500 outputs both a full-color video output and a black-and-
white key signal.

Let’s say you’re keying Deko500 graphics over live video from a
camera. You feed the video and key outputs from Deko500 to a
keyer (which could be Deko500’s own internal keyer), and also the
camera output. Where the key signal is white, the keyer inserts
Deko500’s output (the “fill” signal). Where the key signal is black,
the keyer inserts the camera output (the “key” signal). Where the
key signal is gray — somewhere between black and white — the
keyer mixes the Deko500 and camera outputs.

keyword

A keyword is a name used in command syntax to refer to a specific
command parameter. Every command parameter has a keyword.
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layer

A layer is one element of a Deko500 graphic. A layer is either a
text layer, a rectangle layer or an ellipse layer.

A graphic can have any number of layers. Layers are rendered
from front to back.

layout

The layout is the arrangement of windows and toolbars on the
desktop. Deko500 provides several pre-configured layouts for
composing, editing and playing back graphics and macros.

leading

Leading refers to the spacing between rows of text. The higher the
leading amount, the more space there is between rows.

“Leading” rhymes with “wedding.”

linear key signal

A linear key signal varies from black to white, including
intermediate gray shades. This is in contrast (no pun intended) to a
hard key signal, which has areas of either black or white but no
gray.

A linear key signal is required for keyed graphics to look properly
anti-aliased over background video. Your switcher must be capable
of handling linear key.

list parameter

A list parameter, also known as a repeating parameter, specifies a
list of one or more values. Depending on the command, the values
on the list may or may not be of the same type.

A command can have no more than one list parameter, which is
usually the last parameter.

local variable

A local variable is used exclusively in the current macro, and is
deleted when the macro ends. By default, user-defined variables
are local variables.

One macro cannot reference a second macro’s local variables, even
if the second macro is a subroutine of the first.

look

A look controls everything about the way a text character looks—
colors, edges, shadows, etc. A look is made up of a list of details.

loop

A loop is a section of a macro that is repeated a specified number
of times during playback.

macro

A macro is a series of Deko500 commands that can be saved in a
macro file and played back on demand. You can use the macro
recorder to record a macro, or you can edit a macro as a text file.
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macro recorder

The macro recorder is used to play macros and to record actions to
create macros.

Macro window

A Macro window is a window in which you can open and edit
Deko500 macro files.

maximize button

The maximize button appears on the right side of a window’s title
bar. Clicking this button enlarges the window to its maximum size.

menu bar

The menu bar appears near the top of Deko500’s application
window, under the title bar. Clicking on any entry brings up a pull-
down menu of commands. Click on a command to perform it.
Commands followed by an ellipsis (...) bring up an additional
window for more information to be entered.

minimize button

The minimize button appears on the right side of a title bar.

Clicking this button reduces the window to its smallest size,
usually an icon at the bottom of the screen. For example, clicking
the minimize button in Deko500’s title bar reduces Deko500 to its
application icon. To restore Deko500, double-click the icon.
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navigate

To navigate around a dialog box, use Tab and Shift+Tab to move
between fields, or click on the desired field. The up and down
arrow keys (↑↓ ) scroll through the items in a list.

Double-click a directory to select it.

Double-click a file name to open the file.

object

An object is a discrete data structure, that stores a collection of
values to be treated as a single item. An object is created by a
command and can be used by other commands as a parameter.

Typical Deko500 objects include colors, shaders, ellipses,
rectangles, boxes, fonts and looks.

object parameter

An object parameter specifies a collection of values that is treated
as a single item, i.e. an object. For example, color=(rgb 100
0 0).

Typical objects in Deko500 include colors, shaders, ellipses,
rectangles, boxes, fonts and looks.

The letter command, which adds a letter to a text field, includes
two object parameters, font and look:

letter [character=] [font=]
[look=] [tx=]

[ty=] [code=] [insert+] [-show] [-
attach]

The font parameter specifies an object created by the font
command, and the look parameter specifies an object created by
the look command.

An object is created by a command, such as font or look, and its
components correspond with the parameters of the command that
created it.

For example, the rgb object has four components, red, green, blue
and opacity. To access a component of an object, use the : operator.

operator

An operator is a symbol or other character that indicates an
operation performed on one or more values. Some examples are
the arithmetic operators, + and -, or the assignment operator, =.

optional parameter

An optional parameter always has a default value. Deko500 uses
the default value unless your command specifies a different value.

parameter

A parameter is a command modifier, and may be optional or
required.
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pin location

A character’s pin location determines how it will be placed relative
to the baseline of the current row. The Y value indicates the
baseline of the character, and the X value indicates the left edge of
the character.

pre-rendered style

A style that has been completely rendered and saved on disk. You
may pre-render a complicated style for faster typing response.

preset shader

A preset shader is a shader that has been stored in one of the 18
shader presets at the bottom of the Shader window. All 18 preset
shaders may be saved in a shader presets file.

preset style

A preset style is a style that has been saved in one of the eight
preset style buttons in the Preset Style window.

Preset Style window

The Preset Style window shows the eight preset styles in the
current Preset Style (.pst) file. Click a style to choose it for typing.
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Program window

The Program window shows the current on-air graphic. The
contents of this window match Deko500’s video output, with the
addition of a cursor, safe-title lines and other markers.

ramp shader

A ramp shader, or color gradient, is a type of Deko500 shader,
used to apply color to a detail. You specify the colors at the four
corners of the detail, and Deko500 creates the ramp by
interpolating those colors across the interior of the detail. Ramp
shaders have an optional highlight color, which produces a line
across the ramp.

real parameter

A real parameter specifies any numeric value, whole or fractional,
e.g. 3, 9, 7, -0.9, etc.

Very large or small real values can be expressed in exponent form.
accepts a real number value. For example, 2.5e-10.

An example of a real parameter is the input parameter of the sqrt
(square root) command:

sqrt input=

repeating parameter

A repeating parameter accepts a list of values, which may or may
not be of the same type.

required parameter

A required parameter has no default value. Your command must
specify a value for the parameter.

resolution

Deko500 specifies resolution in screen units, which are user-
definable in Options/Preferences/Advanced/Resolution. The
default value for screen units is 486 in NTSC and 576 in PAL.

restore button

The restore button appears on the right side of a window’s title bar.
Clicking this button restores the window to its size before it was
minimized or maximized.

right-click

To right-click, position the selection cursor over the item on the
screen and tap the right mouse button once.

safe title area

The safe title area is the area of the screen considered safe for
graphics. Anything outside this area may be clipped by an
overscanning monitor.
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The safe title area is only a reference; it does not prevent typing
outside its boundaries.

You can specify the top, bottom, right and left boundaries of the
safe title area. Values represent a percentage of the distance from
the specified edge of the screen to the opposite edge.

The text field box defaults to the dimensions of the safe title area.

screen space

Screen location is indicated on the status bar, expressed as either
world space or screen space.

World space, or resolution-independent space, is measured in
arbitrary units, selected by the user.

Screen space is a literal representation of the video frame buffer.
Screen space varies with the video standard: in NTSC 4x3, there
are 720 horizontal pizels (called dots) and 486 vertical pixels
(called lines). These values can be found in @dots and @lines.

In Options/Preferences, choose Cursor Movement by Pixels for
screen space.

screen units

Screen units are the units Deko500 uses for the height of a typeface
and for the location of text and shapes in a graphic.

Screen units are user-definable, in Options/Preferences/Advanced/
Resolution. Once you set the number of vertical units, the number
of horizontal units is automatically set to 4/3 of that amount.

For convenience, the default value for screen units is 486 in NTSC
and 576 in PAL, which equals the number of visible scan lines in
each video standard.

search path

If Deko500 does not find a file in a current directory, it searches
each directory in the appropriate search path. There are three
different search paths based on file type:

graphics (.dko), sequences (.seq), automation (.aut)

styles (.sty), preset styles (.pst), shaders (.shd)

macros (.mcr)

selection cursor

The selection cursor is used for pointing to objects on the desktop
and clicking or dragging them.

sequence

A sequence is a list of events that controls the playback of a series
of Deko500 graphic files.
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Sequence window

The Sequence window shows the current sequence.

set width

A character’s set width determines how much horizontal space the
character occupies when typed. A character’s set width plus its pin
location equals the pin location of the character to its right.

shader

The shader controls the color — solid, texture, or ramp — of a
detail or a background.
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Shader window

The Shader window shows the current face, edge, shadow,
underline, frame or background shader.

spread justification

Spread justification makes all lines of text flush with both the left
and right sides of the text field box. To do this, space is inserted
between words and between letters, as controlled by the Spread %
in the Style/Layers window.

sprite

A sprite is a smaller element within a graphic or graphic element.
For example, in a multi-row layer, each row is an individual sprite.

status bar

The status bar shows Deko500’s current status.

string

A string is set of characters, such as a word or sentence. A string
that includes spaces or non-alphanumeric characters must be
defined within quotation marks, e.g. “Hello there.”

string operator

A string operator is a command or symbol that operates on
character strings. Most string operations are performed by
commands.

string parameter

A string parameter specifies one or more alphanumeric
characters (e.g. a letter, word or sentence).

A string that contains spaces or non-alphanumeric characters must
be enclosed in quotation marks.
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style

A style consists of a font and a look.

A font is a typeface of specified size, shape and orientation.

A look controls how Deko500 renders a font character. Each look
is comprised of a list of details. Each detail is a face, edge, frame,
shadow, or underline, and has its own set of attributes which
dictate its color, size, shape, etc.

Deko500 provides a variety of tools for specifying attributes of
fonts and looks, to create new styles or to revise existing styles.

Style window

The Style window shows the current style’s font and look.

subroutine

A subroutine is a macro that is used as a command within another
macro.

switch parameter

A switch parameter specifies a parameter that is either true or false.
A true parameter is either preceded by a hyphen (-) or followed by
=1, while a false parameter is either preceded by -no or followed
by =0.
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system variable

A system variable, sometimes called an “at-sign variable” because
its initial character is always @, is a built-in global variable that is
always accessible to commands and macros.

text bar

The text bar is the toolbar at the top of the Deko500 desktop, under
the menu bar, which controls many common text functions.

text box

Text boxes are Windows NT controls in which you type or
otherwise enter information.

text cursor

The text cursor shows where in a text field the next typed character
will be inserted. The text cursor is shaped like an I-beam or a
rectangle, depending how you have your cursor preference set.

               
I - beam cursor             Box cursor

text field

A text field is one layer of text in a Deko500 graphic. A text field
is defined by its text field box, which controls word wrapping and
justification. A text field has a default style (font and look).

Characters in a text field may extend beyond the text field box.
The box is used for alignment, not clipping.

texture shader

A texture shader is used to apply a pattern to a detail. The pattern
is actually a bitmap that is “cut” from another graphic file and
“pasted” onto the detail.

title bar

The title bar is the bar at the top of any Windows NT application
window, including Deko500’s. This bar is highlighted whenever an
application is active.
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tool tips

Tool tips are those little yellow pop-up windows that appear if you
hold the selection cursor over a toolbar button for a brief moment.
They explain what each button does. You can turn tool tips on and
off from the Help menu.

Tools window

The Tools window contains several push buttons for creating,
editing and transforming text fields and layers. To show the Tools
window, choose Tools from the View menu.

Typeface Browser window

The Typeface Browser window shows you a sample of each
installed TrueType or Postscript font or each custom typeface in
the current directory. The current font is always displayed at the
top of the window. The window can be sized and positioned so that
you can see many typefaces at once.

variable

A variable is a place holder of a value that may change. A user-
defined variable always has $ as its first character. For example,
$a, $frequency, $winner.
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world space

Screen location is indicated on the status bar, expressed as either
world space or screen space.

Screen space is a literal representation of the video frame buffer,
and varies with the video standard.

World space, or resolution-independent space, is measured in
arbitrary units, selected by the user. For a 4x3 aspect ratio, the
default world space is 6.0 vertical units that range from -4 to +4
across the screen, and 8.0 horizontal units that range from -3 to +3
bottom to top. The point (0.0) is in the center of the screen.

In Options/Preferences, choose Cursor Movement by Screen Units
for world space.

You can set world space units to any convenient value. In
Options/Preferences/Advanced, enter the number of full screen
vertical units, and Deko500 derives the number of horizontal units
automatically by multiplying the height by the aspect ratio. The
current number of vertical units is  stored in the system variable
@resolution.
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Index

A
Accept Baseline command, 149
Add Ellipse command, 79, 154
Add Rectangle command, 79, 155
Add Text Field command, 76, 155
Append Layers command, 83, 153
Append to Macro command, 113, 117, 153
Append to Sequence command, 91, 153
Apply Baseline command, 149
Arithmetic operators, 123
Array

accessing elements of, 124
subscripting elements of, 123

Aspect ratio
changing, 73
opening graphic recorded under different, 17

Assignment operators, 125
At-sign variables, 123
Auto Advance From Browser command, 94, 157
Auto Cascade command, 163
Automation

defining layers for, 133–34
protocols, 133
window, 132–33

Automation command, 132, 161

B
Background, 74

activating shader for, 60
applying color to, 75
clearing from graphic, 82
opening a graphic into, 75
replacing key, 76
shader, 75
turning into a layer, 75
turning on or off, 75

Background command, 158
Background to Layer command, 155
Baseline

aligning texture with, 64
changing angle of, 24–25, 41

Baseline menu commands, 149–50
Bezier command, 149
Bitwise operators, 124
Blurring

edge, 48
face, 47
frame, 56
shadow, 51
underline, 54

Bold
applying or removing, 24
version of current typeface, 41

Break command, 127
Bring Forward One Layer command, 84, 155
Bring to Front command, 84, 155
Browse for Files command, 157
Browse Typefaces command, 22
Browser

auto advance in sequence, 157
inserting graphics into sequence, 93
texture, 62

Browser command, 22, 161

C
Cancel command, 149
Capitalize command, 26, 160
Cascade command, 163
Center Row command, 160
Channel menu commands, 150
Character

baseline angle, 24–25, 41
decimal tab, 101
importing active graphic as, 43
importing file as, 43
kerning, 27–29, 41
pin location, 44
scaling, 27–28
set width, 44
skewing, 41
spacing, 41
specifying width of, 29–30
typing from an international character set, 23
width, 29–30
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Clear, 89
Clear All command, 82, 151
Clear Background command, 75, 82, 151
Clear Layers command, 81, 82, 151
Clear Sequence command, 90, 157
Clear Text command, 33, 82, 155
Close command, 108, 153
Closing files, 108
Coarse command, 103, 156
Color

applying to detail, 60
edge, 48
eyedropper, 66
face, 46, 47
frame, 56
picking a, 66
shadow, 51
specifying, 59–66
underline, 53, 54
where graphic is transparent, 101

Color Bars command, 150
Command

categories, 118
conditional loop, 128
invoking, 111
parameters, 118–21
syntax, 118–19

Command bar, 111
Command Bar command, 162
Command command, 128
Comments, 126
Comparison operators, 124
Concatenation, 124
Conditional loop commands, 128
Conditional statements, 126–27
Continue command, 127
Convert Graphic to Macro command, 117, 155
Convert Sequence to Macro Command, 117, 155
Copy command, 33, 37, 42, 58, 69, 83, 151
Copy Detail command, 57
Copy Events command, 95
Copying

detail, 57–58
events, 95
font, 42, 69
layer, 82–83
look, 58
tab stops, 57–58
text, 30–33

Crawl, 90, 92–93
Create Directory command, 109, 153
Current style

assigning to preset button, 69
changing with text cursor, 103
picking from graphic, 70
saving as pre-rendered, 72
using a preset style as, 70

window, 68
Current Style command, 162
Cursor

box, 103
hiding, 103
i-beam, 103
movement of, 103

Cusp command, 149
Custom typeface

properties, 44
Custom Typeface command, 43, 162
Cut command, 33, 37, 83, 151
Cut Detail command, 57, 151
Cut Events command, 95, 152
Cutting and pasting

events, 95
layer, 82–83
text, 30–33

Cutting and Pasting
detail, 57–58
tab stops, 57–58

D
Data Type Conversions, 130–31
Delete command, 33
Delete Event command, 95, 157
Delete Events command, 152
Delete File command, 153
Delete Layer command, 82, 155
Delete Selected Point command, 149
Deleting

events, 95
layers, 82

Desktop
arranging layout, 99
overview of, 13
specifying preferences for, 99–105

Detail. See Look, details
Dissolve, 89
Draw Curve command, 149

E
Edge

adding or removing, 47
blurring, 48
changing attributes of, 48
changing color of, 48
hiding, 48
priority among other details, 49
shape, 48, 49–50
size, 49
type, 48

Edge command, 158
Edit Baseline command, 155
Edit Curve command, 149
Edit menu commands, 151–52
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Effects
text, 89–90
transitional, 89–90

Ellipse. See also Layer
adding to graphic, 79
defining box of, 80
hiding, 81
specifying properties of, 80–81
transforming, 80

Else command, 126–27
Elseif command, 126–27
End command, 126–28
End key, 104
Event

copying, 95
cutting and pasting, 95
deleting, 95
inserting, 95
specifying, 90–95
specifying starting, 96

Exchange Down command, 160
Exchange Up command, 160
Exit command, 11, 108, 153
Exiting

WriteDeko, 11
Expressions, 125
Eyedropper, 66

F
Face

adding or removing, 46
blurring, 47
changing attributes of, 47
changing color of, 46, 47
hiding, 47
priority among other details, 47

Face command, 158
Factory Defaults command, 100, 156
Fast Action Keyboard option, 134–42
File 1,2,3,4 command, 153
File menu commands, 153–54
Files

closing, 108
graphic, 13
missing, 101
opening, 107
prompting to save, 82
saving, 108–9, 91
sharing, 109

Find command, 34, 152
Find Event Closest to Timecode command, 135, 161
Find Next command, 152
Fine command, 103, 156
Font

as part of style, 40, 111
changing attributes of current, 40

copying, 42, 69
displaying Style/Font window, 40
installing TrueType and Postscript, 42
size, 27–28, 41
width, 41

For command, 128
Four Field Grab command, 150
Frame

adding or removing, 55
blurring, 56
changing attributes of, 56
changing color of, 56
descender characters, 57
grabbing, 20
height, 56
hiding, 56
offset, 57
priority among other details, 57
shape, 56
spaces between words, 57
width, 56

Frame command, 158
Frame Grab command, 150
Frame Grabbing

suppressing motion during, 20
Frame Shader command, 158
Free command, 123
Freeze Windows command, 68, 163
FXDeko

user interface, 111

G
Global command, 123
GPI Settings command, 157
Grabbing frames, 20
Graphic

appending to another graphic, 83
background. See Background
browsing for, 62, 93
clearing background from, 82
clearing layers from, 81
converting from different standard or format, 102
converting into Macro, 117
creating a, 14
files, 13
layers of, 73
missing, 101
Program, 13
rendering time limit, 105
saving a, 14
using as a texture, 62

Graphics Factory
exporting Halo images to WriteDeko, 19

H
Hardware settings



Glossary 193

Deko500 User’s Guide

resetting, 99–100
Hardware Settings command, 156
Home key, 104
Horizontal Scrolling command, 160
Hot Keys. See Shortcut keys

I
If command, 128
Import Character command, 43, 153
Import Character From File, 153
Index operators, 124
Insert Event command, 95, 157
Insert Point command, 149
Inserting

a detail
edge, 47
face, 46
frame, 55
shadow, 50
underline, 53

a layer
ellipse, 79
rectangle, 79
text, 76

a text field, 76
an event, 95

International
character sets, 23

International command, 23, 162
Italic

applying or removing, 24
version of current typeface, 41

J
Justify command, 35, 86, 160

K
Kerning, 27–29, 27–29, 41
Kerning & Leading command, 28, 30, 156
Keyboard

Home and End key preferences, 104
language, 23

Keyer
using built-in, 19

Keyer Off command, 150
Keyer On command, 150
Keyer Test command, 150
Keywords, 118–19

L
Layer. See also Text field, Rectangle, Ellipse
Layer 1,2,3... command, 154
Layer menu commands, 154–55
Layers

about, 73
adding to graphic, 76, 79
clearing from graphic, 81
copying, 82–83
cutting and pasting, 82–83
deleting, 82
moving, 84–86
position, 84–86
reordering, 84
rotating, 86–87
scaling, 87
selecting, 81
skewing, 88
specifying properties of, 76–79, 80–81

Layers to Background command, 155
layout

desktop, 99
Layout

initial, 101
keyboard, 23
Style Edit, 13

Layouts command, 112
Leading, 30, 41
Line to command, 149
Local variables, 123
Look

as part of style, 45
copying, 58
details. See also Face, Edge, Shadow, Underline,

Frame
adding, 46
copying, 57–58
cutting and pasting, 57–58
deleting, 46
list of, 45

displaying Style/Look window, 45
specifying, 43–58

Loops, 127–28
conditional, 128

Loose Fit command, 149
Lower Case command, 27, 160

M
Macro

appending to another macro, 112, 117
canceling, 115
converting graphic into, 117
editing, 116
invoking, 111
pausing, 114, 115
playing, 113–14
recording, 117
resuming paused, 114
saving, 116–17
single-stepping, 115
use-d as subroutine, 128–29
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viewing, 113, 117
Macro command, 113, 116, 117, 162
Macro menu commands, 155–56
Macro recorder, 111
Macro Recorder

Using the, 113
Macro window

working in, 112
Macro Window, 111
Motion

suppressing, 20
Motion Suppress command, 20
Move command, 27, 34, 84, 156
Move to command, 149
Moving

layer, 84–86
tab stops, 37
text, 34–35

N
New command, 153
Next Point command, 150

O
Objects, 129–30

accessing elements of, 124, 129–30
creating, 129

ODBC, 135
Open command, 107, 153
Opening files, 107
Opening Files

under different aspect ratio, 17
Operators, 125

arithmetic, 123
assignment, 125
bitwise, 124
comparison, 124
index, 124
order of application of, 125
string, 124

Options
Automation

Database Connection, 135
Fast Action Keyboard, 134–42
Sportsware

place pop, 144, 145
style pop, 143
text pop, 143, 145

Options menu commands, 156–57

P
Parameters, 119

categories of, 118–21
choice, 120
integer, 120

keywords of, 118–19
list, 121
object, 120
positional order of, 118–19
real, 119
string, 120
switch, 120

Paste command, 33, 38, 42, 58, 69, 83, 152
Paste Detail command, 58, 152
Paste Events command, 95, 152
Pasting. See Cutting and pasting. See Cutting and

pasting. See Cutting and pasting. See Cutting and
pasting

Pause Macro command, 114, 155
Pause Sequence command, 96, 97, 157
Pick Font command, 22, 157, 159, 160
Pick Look command, 157, 159, 160
Pick Presets command, 70, 157, 159, 160
Pick Style command, 157, 159, 160
Pinnacle Systems
how to contact. See Technical

Support
Play Macro command, 113, 115, 156
Play Sequence command, 96, 97, 158
Playback Rate command, 158
Preferences

advanced, 104–5
common, 100–101
cursor, 102–4
marker, 104
prompts, 101–2
resetting, 99–100
specifying, 99–105

Preferences command, 10, 11, 38, 82, 99, 100, 108,
156

Preset menus commands, 157
Preset Shader Select command, 158
Preset Shader Set command, 67, 159
Preset shaders

applying to detail, 67
assigning current shader to, 67
saving, 67
using, 67

Preset style. See Style. See Style
Preset Style Select command, 157, 160
Preset Style Set command, 157, 160
Preset Styles command, 69, 162
Prev Point command, 150
Print command, 154
Print Setup command, 154
Program, 13
Program command, 162
Properties command, 77, 80, 155
Push, 89
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R
Ramp. See also Shader

applying to detail, 61
background, 75
group, 61
highlighting, 61, 62
opacity, 61
scaling, 62

Reading files. See Opening files
Record Macro command, 113
Record Macro Command, 156
Recording files. See Saving files
Rectangle. See also Layer

adding to graphic, 79
defining box of, 80
hiding, 81
specifying properties of, 80–81
transforming, 80

Redo command, 152
Render and Save Style command, 72
Render and Save Style Command, 154
Replace Background command, 75, 154
Replace Background Key command, 76, 154
Replace command, 34, 152
Replace Layers command, 154
Reset Current Layout command, 163
Reset to Defaults command, 157, 159, 160
Resolution

specifying, 105
Return command, 129
Returns, 125
Reveal, 90
Reverse Baseline command, 32
Reverse Baseline Command, 150
Roll, 89, 92–93
Rotate & Skew command, 24, 25, 86, 88, 156
Rotating

layer, 86–87
text, 25, 41

Row spacing, 30, 41

S
Safe title area

defining, 104
displaying or hiding, 104

Save As command, 67, 69, 71, 91, 109, 116
Save As Command, 154
Save command, 67, 69, 71, 109, 117
Save Command, 154
Save Settings Now Command, 156
Save Settings on Exit Command, 156
Saving

a graphic, 14
a macro, 116–17
a pre-rendered style, 42, 71–72, 71–72
a sequence, 91

a style, 69
files, 108–9
preset shaders, 59, 67
prompt before, 82, 101

Scale & Width command, 27, 29, 87, 157
Scaling

layer, 87
ramp, 62
text, 27–28, 78

Screen units, 41, 77, 80, 103, 105
defined, 184

Select All command, 152
Select Field command, 152
Select Layers command, 152
Select Layout command, 113, 116, 117, 163
Select More command, 152
Select Next Layer command, 155
Select Previous Layer command, 155
Select Style command, 152
Selecting

details, 45
events, 94
layer, 81
tab stop, 37
text, 21
typeface, 22

Send Back One Layer command, 155
Send to Back command, 84, 155
Sequence

appending to another sequence, 91
creating, 90–95
effects available for, 89–90
pausing, 96
playing, 96
resuming paused, 97
saving, 91
specifying events of, 90–95
starting event of, 96
stopping, 98

Sequence command, 90, 162
Sequence menu commands, 157–58
Set Intime to Current Timecode command, 161
Set Intime to Outtime command, 134, 161
Set Outtime to Current Timecode command, 161
Set Outtime to Intime command, 134, 161
Set Ramp Bottom Left Color command, 159
Set Ramp Bottom Right Color command, 159
Set Ramp Hilite Color command, 159
Set Ramp Top Left Color command, 159
Set Ramp Top Right Color command, 159
Set Shader Color command, 159
Shader. See also Color, Ramp, Texture

activating, 60
background, 60, 75
edge, 48
face, 46, 47
frame, 56
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preset. See Preset shaders
shadow, 51
types, 59
underline, 53, 54

Shader command, 162
Shader menu commands, 158–59
Shadow

adding or removing, 50
blurring, 51
changing attributes of, 51
changing color of, 51
distance from detail, 52
hiding, 51
offset angle, 51
priority among other details, 52
shape, 52–53
type, 52

Shadow command, 159
Shortcut keys, 163–67
Show Background command, 75, 155
Show Key Output command, 19, 150
Skewing

layer, 88
text, 26, 41

Slide, 89
Small caps, 26, 41
Smooth command, 150
Software settings

resetting, 99–100
Spacing characters, 27–29, 41
Starting

Windows NT, 9–10
WriteDeko, 10

Status Bar command, 162
Stop Macro Playback command, 115, 156
Stop Sequence Playback command, 98, 158
String operators, 124
Style

assigning to preset button, 69
current. See Current style
picking up from graphic, 70
pre-rendered, 42
retrieving, 70–71
saving, 69
saving a pre-rendered, 71–72, 71–72
saving as pre-rendered, 72
saving preset, 71

Style command, 162
Style menu commands, 159–60
Subroutines, 128–29
Symmetric command, 150
System variables, 123

T
Tab Clear All command, 37, 160
Tab Clear command, 37, 160

Tab Set command, 37, 161
Tab stops, 37–38

changing the decimal tab character, 38
clearing selected, 37
clearing within a layer, 37
displaying or hiding, 38, 104
moving, 37
selecting, 37
setting, 37

Targa files
saving, 16

Technical Support
on Internet, 9

Text
changing case of, 26–27
copying, 30–33
cutting and pasting, 30–33
deleting, 33
deleting all within a layer, 33
finding and replacing, 34
initialization, 78–79
justifying, 78
kerning, 27–29, 41
leading, 30, 41
moving, 34–35
rendering time limit, 105
rotating, 24–25, 24–25
scaling, 27–28, 78
selecting, 21
skewing, 26, 41
underlining, 24

Text Bar command, 163
Text case

changing, 26–27
small caps, 26

Text field
adding to graphic, 76
hiding, 77
justifying text within, 78
specifying properties of, 76–79

Text field box
changing, 24–27
defining, 77
displaying or hiding, 104
transforming, 77

Text to Field command, 76, 161
Text to Multiple Field command, 161
Text to Multiple Fields command, 76
Texture. See also Shader

alignment, 64
applying to a detail, 62–64
background, 75
file name, 63
group, 63
offset, 63
opacity, 63

Tiff files
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saving, 16
Tight Fit command, 150
Tool Tips command, 154
Tools command, 163
TrueType and Postscript fonts

installing, 42
Typeface

installing TrueType and Postscript fonts, 42
selecting, 22

U
Underline

adding or removing, 53
blurring, 54
changing attributes of, 54
changing color of, 53, 54
height and width, 54
hiding, 54
offset, 54
priority among other details, 55
shape, 54
spaces between words, 54

Underline command, 159
Underline Shader command, 159
Underlining Text, 24
Undo command, 152
Undo enabled command, 152
Upper Case command, 26, 161

V
Variable, 121–23

assignment, 121–22, 123
data type, 121
global, 123
local, 123

subscripted, 123
system, 123
user-defined, 121

Variables, 121–23
Vertical Scrolling command, 92, 161
Video standard

changing, 73
View menu commands, 161–63

W
While command, 128
Window

clearing, 101
closing, 101
opening, 101
position on desktop, 99

Window menu commands, 163
Windows 1,2,3... command, 163
Windows NT

changing keyboard layout, 23
clipboard, 33, 43, 58, 69
File Manager, 109
installing TrueType and Postscript fonts, 42
Program Manager, 10, 11, 12, 23, 42
starting, 9–10

Wipe, 89
Word wrap, 78
Word Wrap command, 161
WriteDeko

exiting, 11, 101, 108
preconfigured layouts, 99
prompts, 82, 101–2, 108
resetting to factory defaults, 99–100
starting, 10, 101
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